summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSid Pranjale2024-02-02 22:27:34 +0530
committerSid Pranjale2024-02-02 23:01:29 +0530
commit37847ee8b143826b96f6dd83bda9275a74009d2d (patch)
treec227fddf8241ea31550aa3ccc15f2685ba79a306
parente4c3f15ae955edd9fee01d4e1474d41ba5ecabc9 (diff)
downloadaur-37847ee8b143826b96f6dd83bda9275a74009d2d.tar.gz
rewrite the PKGBUILD to follow the Arch gamescope PKGBUILD more closely
-rw-r--r--.SRCINFO63
-rw-r--r--PKGBUILD135
2 files changed, 91 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd682abcb22c..e807179c0296 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,52 +1,43 @@
pkgbase = gamescope-git
- pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.13.19.r25.g58509f0
+ pkgdesc = SteamOS session compositing window manager
+ pkgver = 3.14.0.r6.g9e46c89
pkgrel = 1
url = https://github.com/ValveSoftware/gamescope
arch = x86_64
- license = custom:BSD-2-Clause
+ license = BSD
+ makedepends = benchmark
makedepends = git
+ makedepends = glslang
makedepends = meson
makedepends = ninja
makedepends = vulkan-headers
- makedepends = glslang
makedepends = wayland-protocols
- makedepends = cmake
- depends = libavif
- depends = libxcomposite
- depends = libxtst
- depends = libxres
- depends = sdl2
- depends = pipewire
- depends = libxmu
+ depends = gcc-libs
+ depends = glibc
depends = glm
- depends = benchmark
+ depends = libcap
depends = libdrm
+ depends = libpipewire-0.3.so
+ depends = libvulkan.so
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
depends = libxkbcommon
- depends = libinput
- depends = pixman
- depends = xorg-xwayland
- depends = xcb-util-renderutil
- depends = xcb-util-wm
- depends = xcb-util-errors
- depends = seatd
+ depends = libxmu
+ depends = libxrender
+ depends = libxres
+ depends = libxtst
+ depends = libxxf86vm
+ depends = sdl2
+ depends = vulkan-icd-loader
+ depends = wayland
+ depends = xorg-server-xwayland
provides = gamescope
- provides = steamcompmgr
conflicts = gamescope
- conflicts = steamcompmgr
- source = gamescope::git+https://github.com/ValveSoftware/gamescope.git
- source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
- source = git+https://gitlab.freedesktop.org/emersion/libliftoff.git
- source = git+https://gitlab.freedesktop.org/emersion/libdisplay-info.git
- source = git+https://github.com/ValveSoftware/openvr.git
- source = git+https://github.com/Joshua-Ashton/vkroots.git
- source = git+https://github.com/nothings/stb.git
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ source = git+https://github.com/ValveSoftware/gamescope.git
+ b2sums = SKIP
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index ac77d28c275d..ca9aee50ff35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,92 +1,85 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# PKGBUILD based on the official Arch gamescope PKGBUILD
+# Maintainer - Sid Pranjale <sidpranjale127@protonmail.com>
+
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Samuel "scrufulufugus" Monson <smonson@irbash.net>
+# Contributor: PedroHLC <root@pedrohlc.com>
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.13.19.r25.g58509f0
+pkgver=3.14.0.r6.g9e46c89
pkgrel=1
-pkgdesc="Micro-compositor formerly known as steamcompmgr"
+pkgdesc='SteamOS session compositing window manager'
arch=(x86_64)
-url="https://github.com/ValveSoftware/gamescope"
-license=("custom:BSD-2-Clause")
+url=https://github.com/ValveSoftware/gamescope
+license=(BSD)
depends=(
- # gamescope
- "libavif" "libxcomposite" "libxtst" "libxres" "sdl2" "pipewire" "libxmu" "glm" "benchmark"
- # wlroots
- "libdrm" "libxkbcommon" "libinput" "pixman" "xorg-xwayland" "xcb-util-renderutil" "xcb-util-wm" "xcb-util-errors" "seatd"
+ gcc-libs
+ glibc
+ glm
+ libcap
+ libdrm
+ libpipewire-0.3.so
+ libvulkan.so
+ libx11
+ libxcb
+ libxcomposite
+ libxdamage
+ libxext
+ libxfixes
+ libxkbcommon
+ libxmu
+ libxrender
+ libxres
+ libxtst
+ libxxf86vm
+ sdl2
+ vulkan-icd-loader
+ wayland
+ xorg-server-xwayland
)
-makedepends=("git" "meson" "ninja" "vulkan-headers" "glslang" "wayland-protocols" "cmake"
+makedepends=(
+ benchmark
+ git
+ glslang
+ meson
+ ninja
+ vulkan-headers
+ wayland-protocols
)
-provides=($_pkgname "steamcompmgr")
-conflicts=($_pkgname "steamcompmgr")
-source=("$_pkgname::git+https://github.com/ValveSoftware/gamescope.git"
- "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
- "git+https://gitlab.freedesktop.org/emersion/libliftoff.git"
- "git+https://gitlab.freedesktop.org/emersion/libdisplay-info.git"
- "git+https://github.com/ValveSoftware/openvr.git"
- "git+https://github.com/Joshua-Ashton/vkroots.git"
- "git+https://github.com/nothings/stb.git")
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-
-
-pkgver() {
- cd "$srcdir/$_pkgname"
-
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=(
+ git+https://github.com/ValveSoftware/gamescope.git
+)
+b2sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
prepare() {
- cd "$srcdir/$_pkgname"
-
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- echo "Applying patch $src..."
- git apply "../$src"
- done
-
- git submodule init
- git config submodule.subprojects/wlroots.url "$srcdir/wlroots"
- git config submodule.subprojects/libliftoff.url "$srcdir/libliftoff"
- git config submodule.subprojects/libdisplay-info.url "$srcdir/libdisplay-info"
- git config submodule.subprojects/openvr.url "$srcdir/openvr"
- git config submodule.subprojects/vkroots.url "$srcdir/vkroots"
+ cd $_pkgname
+ git submodule update --init --recursive --depth=1
git -c protocol.file.allow=always submodule update
+}
- # make stb.wrap use our local clone
- sed -i "s|https://github.com/nothings/stb.git|$srcdir/stb|" "subprojects/stb.wrap"
- meson subprojects download
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_pkgname}"
-
- export LDFLAGS="$LDFLAGS -lrt"
-
- arch-meson "$srcdir/$_pkgname" build \
- --buildtype release \
- --force-fallback-for=wlroots,libliftoff,stb \
- -Dpipewire=enabled \
- -Dwlroots:backends=drm,libinput,x11 \
- -Dwlroots:renderers=gles2,vulkan
-
+ cd $_pkgname
+ meson build \
+ -Dforce_fallback_for=stb \
+ -Dpipewire=enabled
ninja -C build
}
package() {
- cd "${_pkgname}"
-
- meson install -C build --skip-subprojects --destdir "$pkgdir"
-
- cd "$srcdir/$_pkgname"
-
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ ls
+ cd $_pkgname
+ DESTDIR="${pkgdir}" meson install -C build \
+ --skip-subprojects
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/gamescope/
}
+# vim: ts=2 sw=2 et: