summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitchell Richters2022-11-12 11:35:05 +1100
committerMitchell Richters2022-11-12 11:35:05 +1100
commit3795de47d5e2a36e731abec9fa78a31c84e3dd4a (patch)
tree34ee4d5157fe92705d58ea5bf02961ac0d056557
parente31b2f1432776f19f98c4e765801ada1f0278b44 (diff)
downloadaur-3795de47d5e2a36e731abec9fa78a31c84e3dd4a.tar.gz
raze-git-1.6pre+2012+g003382654-1
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Fix-file-paths.patch87
-rw-r--r--PKGBUILD20
3 files changed, 8 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2409b97aaed9..13a32e075156 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,10 +23,8 @@ pkgbase = raze-git
provides = raze
conflicts = raze
source = Raze::git+https://github.com/coelckers/Raze
- source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = d8960cba3a0596a6e52072b9bd8f38e92d51be0315fcb53f3cb9c72da4e87081
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze-git
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
deleted file mode 100644
index 9f026a8cb274..000000000000
--- a/0001-Fix-file-paths.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
-index a28b90f01..3bd907336 100644
---- a/source/common/platform/posix/sdl/i_main.cpp
-+++ b/source/common/platform/posix/sdl/i_main.cpp
-@@ -175,19 +175,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
-- char program[PATH_MAX];
-- if (realpath (argv[0], program) == NULL)
-- strcpy (program, argv[0]);
-- char *slash = strrchr (program, '/');
-- if (slash != NULL)
-- {
-- *(slash + 1) = '\0';
-- progdir = program;
-- }
-- else
-- {
-- progdir = "./";
-- }
-+ progdir = "/usr/lib/raze/";
-
- I_StartupJoysticks();
-
-diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
-index 68e63b9c9..9ece4fe78 100644
---- a/source/core/gameconfigfile.cpp
-+++ b/source/core/gameconfigfile.cpp
-@@ -103,17 +103,11 @@ FGameConfigFile::FGameConfigFile ()
- // I assume other distributions don't do anything radically different
- SetValueForKey ("Path", "/opt/raze", true);
- SetValueForKey ("Path", "/usr/share/games/raze", true);
-- SetValueForKey ("Path", "/usr/local/share/games/raze", true);
- SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
-- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/share/games/eduke32", true);
-- SetValueForKey ("Path", "/usr/local/share/games/eduke32", true);
- SetValueForKey ("Path", "/usr/share/games/nblood", true);
-- SetValueForKey ("Path", "/usr/local/share/games/nblood", true);
- SetValueForKey("Path", "/usr/share/games/jfsw", true);
-- SetValueForKey("Path", "/usr/local/share/games/jfsw", true);
- SetValueForKey("Path", "/usr/share/games/voidsw", true);
-- SetValueForKey("Path", "/usr/local/share/games/voidsw", true);
-
- #endif
- SetValueForKey ("Path", "$STEAM", true); // also covers GOG.
-@@ -133,13 +127,10 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey ("Path", "$GAMEDIR", true);
- #else
- SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
-- SetValueForKey ("Path", SHARE_DIR, true);
-+ SetValueForKey ("Path", "/usr/share/raze", true);
- SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
-- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/share/games/eduke32", true);
-- SetValueForKey ("Path", "/usr/local/share/games/eduke32", true);
- SetValueForKey ("Path", "/usr/share/games/nblood", true);
-- SetValueForKey ("Path", "/usr/local/share/games/nblood", true);
- #endif
- }
-
-@@ -156,10 +147,7 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "$PROGDIR/soundfonts", true);
- #else
- SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/local/share/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/local/share/games/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/games/" GAME_DIR "/soundfonts", true);
-+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/soundfonts", true);
- #endif
- }
-
-diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index d70e20584..0c5322464 100644
---- a/source/core/gamecontrol.cpp
-+++ b/source/core/gamecontrol.cpp
-@@ -929,7 +929,7 @@ int RunGame()
- FString logfile = Args->TakeValue("+logfile");
-
- // As long as this engine is still in prerelease mode let's always write a log file.
-- if (logfile.IsEmpty()) logfile.Format("%s" GAMENAMELOWERCASE ".log", M_GetDocumentsPath().GetChars());
-+ if (logfile.IsEmpty()) logfile.Format("%s/" GAMENAMELOWERCASE ".log", M_GetDocumentsPath().GetChars());
-
- if (logfile.IsNotEmpty())
- {
diff --git a/PKGBUILD b/PKGBUILD
index 474c3f3ff232..31c3f687a002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Jan Cholasta <grubber at grubber cz>
+# Maintainer: Mitch Richters <mjr4077au at gmail com>
+# Contributor: Jan Cholasta <grubber at grubber cz>
pkgname=raze-git
-pkgver=1.4pre+1256+g3c54495c5
-pkgrel=2
+pkgver=1.6pre+2012+g003382654
+pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech (git version)'
arch=('x86_64')
url='https://github.com/coelckers/Raze'
@@ -24,10 +25,8 @@ optdepends=('gxmessage: crash dialog (GNOME)'
provides=('raze')
conflicts=('raze')
source=("Raze::git+https://github.com/coelckers/Raze"
- '0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- 'd8960cba3a0596a6e52072b9bd8f38e92d51be0315fcb53f3cb9c72da4e87081'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {
@@ -35,11 +34,6 @@ pkgver() {
git describe --tags | tr - +
}
-prepare() {
- cd Raze
- patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
-}
-
build() {
cd Raze
mkdir -p build
@@ -47,14 +41,16 @@ build() {
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=." \
-D DYN_GTK=OFF \
- -D DYN_OPENAL=OFF
+ -D DYN_OPENAL=OFF \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SYSTEMINSTALL=ON
make -C build
}
package() {
cd Raze
install build/raze -t "$pkgdir"/usr/bin -D
- install build/raze.pk3 -t "$pkgdir"/usr/lib/raze -D -m 644
+ install build/raze.pk3 -t "$pkgdir"/usr/share/raze -D -m 644
desktop-file-install "$srcdir"/raze.desktop --dir="$pkgdir"/usr/share/applications
install source/platform/posix/game.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/raze.xpm -D -m 644
install package/common/buildlic.txt -t "$pkgdir"/usr/share/licenses/$pkgname -D -m 644