summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-12-17 22:01:48 +0100
committerBenjamin Chrétien2013-12-17 22:02:31 +0100
commit381b3332d290e60c58f0fc31563e306d3b2d3560 (patch)
treec207ece8942fe77687345f67fa4193e3551a6ba3
downloadaur-381b3332d290e60c58f0fc31563e306d3b2d3560.tar.gz
Add ttf-pizzadude-bullets.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--ttf-pizzadude-bullets.install21
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b92e8dc63fc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-pizzadude-bullets
+ pkgdesc = A dingbats-style symbolic font that displays happy faces, stars, arrows, eyes, hearts, and more.
+ pkgver = 2.0
+ pkgrel = 2
+ url = http://www.pizzadude.dk
+ install = ttf-pizzadude-bullets.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = pizzadude_bullets.zip::http://img.dafont.com/dl/?f=pizzadude_bullets
+ md5sums = 9ecfa31321fa775367864042dc1daded
+
+pkgname = ttf-pizzadude-bullets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63083f096ff7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Julius2 <lt_a_p@yahoo.co.uk>
+# Original font design by Jakob Fischer <admin@pizzadude.dk>
+
+pkgname=ttf-pizzadude-bullets
+pkgver=2.0
+pkgrel=2
+url="http://www.pizzadude.dk"
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc="A dingbats-style symbolic font that displays happy faces, stars, arrows, eyes, hearts, and more."
+arch=('any')
+license=('custom')
+source=(pizzadude_bullets.zip::http://img.dafont.com/dl/?f=pizzadude_bullets)
+install=$pkgname.install
+md5sums=('9ecfa31321fa775367864042dc1daded')
+
+build() {
+ cd $srcdir
+ mkdir -p "${pkgdir}/usr/share/fonts/TTF"
+
+install -Dm 644 PIZZADUDEBULLETS.ttf $pkgdir/usr/share/fonts/TTF/pizzadude-bullets.ttf
+install -Dm 644 pizzadudedotdk.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+}
+
diff --git a/ttf-pizzadude-bullets.install b/ttf-pizzadude-bullets.install
new file mode 100644
index 000000000000..a98c0cdf706c
--- /dev/null
+++ b/ttf-pizzadude-bullets.install
@@ -0,0 +1,21 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*
+