summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-02-09 13:25:35 +0200
committerStelios Tsampas2023-02-09 13:25:35 +0200
commit3825881459851304dabf5936d45f6227579f93f2 (patch)
treea1a9a0a68936ac0a12afd3bcaa3133006c4660de
parentd17391b50e8b68354c1669c7cf1310f8c67e36b7 (diff)
downloadaur-3825881459851304dabf5936d45f6227579f93f2.tar.gz
[vitables] fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--PKGBUILD.live9
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 509e555cfb9a..6a82b5ca7069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = vitables
pkgdesc = A GUI browser and editor for PyTables/HDF5 files
pkgver = 3.0.2
- pkgrel = 4
+ pkgrel = 5
url = https://vitables.org
arch = any
license = GPL3
makedepends = python-sphinx
+ depends = python-build
+ depends = python-installer
+ depends = python-wheel
+ depends = python-setuptools-scm
depends = python-pyqt5
depends = python-qtpy
depends = python-pytables
diff --git a/PKGBUILD b/PKGBUILD
index c88192e26500..606fb5eb9bac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@
pkgname=vitables
pkgver=3.0.2
-pkgrel=4
+pkgrel=5
pkgdesc="A GUI browser and editor for PyTables/HDF5 files"
arch=(any)
url=https://vitables.org
license=(GPL3)
-depends=(
+depends=(python-{build,installer,wheel}
+ python-setuptools-scm
'python-pyqt5'
'python-qtpy'
'python-pytables'
@@ -31,12 +32,12 @@ prepare() {
build() {
cd ViTables-"$pkgver"
- python setup.py build
+ python -m build -wn
}
package() {
cd ViTables-"$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer -d "$pkgdir" dist/*.whl
install -d "$pkgdir"/usr/share/{applications,pixmaps,doc}
install -m644 "$srcdir"/vitables.desktop "$pkgdir"/usr/share/applications/
install -m644 "$srcdir"/vitables.svg "$pkgdir"/usr/share/pixmaps/
diff --git a/PKGBUILD.live b/PKGBUILD.live
index e1fa7eb1258e..c359c2ea203b 100644
--- a/PKGBUILD.live
+++ b/PKGBUILD.live
@@ -3,13 +3,14 @@
# Contributor: archlinux.info:tdy
pkgname=vitables
-pkgver=3.0.2.r6.gd3e6b4e
+pkgver=3.0.2.r14.g08709d4
pkgrel=1
pkgdesc="A GUI browser and editor for PyTables/HDF5 files"
arch=(any)
url=https://vitables.org
license=(GPL3)
-depends=(
+depends=(python-{build,installer,wheel}
+ python-setuptools-scm
'python-pyqt5'
'python-qtpy'
'python-pytables'
@@ -30,12 +31,12 @@ pkgver() {
build() {
cd "$pkgname"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$pkgname"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer -d "$pkgdir" dist/*.whl
install -d "$pkgdir"/usr/share/{applications,pixmaps,doc}
install -m644 "$srcdir"/vitables.desktop "$pkgdir"/usr/share/applications/
install -m644 "$srcdir"/vitables.svg "$pkgdir"/usr/share/pixmaps/