summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-08-08 14:45:22 +0000
committerDaniel Bermond2021-08-08 14:45:22 +0000
commit382cfbd43ae8fe3c32d1322cd676d03692912d98 (patch)
treeb1243370cae1d63f2a07d78daa15d9eb2f67fb42
parent1dfeac96f0db3a707a65dbd4a3984b7435362a1e (diff)
downloadaur-382cfbd43ae8fe3c32d1322cd676d03692912d98.tar.gz
Match latest upstream changes and fix build
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 545f8faf3960..7d3a1f334d94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intel-graphics-compiler-git
pkgdesc = Intel Graphics Compiler for OpenCL (git version)
- pkgver = 1.0.7181.r237.g708bc5f58
+ pkgver = 1.0.8173.r179.ga939ee8ef
pkgrel = 1
epoch = 1
url = https://github.com/intel/intel-graphics-compiler/
@@ -10,7 +10,7 @@ pkgbase = intel-graphics-compiler-git
makedepends = git
makedepends = cmake
makedepends = python
- depends = gcc-libs
+ depends = libxml2
depends = zlib
provides = intel-graphics-compiler
provides = spirv-llvm-translator
@@ -24,13 +24,12 @@ pkgbase = intel-graphics-compiler-git
source = git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_100
source = git+https://github.com/intel/opencl-clang.git#branch=ocl-open-100
source = git+https://github.com/llvm/llvm-project.git#tag=llvmorg-10.0.0
- source = git+https://github.com/intel/llvm-patches.git
- sha256sums = SKIP
+ source = 010-intel-graphics-compiler-missing-limits-header.patch::https://github.com/intel/intel-graphics-compiler/commit/8e1a461d3e6b85a6cf018caf6abf4a3ba9a1758d.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = d943a3d56ae62bde12caf133ab171777b4a73ee50a8d07449831ffc57e73e514
pkgname = intel-graphics-compiler-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 817a719a2c4a..876338640e67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=intel-graphics-compiler-git
-pkgver=1.0.7181.r237.g708bc5f58
+pkgver=1.0.8173.r179.ga939ee8ef
pkgrel=1
epoch=1
pkgdesc='Intel Graphics Compiler for OpenCL (git version)'
arch=('x86_64')
url='https://github.com/intel/intel-graphics-compiler/'
license=('MIT' 'custom')
-depends=('gcc-libs' 'zlib')
+depends=('libxml2' 'zlib')
makedepends=('git' 'cmake' 'python')
provides=('intel-graphics-compiler' 'spirv-llvm-translator' 'intel-opencl-clang')
conflicts=('intel-graphics-compiler' 'spirv-llvm-translator' 'intel-opencl-clang')
@@ -18,19 +18,20 @@ source=('git+https://github.com/intel/intel-graphics-compiler.git'
'git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_100'
'git+https://github.com/intel/opencl-clang.git#branch=ocl-open-100'
'git+https://github.com/llvm/llvm-project.git#tag=llvmorg-10.0.0'
- 'git+https://github.com/intel/llvm-patches.git')
+ '010-intel-graphics-compiler-missing-limits-header.patch'::'https://github.com/intel/intel-graphics-compiler/commit/8e1a461d3e6b85a6cf018caf6abf4a3ba9a1758d.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'd943a3d56ae62bde12caf133ab171777b4a73ee50a8d07449831ffc57e73e514')
prepare() {
ln -sf intel-graphics-compiler igc
ln -sf ../../../SPIRV-LLVM-Translator llvm-project/llvm/projects/llvm-spirv
ln -sf ../../../opencl-clang llvm-project/llvm/projects/opencl-clang
- ln -sf llvm-patches llvm_patches
+
+ patch -d intel-graphics-compiler -Np1 -i "${srcdir}/010-intel-graphics-compiler-missing-limits-header.patch"
}
pkgver() {
@@ -56,7 +57,6 @@ package() {
# additional files for spirv-llvm-translator and opencl-clang
cp -dr --no-preserve='ownership' build/IGC/VectorCompiler/spirv-install/include/LLVMSPIRVLib "${pkgdir}/usr/include"
- install -D -m644 build/IGC/VectorCompiler/spirv-install/lib/libSPIRVDLL.so -t "${pkgdir}/usr/lib"
install -D -m644 build/IGC/VectorCompiler/spirv-install/lib/pkgconfig/*.pc -t "${pkgdir}/usr/lib/pkgconfig"
install -D -m644 build/IGC/llvm-deps/src/llvm/projects/opencl-clang/common_clang.h -t "${pkgdir}/usr/include/cclang"
install -D -m644 SPIRV-LLVM-Translator/LICENSE.TXT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-spirv-llvm-translator"