summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-07-24 17:51:34 -0700
committerChristian Bundy2018-07-24 17:51:34 -0700
commit385340f1647044b66cdef0e702a0e2dc8f985c9c (patch)
tree06e2a79a6dafd6326ef597a4b10c0f81ead40679
parent5a7e3557a3e14a9f51a69706b103c38c5d757293 (diff)
downloadaur-385340f1647044b66cdef0e702a0e2dc8f985c9c.tar.gz
Transition to patchbay-git
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
-rw-r--r--run.sh2
3 files changed, 37 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e3778b478d7..77f88675f295 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = patchbay
+pkgbase = patchbay-git
pkgdesc = An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork
- pkgver = 7.13.1
+ pkgver = 7.13.1.r182.g68110fd
pkgrel = 1
url = https://github.com/ssbc/patchbay
arch = i686
@@ -13,13 +13,15 @@ pkgbase = patchbay
depends = gconf
depends = python
depends = lib32-gcc-libs
+ provides = patchbay
+ conflicts = patchbay
options = !strip
- source = https://github.com/ssbc/patchbay/archive/v7.13.1.tar.gz
+ source = git+https://github.com/ssbc/patchbay.git
source = run.sh
source = patchbay.desktop
- md5sums = 6ad303f916136ac12d53e1058be25798
+ md5sums = SKIP
md5sums = fae47b2d8539295743f7946ea07393c4
md5sums = f459479fef0987c5fa81a38b04767ffa
-pkgname = patchbay
+pkgname = patchbay-git
diff --git a/PKGBUILD b/PKGBUILD
index 114df9e43ae1..a408214e772e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,53 @@
-# Maintainer: Christian Bundy <christianbundy@fraction.io>
-
-pkgname=patchbay
-pkgver=7.13.1
+# Maintainer: Christian Bundy <christianbundy@fraction.io>
+pkgname=patchbay-git
+pkgver=7.13.1.r182.g68110fd
pkgrel=1
pkgdesc="An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork "
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchbay"
license=('MIT')
+provides=('patchbay')
+conflicts=('patchbay')
depends=('libsodium' 'gtk2' 'gconf' 'python' 'lib32-gcc-libs')
makedepends=('nodejs' 'npm')
options=(!strip)
+_srcname=patchbay
+
source=(
-"https://github.com/ssbc/${pkgname}/archive/v${pkgver}.tar.gz"
+"git+https://github.com/ssbc/${_srcname}.git"
'run.sh'
-"${pkgname}.desktop"
+"${_srcname}.desktop"
)
-md5sums=('6ad303f916136ac12d53e1058be25798'
- 'fae47b2d8539295743f7946ea07393c4'
+md5sums=('SKIP'
+ '6632351cad7b33d94834e9a37f77f727'
'f459479fef0987c5fa81a38b04767ffa')
+pkgver() {
+ cd "${_srcname}"
+
+ # https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=linux-git&id=e03e86d03543561336930472671ffa3e8b8e8cbd#n34
+ git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_srcname}"
+
+ # https://github.com/ssbc/patchbay/issues/211
+ npm install --save git://github.com/Happy0/ssb-chess#master
+ npm audit fix
+
npm ci
+ npm run rebuild
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_srcname}"
install -d "${pkgdir}/opt/${pkgname}"
cp -a * "${pkgdir}/opt/${pkgname}"
- install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+ install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${_srcname}.png"
cd "${srcdir}"
- install -D run.sh "${pkgdir}/usr/bin/${pkgname}"
- install -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D run.sh "${pkgdir}/usr/bin/${_srcname}"
+ install -D "${_srcname}.desktop" "${pkgdir}/usr/share/applications/${_srcname}.desktop"
}
diff --git a/run.sh b/run.sh
index 8566be80b2b9..2ba70b411f38 100644
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-cd /opt/patchbay
+cd /opt/patchbay-git
./node_modules/.bin/electron index.js "$@"