summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2018-01-19 12:54:31 +0100
committerxsmile2018-01-19 12:54:31 +0100
commit388c8b591a12c024bb93bda23a48ccb49e043978 (patch)
tree805652b0b067b7cb27416dd272074487d726c1aa
downloadaur-388c8b591a12c024bb93bda23a48ccb49e043978.tar.gz
3.11.2.4
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD34
-rw-r--r--myetherwallet3
-rw-r--r--myetherwallet.desktop7
6 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfe2ce0b34de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = myetherwallet
+ pkgdesc = Free, open-source, client-side tool for easily & securely interacting with the Ethereum network
+ pkgver = 3.11.2.4
+ pkgrel = 1
+ url = https://github.com/kvhnuke/etherwallet
+ arch = any
+ license = MIT
+ depends = xdg-utils
+ source = https://github.com/kvhnuke/etherwallet/releases/download/v3.11.2.4/etherwallet-v3.11.2.4.zip
+ source = myetherwallet.desktop
+ source = myetherwallet
+ source = LICENSE
+ md5sums = 31a387d5601eec30190b7b8cc834987e
+ md5sums = 7ede310a5ce49d1e13aaafdf486324d2
+ md5sums = 812af8159b21a3895a9dd5ed6621c912
+ md5sums = 1d90c6c90650a922d22d50bdc0194e89
+
+pkgname = myetherwallet
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3b46996519c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.zip
+*.tar*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2f43cb654b6a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (C) 2015-2017 MyEtherWallet LLC
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab5b085cd399
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: xsmile <sascha_r gmx de>
+
+pkgname=myetherwallet
+pkgver=3.11.2.4
+pkgrel=1
+pkgdesc='Free, open-source, client-side tool for easily & securely interacting with the Ethereum network'
+arch=('any')
+depends=('xdg-utils')
+url='https://github.com/kvhnuke/etherwallet'
+license=('MIT')
+source=("$url/releases/download/v$pkgver/etherwallet-v$pkgver.zip"
+ 'myetherwallet.desktop'
+ 'myetherwallet'
+ 'LICENSE')
+md5sums=('31a387d5601eec30190b7b8cc834987e'
+ '7ede310a5ce49d1e13aaafdf486324d2'
+ '812af8159b21a3895a9dd5ed6621c912'
+ '1d90c6c90650a922d22d50bdc0194e89')
+
+package() {
+ cd "$srcdir/etherwallet-v$pkgver"
+
+ # Lib directory
+ install -d "$pkgdir/opt/$pkgname"
+ cp -a css fonts images js *.html "$pkgdir/opt/$pkgname"
+ # Executable
+ install -Dm755 "$srcdir/$pkgname" -t "$pkgdir/usr/bin"
+
+ # License
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+ # Menu entry
+ install -Dm644 "$srcdir/$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "images/fav/android-chrome-192x192.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/myetherwallet b/myetherwallet
new file mode 100644
index 000000000000..ea01a610915e
--- /dev/null
+++ b/myetherwallet
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+libdir=/opt/myetherwallet
+xdg-open "$libdir/index.html"
diff --git a/myetherwallet.desktop b/myetherwallet.desktop
new file mode 100644
index 000000000000..0c1eb30d4d6f
--- /dev/null
+++ b/myetherwallet.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=MyEtherWallet
+Comment=Free, open-source, client-side tool for easily & securely interacting with the Ethereum network
+Icon=myetherwallet
+Exec=myetherwallet
+Categories=Network;