summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Brandt2018-04-02 13:05:16 +0200
committerStephen Brandt2018-04-02 13:05:16 +0200
commit38d50b103a8582278205c0220f693106c812fceb (patch)
treecb055eb2749c48dbda416d40ffdff4fccbec7dbc
downloadaur-38d50b103a8582278205c0220f693106c812fceb.tar.gz
Add .SRCINFO and PKGBUILD
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD35
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba541e224f58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = haguichi-git
+ pkgdesc = Provides a user friendly GUI to control the Hamachi client on Linux (development version)
+ pkgver = r320.0a59e37
+ pkgrel = 1
+ url = https://github.com/ztefn/haguichi
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = logmein-hamachi
+ provides = haguichi
+ conflicts = haguichi
+ replaces = haguichi-bzr
+ replaces = haguichi-indicator-bzr
+ source = git+https://github.com/ztefn/haguichi
+ sha512sums = SKIP
+
+pkgname = haguichi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde97cec0db2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Stephen Brandt <stephen@stephenbrandt.com>
+
+pkgname=haguichi-git
+pkgver=r320.0a59e37
+pkgrel=1
+pkgdesc="Provides a user friendly GUI to control the Hamachi client on Linux (development version)"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/ztefn/haguichi"
+license=('GPL3')
+depends=('gtk3' 'libappindicator-gtk3' 'libnotify' 'logmein-hamachi')
+makedepends=('git' 'meson' 'vala')
+conflicts=('haguichi')
+provides=('haguichi')
+replaces=('haguichi-bzr' 'haguichi-indicator-bzr')
+source=("git+$url")
+sha512sums=('SKIP')
+_pkg=haguichi
+
+pkgver() {
+ cd $_pkg
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkg
+ rm -rf build
+ mkdir build && cd build
+
+ meson -Denable-appindicator=true ..
+ ninja
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C $_pkg/build install
+}