summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-04-22 18:25:51 +0200
committerChristopher Arndt2020-04-24 23:03:58 +0200
commit38d9ecf602965ae7e15cb3c0999cf4f08cf5f659 (patch)
tree27f2420091e25d51208d5c3320c3d054d2175cc4
parentc0fbc515cff758b83421e898ee03f158c9428580 (diff)
downloadaur-38d9ecf602965ae7e15cb3c0999cf4f08cf5f659.tar.gz
Adapt to upstream changes and update dependencies
* Run waf with Python 3 and drop 'python2' from makedepends * Add 'libwebsockets' and 'cwiid' to makedepends and optdepends * Add git ignore file
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e03ce77bc93..bac8133c9a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,34 @@
-# Generated by mksrcinfo v8
-# Sun Jan 12 18:27:49 UTC 2020
pkgbase = ardour-git
pkgdesc = A multichannel hard disk recorder and digital audio workstation
- pkgver = 6.0.pre0.r3201.gc87bec07cd
+ pkgver = 6.0.rc1.r45.gfcfaa0ac49
pkgrel = 1
url = http://ardour.org/
arch = i686
arch = x86_64
groups = pro-audio
license = GPL
- makedepends = git
- makedepends = python2
makedepends = boost
makedepends = cppunit
+ makedepends = cwiid
makedepends = doxygen
+ makedepends = git
makedepends = graphviz
makedepends = itstool
makedepends = lv2
+ makedepends = libwebsockets
depends = alsa-lib
depends = aubio
depends = gtkmm
+ depends = libarchive
depends = liblo
depends = liblrdf
depends = lilv
- depends = suil
+ depends = python
depends = rubberband
+ depends = suil
depends = taglib
- depends = libarchive
- depends = python
+ optdepends = cwiid: Wiimote control support
+ optdepends = libwebsockets: WebSockets control support
provides = ardour
conflicts = ardour
source = ardour::git://github.com/Ardour/ardour.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b79ce49d342f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+ardour/
+ardour-git-*.pkg.tar.xz
+ardour-git-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index d09de1e03dff..20649a7a7c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
-# Maintainer: Gimmeapill <gimmeapill@gmail.com>
+# Maintainer: Gimmeapill <gimmeapill at gmail.com>
# Contributor: Boohbah <boohbah at gmail.com>
# Contributor: SpepS <dreamspepser at yahoo.it>
# Contributor: Bernardo Barros <bernardobarros at gmail.com>
# Contributor: Uli Armbruster <uli_armbruster at web.de>
-# Contributor: Christopher Arndt <chris at chrisarndt.de>
+# Contributor: Christopher Arndt <aur at chrisarndt.de>
pkgname=ardour-git
-pkgver=6.0.pre0.r3201.gc87bec07cd
+pkgver=6.0.rc1.r45.gfcfaa0ac49
pkgrel=1
pkgdesc="A multichannel hard disk recorder and digital audio workstation"
arch=('i686' 'x86_64')
url="http://ardour.org/"
license=('GPL')
groups=('pro-audio')
-depends=('alsa-lib' 'aubio' 'gtkmm' 'liblo' 'liblrdf' 'lilv' 'suil' 'rubberband' 'taglib' 'libarchive' 'python')
-makedepends=('git' 'python2' 'boost' 'cppunit' 'doxygen' 'graphviz' 'itstool' 'lv2')
+depends=('alsa-lib' 'aubio' 'gtkmm' 'libarchive' 'liblo' 'liblrdf' 'lilv'
+ 'python' 'rubberband' 'suil' 'taglib')
+makedepends=('boost' 'cppunit' 'cwiid' 'doxygen' 'git' 'graphviz' 'itstool'
+ 'lv2' 'libwebsockets')
+optdepends=('cwiid: Wiimote control support'
+ 'libwebsockets: WebSockets control support')
provides=('ardour')
conflicts=('ardour')
source=("${pkgname%-*}::git://github.com/Ardour/ardour.git"
@@ -30,7 +34,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-*}"
- python2 waf configure --prefix=/usr \
+ python waf configure --prefix=/usr \
--configdir=/etc \
--with-backends=jack,alsa,dummy \
--libjack=weak \
@@ -40,13 +44,13 @@ build() {
--ptformat \
--no-phone-home
- python2 waf build $MAKEFLAGS
+ python waf build $MAKEFLAGS
}
package() {
cd "${srcdir}/${pkgname%-*}"
- python2 waf --destdir="${pkgdir}" install
+ python waf --destdir="${pkgdir}" install
# Install freedesktop.org compatible application starter desktop file
install -Dm644 "${srcdir}/ardour.desktop" \