summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-08-19 23:52:22 +0200
committerLukáš Jirkovský2016-08-19 23:52:22 +0200
commit38f5fc898238bf7a6fb0babc36d429e7e7a8f8e3 (patch)
tree42fcd0c38687b270df7496b43c6b72f8e3825522
downloadaur-38f5fc898238bf7a6fb0babc36d429e7e7a8f8e3.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--trace_sched_build_fix.diff12
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..443f6690c440
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Aug 19 21:52:22 UTC 2016
+pkgbase = linux-test-project
+ pkgdesc = A collection of tools for testing the Linux kernel and related features
+ pkgver = 20160510
+ pkgrel = 1
+ url = http://linux-test-project.github.io/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = acl
+ depends = bash
+ depends = gawk
+ depends = libcap
+ depends = libtirpc
+ depends = python2
+ source = https://github.com/linux-test-project/ltp/releases/download/20160510/ltp-full-20160510.tar.bz2
+ source = trace_sched_build_fix.diff
+ md5sums = baa738d00b53d734c0515b2979a9577e
+ md5sums = 852a73b5614df7ab6dbf6293136512de
+
+pkgname = linux-test-project
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c97dd3f3477
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=linux-test-project
+pkgver=20160510
+pkgrel=1
+pkgdesc="A collection of tools for testing the Linux kernel and related features"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://linux-test-project.github.io/"
+depends=('acl' 'bash' 'gawk' 'libcap' 'libtirpc' 'python2')
+source=("https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.bz2"
+ "trace_sched_build_fix.diff")
+md5sums=('baa738d00b53d734c0515b2979a9577e'
+ '852a73b5614df7ab6dbf6293136512de')
+
+prepare() {
+ cd "$srcdir/ltp-full-$pkgver"
+
+ # fix compilation
+ patch -Np1 < "$srcdir/trace_sched_build_fix.diff"
+ # fix python scripts
+ find . -type f -exec sed -i 's|^#!.*python$|#!/usr/bin/env python2|' '{}' ';'
+}
+
+build() {
+ cd "$srcdir/ltp-full-$pkgver"
+
+ ./configure --mandir=/usr/share/man --with-bash
+ make all
+}
+
+package() {
+ cd "$srcdir/ltp-full-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/trace_sched_build_fix.diff b/trace_sched_build_fix.diff
new file mode 100644
index 000000000000..b90006dded8d
--- /dev/null
+++ b/trace_sched_build_fix.diff
@@ -0,0 +1,12 @@
+diff -rup ltp-full-20160510/testcases/kernel/sched/tool/trace_sched.c ltp-full-20160510.new/testcases/kernel/sched/tool/trace_sched.c
+--- ltp-full-20160510/testcases/kernel/sched/tool/trace_sched.c 2016-05-10 14:29:54.000000000 +0200
++++ ltp-full-20160510.new/testcases/kernel/sched/tool/trace_sched.c 2016-08-19 22:11:24.689699756 +0200
+@@ -422,7 +422,7 @@ int main(int argc, /* number of input p
+ if (status == (thread_sched_t *) - 1) {
+ fprintf(stderr,
+ "thread [%d] - process exited with errors %d\n",
+- thrd_ndx, WEXITSTATUS(status));
++ thrd_ndx, WEXITSTATUS((int)status));
+ exit(-1);
+ } else {
+ exp_prio[thrd_ndx] = status->exp_prio;