summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Peters2017-08-07 17:02:20 +0200
committerBert Peters2017-08-07 17:06:12 +0200
commit3929de850e19eaeedc4517220518c8f70e5bc071 (patch)
tree86c49495a8824d575511991ca9856be3cf67073b
parent0a584b0ec0be5735bb40371e079f0c0be5d90443 (diff)
downloadaur-3929de850e19eaeedc4517220518c8f70e5bc071.tar.gz
Update to 4.2.7.
With this version, I moved all library fixes from the main package to this one, since most problems are in this package anyway.
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD52
3 files changed, 84 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afb87586a93b..9eb9afc2e96c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 27 01:51:29 UTC 2017
pkgbase = ruby-gollum-lib
- pkgdesc = A simple, Git-powered wiki.
- pkgver = 4.2.2
+ pkgdesc = A simple, Git-powered wiki, external library dependencies.
+ pkgver = 4.2.7
pkgrel = 1
url = http://github.com/gollum/gollum-lib
arch = any
@@ -15,10 +13,42 @@ pkgbase = ruby-gollum-lib
depends = ruby-sanitize
depends = ruby-github-markup
depends = ruby-gemojione
- noextract = gollum-lib-4.2.2.gem
+ provides = ruby-gollum-grit_adapter=1.0.1
+ provides = ruby-mini_portile2=2.1.0
+ provides = ruby-sanitize=2.1.0
+ provides = ruby-github-markup=1.6.1
+ provides = ruby-kramdown=1.9.0
+ provides = ruby-rack=1.6.8
+ provides = ruby-mustache=0.99.8
+ provides = ruby-useragent=0.16.8
+ noextract = gollum-lib-4.2.7.gem
+ noextract = gollum-grit_adapter-1.0.1.gem
+ noextract = mini_portile2-2.1.0.gem
+ noextract = sanitize-2.1.0.gem
+ noextract = github-markup-1.6.1.gem
+ noextract = kramdown-1.9.0.gem
+ noextract = rack-1.6.8.gem
+ noextract = mustache-0.99.8.gem
+ noextract = useragent-0.16.8.gem
options = !emptydirs
- source = https://rubygems.org/downloads/gollum-lib-4.2.2.gem
- sha1sums = 131999c2587f77bdb16eadb84fea854942b78f82
+ source = https://rubygems.org/downloads/gollum-lib-4.2.7.gem
+ source = https://rubygems.org/downloads/gollum-grit_adapter-1.0.1.gem
+ source = https://rubygems.org/downloads/mini_portile2-2.1.0.gem
+ source = https://rubygems.org/downloads/sanitize-2.1.0.gem
+ source = https://rubygems.org/downloads/github-markup-1.6.1.gem
+ source = https://rubygems.org/downloads/kramdown-1.9.0.gem
+ source = https://rubygems.org/downloads/rack-1.6.8.gem
+ source = https://rubygems.org/downloads/mustache-0.99.8.gem
+ source = https://rubygems.org/downloads/useragent-0.16.8.gem
+ sha256sums = d809bff03538ec4526845350b175aec099664654e4084cb8a90217e9e4e634ba
+ sha256sums = 8b644bac7bd10f38b7944c324263b3f6d4506a0571e6221d604e853d4c5d9139
+ sha256sums = 0b0e83fe0fc190640a93c48cef0c8e1f1f40f77840d82c160fefc1b07a5345f8
+ sha256sums = c3be075f5b38a1b02404be5778b181e50fba9ab253bac851cb217d9a71375b77
+ sha256sums = 38828ee5b49a2f645919d08fc4b6bdd888500117251f6b50c4e52726264bcbdb
+ sha256sums = e00ef90f083f845118577dd6a040b4a4aa475bd7a2a645b2ad6944da0555598b
+ sha256sums = eae37ccb7686b2c672f64bc6be366cfda4d828ea58e1086cb82766b17a54a7a6
+ sha256sums = 826a96db895819c13fffa4fa3c20b85e80b60aaec1f28f79e7db80092abdb0bc
+ sha256sums = 18e23793f52862597576757bb61e9ecae329a50a6826c4190e1386edb1646984
pkgname = ruby-gollum-lib
diff --git a/.gitignore b/.gitignore
index 32f0ae164510..8e89e1ea6018 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src/
pkg/
*.tar.gz
*.tar.xz
+*.gem
diff --git a/PKGBUILD b/PKGBUILD
index a88dc900757b..1f3be883ee70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
-# Maintainer: Grey Christoforo <grey@christoforo.net>
+# Maintainer: Bert Peters <bert@bertptrs.nl>
_gemname=gollum-lib
pkgname=ruby-$_gemname
-pkgver=4.2.2
+pkgver=4.2.7
pkgrel=1
-pkgdesc='A simple, Git-powered wiki.'
+pkgdesc='A simple, Git-powered wiki, external library dependencies.'
arch=(any)
url='http://github.com/gollum/gollum-lib'
license=(MIT)
@@ -13,11 +13,51 @@ depends=(ruby ruby-gollum-grit_adapter ruby-rouge ruby-nokogiri ruby-stringex ru
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha1sums=('131999c2587f77bdb16eadb84fea854942b78f82')
+provides=()
+
+# The following section contains a hack to add quite a few packages without repeating myself too often.
+# This should be removed once dependency hell is fixed.
+
+_packagefixes=(
+'gollum-grit_adapter=1.0.1'
+'mini_portile2=2.1.0'
+'sanitize=2.1.0'
+'github-markup=1.6.1'
+'kramdown=1.9.0'
+'rack=1.6.8'
+'mustache=0.99.8'
+'useragent=0.16.8'
+)
+
+for _buggeddep in ${_packagefixes[@]}; do
+ _buggedgem=$(echo $_buggeddep | cut -d '=' -f 1)
+ _buggedver=$(echo $_buggeddep | cut -d '=' -f 2)
+
+ source+=("https://rubygems.org/downloads/$_buggedgem-$_buggedver.gem")
+ noextract+=("$_buggedgem-$_buggedver.gem")
+ provides+=("ruby-$_buggeddep")
+done
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
- rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" ${noextract[@]}
+
+ # Remove cache, since we are a pacman package.
+ rm -rf "$pkgdir/$_gemdir/cache"
+
+ # Remove binaries, as they are not needed.
+ rm -rf "$pkgdir/usr/bin"
+
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+sha256sums=('d809bff03538ec4526845350b175aec099664654e4084cb8a90217e9e4e634ba'
+ '8b644bac7bd10f38b7944c324263b3f6d4506a0571e6221d604e853d4c5d9139'
+ '0b0e83fe0fc190640a93c48cef0c8e1f1f40f77840d82c160fefc1b07a5345f8'
+ 'c3be075f5b38a1b02404be5778b181e50fba9ab253bac851cb217d9a71375b77'
+ '38828ee5b49a2f645919d08fc4b6bdd888500117251f6b50c4e52726264bcbdb'
+ 'e00ef90f083f845118577dd6a040b4a4aa475bd7a2a645b2ad6944da0555598b'
+ 'eae37ccb7686b2c672f64bc6be366cfda4d828ea58e1086cb82766b17a54a7a6'
+ '826a96db895819c13fffa4fa3c20b85e80b60aaec1f28f79e7db80092abdb0bc'
+ '18e23793f52862597576757bb61e9ecae329a50a6826c4190e1386edb1646984')
+