summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2021-05-09 23:10:51 -0700
committermutantmonkey2021-05-09 23:10:51 -0700
commit394a2d198dd09662f7dc29b77b3448b1cd75c2e9 (patch)
treea7b2a0c3a3101552af776ec312783a32a828c17f
parent4535986bcb454a1b97bb7b247b51607eae2f24b7 (diff)
downloadaur-394a2d198dd09662f7dc29b77b3448b1cd75c2e9.tar.gz
upgpkg: intiface-desktop 20.0.0-2
Add patch to fix use of default import for is-online module. This should fix the following build error: src/IntifaceBackendManager.ts(12,8): error TS1259: Module '"/build/intiface-desktop/src/intiface-desktop-20.0.0/packages/core/node_modules/is-online/index"' can only be default-imported using the 'allowSyntheticDefaultImports' flag
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--core_isonline_fix.patch13
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef351297aa77..200b3801fc9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intiface-desktop
pkgdesc = Open-source, cross-platform application that acts as a hub for sex hardware access
pkgver = 20.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://intiface.com/desktop/
arch = i686
arch = x86_64
@@ -12,12 +12,14 @@ pkgbase = intiface-desktop
makedepends = trash-cli
makedepends = typescript
depends = electron
- source = https://github.com/intiface/intiface-desktop/archive/v20.0.0.tar.gz
+ source = intiface-desktop-20.0.0.tar.gz::https://github.com/intiface/intiface-desktop/archive/v20.0.0.tar.gz
source = intiface-desktop.sh
source = intiface-desktop.desktop
+ source = core_isonline_fix.patch
sha256sums = 9402de0e8aa9b969ae90538ef96e7df3b6252dec73f14f0c2105c5381976b6d2
sha256sums = 2f7d3350631fda4da8f03938eb06b0b6d3ed571c9975906b7863298f75e4c73f
sha256sums = ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64
+ sha256sums = 0060f45c1036f19955940f843d52c820a50cb9f362e3ad91ab0eb13a8d6e525c
pkgname = intiface-desktop
diff --git a/PKGBUILD b/PKGBUILD
index cf942616e535..c3909c856a8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,26 @@
pkgname=intiface-desktop
pkgver=20.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source, cross-platform application that acts as a hub for sex hardware access"
depends=('electron')
makedepends=('npm' 'yarn' 'git' 'trash-cli' 'typescript')
arch=('i686' 'x86_64')
url="https://intiface.com/desktop/"
license=('BSD')
-source=("https://github.com/intiface/intiface-desktop/archive/v${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/intiface/intiface-desktop/archive/v${pkgver}.tar.gz"
'intiface-desktop.sh'
- 'intiface-desktop.desktop')
+ 'intiface-desktop.desktop'
+ 'core_isonline_fix.patch')
sha256sums=('9402de0e8aa9b969ae90538ef96e7df3b6252dec73f14f0c2105c5381976b6d2'
'2f7d3350631fda4da8f03938eb06b0b6d3ed571c9975906b7863298f75e4c73f'
- 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64')
+ 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64'
+ '0060f45c1036f19955940f843d52c820a50cb9f362e3ad91ab0eb13a8d6e525c')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i ../core_isonline_fix.patch
+}
build() {
cd "${pkgname}-${pkgver}"
diff --git a/core_isonline_fix.patch b/core_isonline_fix.patch
new file mode 100644
index 000000000000..504b661110a8
--- /dev/null
+++ b/core_isonline_fix.patch
@@ -0,0 +1,13 @@
+diff --git a/packages/core/src/IntifaceBackendManager.ts b/packages/core/src/IntifaceBackendManager.ts
+index 35346b2..aa36775 100644
+--- a/packages/core/src/IntifaceBackendManager.ts
++++ b/packages/core/src/IntifaceBackendManager.ts
+@@ -9,7 +9,7 @@ import { IntifaceUtils } from "./Utils";
+ import { IApplicationUpdater } from "./IApplicationUpdater";
+ import { IntifaceBackendLogger } from "./IntifaceBackendLogger";
+ import { EventEmitter } from "events";
+-import isOnline from "is-online";
++import * as isOnline from "is-online";
+ import { promisify } from "util";
+ import * as winston from "winston";
+ import * as rimraf from "rimraf";