summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroberon20072015-09-22 00:02:36 +0200
committeroberon20072015-09-22 00:02:36 +0200
commit3978bbc808bbd4399dcc26c1a4382ff054bb5178 (patch)
tree4e2b59fbb8087ad642c6996994fdf5319aefd559
downloadaur-3978bbc808bbd4399dcc26c1a4382ff054bb5178.tar.gz
new
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--xfce4-indicator-plugin.install11
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccd64734d013
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xfce4-indicator-plugin
+ pkgdesc = Plugin to display information from applications in the Xfce4 panel
+ pkgver = 2.3.3
+ pkgrel = 2
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin
+ install = xfce4-indicator-plugin.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = xfce4-dev-tools
+ depends = xfce4-panel
+ depends = libindicator-gtk2
+ depends = libindicator-gtk3
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ optdepends = indicator-application-gtk2: take menus from applications and place them in the panel
+ optdepends = indicator-sound-gtk2: unified sound menu
+ optdepends = indicator-sound: GTK3 unified sound menu
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/2.3/xfce4-indicator-plugin-2.3.3.tar.bz2
+ sha256sums = c46b529b0f31c8ba9401fdc3e245ed3f30e61fadc0e8d2ddb6aaa10b02edbd52
+
+pkgname = xfce4-indicator-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f300f247ffc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: Abi Hafshin <abi@hafs.in>
+
+pkgname=xfce4-indicator-plugin
+_pkgname=xfce4-indicator-plugin
+pkgver=2.3.3
+_major=2.3
+pkgrel=2
+pkgdesc="Plugin to display information from applications in the Xfce4 panel"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+license=('GPL')
+depends=('xfce4-panel' 'libindicator-gtk2' 'libindicator-gtk3' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('intltool' 'xfce4-dev-tools')
+optdepends=('indicator-application-gtk2: take menus from applications and place them in the panel'
+ 'indicator-sound-gtk2: unified sound menu'
+ 'indicator-sound: GTK3 unified sound menu')
+install=$pkgname.install
+source=(http://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/${_major}/${_pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c46b529b0f31c8ba9401fdc3e245ed3f30e61fadc0e8d2ddb6aaa10b02edbd52')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/xfce4-indicator-plugin.install b/xfce4-indicator-plugin.install
new file mode 100644
index 000000000000..2c455e952b7b
--- /dev/null
+++ b/xfce4-indicator-plugin.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}