summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkouta-kun2022-12-15 22:24:58 -0300
committerkouta-kun2022-12-15 22:29:06 -0300
commit398e7256967eae78296cacab1aae1fe3c13de284 (patch)
tree2c6b47b72a4a465388b16f3e0f30ce1e8169c4cd
parent2437b876d01ed9f1bc12ad14a3e12518b78055dc (diff)
downloadaur-398e7256967eae78296cacab1aae1fe3c13de284.tar.gz
Initial commit
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--0001-Fix-compilation-errors-on-format-security.patch87
-rw-r--r--PKGBUILD27
4 files changed, 113 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6634ac7e057..848ddf63dc64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = ufoai-git
pkgdesc = In UFO: Alien Invasion you fight aliens trying to capture Earth (dev version)
- pkgver = 2.6.42188.8e2a1a5
+ pkgver = 2.6.45213.9b2eab2222
pkgrel = 1
epoch = 1
url = http://ufoai.org/wiki/News
- arch = i686
+ arch = aarch64
arch = x86_64
license = GPL
makedepends = git
@@ -13,6 +13,7 @@ pkgbase = ufoai-git
makedepends = gtksourceview2
makedepends = gtkglext
makedepends = openal
+ makedepends = python-urllib3
depends = libjpeg
depends = libgl
depends = libpng
@@ -29,8 +30,9 @@ pkgbase = ufoai-git
optdepends = openal: compiling the map-editor
conflicts = ufoai
conflicts = ufoai-data
- source = git+https://github.com/ufoai/ufoai
+ source = git+git://git.code.sf.net/p/ufoai/code
+ source = 0001-Fix-compilation-errors-on-format-security.patch
sha256sums = SKIP
+ sha256sums = 18a4cc6cfed138c58f02fd733d19250749ba31d6eaa9078dffb6537bca92eb25
pkgname = ufoai-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9130e88ac5fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+code/
+pkg/
+src/
+*.tar.*
+*~ \ No newline at end of file
diff --git a/0001-Fix-compilation-errors-on-format-security.patch b/0001-Fix-compilation-errors-on-format-security.patch
new file mode 100644
index 000000000000..0b810ee25fef
--- /dev/null
+++ b/0001-Fix-compilation-errors-on-format-security.patch
@@ -0,0 +1,87 @@
+From ff198496b716c36f98100286984d3c55be0bed05 Mon Sep 17 00:00:00 2001
+From: kouta-kun <darkfm@vera.com.uy>
+Date: Wed, 14 Dec 2022 01:49:24 -0300
+Subject: [PATCH] * Fix compilation errors on format-security
+
+---
+ src/client/cl_lua.cpp | 4 ++--
+ src/client/ui/swig/ui_lua_shared.cpp | 2 +-
+ src/tests/test_rma.cpp | 8 ++++----
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/client/cl_lua.cpp b/src/client/cl_lua.cpp
+index acabf49bb2..8cbf74ff35 100644
+--- a/src/client/cl_lua.cpp
++++ b/src/client/cl_lua.cpp
+@@ -67,13 +67,13 @@ static int CL_UfoModuleLoader (lua_State* L) {
+ } else {
+ /* push error string onto the stack */
+ sprintf(errmsg, "Lua custom-loader error: cannot load module named [%s]:\n\t%s\n", module, lua_tostring(L, -1));
+- Com_Printf(errmsg);
++ Com_Printf("%s", errmsg);
+ lua_pushstring(L, errmsg);
+ }
+ } else {
+ /* push error string onto the stack */
+ sprintf(errmsg, "Lua custom-loader error: cannot find module named [%s]\n", module);
+- Com_Printf(errmsg);
++ Com_Printf("%s", errmsg);
+ lua_pushstring(L, errmsg);
+ }
+ /* an error occured, return 0*/
+diff --git a/src/client/ui/swig/ui_lua_shared.cpp b/src/client/ui/swig/ui_lua_shared.cpp
+index c89b86f53b..14b0c9a299 100644
+--- a/src/client/ui/swig/ui_lua_shared.cpp
++++ b/src/client/ui/swig/ui_lua_shared.cpp
+@@ -8,7 +8,7 @@
+ * interface file instead.
+ * ----------------------------------------------------------------------------- */
+
+-
++#pragma GCC diagnostic ignored "-Wformat-security"
+ #ifndef SWIGLUA
+ #define SWIGLUA
+ #endif
+diff --git a/src/tests/test_rma.cpp b/src/tests/test_rma.cpp
+index c2b366b51c..27041c81c1 100644
+--- a/src/tests/test_rma.cpp
++++ b/src/tests/test_rma.cpp
+@@ -120,7 +120,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblyTimeout)
+ const char *self = "RandomMapAssemblyTest.MassAssemblyTimeout";
+ unsigned const int numRuns = 10;
+ sv_threads->integer = 1;
+- SCOPED_TRACE(va(self));
++ SCOPED_TRACE(self);
+ testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
+ }
+
+@@ -129,7 +129,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblyParallel)
+ const char *self = "RandomMapAssemblyTest.MassAssemblyParallel";
+ unsigned const int numRuns = 10;
+ sv_threads->integer = 2;
+- SCOPED_TRACE(va(self));
++ SCOPED_TRACE(self);
+ testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
+ }
+
+@@ -139,7 +139,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblySequential)
+ const char *self = "RandomMapAssemblyTest.MassAssemblySequential";
+ unsigned const int numRuns = 10;
+ sv_threads->integer = 0;
+- SCOPED_TRACE(va(self));
++ SCOPED_TRACE(self);
+ testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
+ }
+
+@@ -162,7 +162,7 @@ TEST_F(RandomMapAssemblyTest, Seedlists)
+ sv_threads->integer = 0;
+ long timeSum = 0;
+
+- SCOPED_TRACE(va(self));
++ SCOPED_TRACE(self);
+ for (int n = 0; n < length; n++) {
+ timeSum += testAssembly(self, numRuns, assNames[n][0], assNames[n][1]);
+ }
+--
+2.39.0
+
diff --git a/PKGBUILD b/PKGBUILD
index ac37a8452102..e4bfb1d4d4f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Maintainer: Salvador PardiƱas <darkfm at vera dot com dot uy>
+# Contributor: Levente Polyak <levente[at]leventepolyak[dot]net>
# Contributor: Dr.T.Error <der_dot_t_dot_error_at_online_dot_de>
pkgname=ufoai-git
-_gitname=ufoai
-pkgver=2.6.42188.8e2a1a5
+_gitname=code
+pkgver=2.6.45213.9b2eab2222
pkgrel=1
epoch=1
pkgdesc="In UFO: Alien Invasion you fight aliens trying to capture Earth (dev version)"
url="http://ufoai.org/wiki/News"
license=('GPL')
-arch=('i686' 'x86_64')
+arch=('aarch64' 'x86_64')
depends=('libjpeg' 'libgl' 'libpng' 'curl' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'libtheora' 'xvidcore' 'glu')
-makedepends=('git' 'python2' 'zip' 'gtksourceview2' 'gtkglext' 'openal')
+makedepends=('git' 'python2' 'zip' 'gtksourceview2' 'gtkglext' 'openal' 'python-urllib3')
optdepends=('python2: compiling self-created maps'
'gtksourceview2: compiling the map-editor'
'gtkglext: compiling the map-editor'
'openal: compiling the map-editor')
conflicts=('ufoai' 'ufoai-data')
-source=(git+https://github.com/ufoai/ufoai)
-sha256sums=('SKIP')
+source=(git+git://git.code.sf.net/p/ufoai/code "0001-Fix-compilation-errors-on-format-security.patch")
+#source=('git+file:///home/kouta-kun/ufo')
+sha256sums=('SKIP' "18a4cc6cfed138c58f02fd733d19250749ba31d6eaa9078dffb6537bca92eb25")
pkgver() {
cd ${_gitname}
@@ -27,11 +29,12 @@ pkgver() {
}
prepare() {
- cd ${_gitname}
- # uncomment the '--enable-uforadiant' line for ufo-radiant (map editor)
- ./configure --prefix=/usr --datadir=/usr/share/ufoai \
- --enable-release --localedir=/usr/share/ufoai/base/i18n/ \
- --enable-uforadiant
+ cd ${_gitname}
+ patch --forward --strip=1 --input="${srcdir}/0001-Fix-compilation-errors-on-format-security.patch"
+ # uncomment the '--enable-uforadiant' line for ufo-radiant (map editor)
+ ./configure --prefix=/usr --datadir=/usr/share/ufoai \
+ --enable-release --localedir=/usr/share/ufoai/base/i18n/ \
+ --disable-uforadiant
}
build() {