summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Martin2016-07-15 23:42:41 -0500
committerAndrew Martin2016-07-15 23:42:41 -0500
commit39937e98478a45912fb38cd45ec1d981084a5a80 (patch)
tree595230f5ea5dbdc9dadb769c12ff1e9f0ad2393f
downloadaur-39937e98478a45912fb38cd45ec1d981084a5a80.tar.gz
initial build of Photomatix 1.0.0 for Linux
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06e756adc183
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = photomatix
+ pkgdesc = Professional HDR Creation Program
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://hdrsoft.com/download/photomatix-linux.html
+ arch = x86_64
+ license = custom
+ depends = libtiff
+ depends = openexr
+ depends = gtkmm3
+ source = http://hdrsoft.com/download/linux/PhotomatixLinux_Ubuntu_16.04.deb
+ sha1sums = 28a56527b8e2f463b96653a348034e7b1db02c93
+
+pkgname = photomatix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b639144b1941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Martin <amartin@avidandrew.com>
+
+pkgname=photomatix
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Professional HDR Creation Program"
+url="http://hdrsoft.com/download/photomatix-linux.html"
+arch=('x86_64')
+license=('custom')
+depends=('libtiff' 'openexr' 'gtkmm3')
+source=("http://hdrsoft.com/download/linux/PhotomatixLinux_Ubuntu_16.04.deb")
+sha1sums=('28a56527b8e2f463b96653a348034e7b1db02c93')
+
+package() {
+ # extract the deb file's data.tar.gz archive
+ tar -xJf data.tar.xz -C "${srcdir}"
+
+ install -d ${pkgdir}/usr/share
+ mv ${srcdir}/usr/share/{applications,photomatix} ${pkgdir}/usr/share/
+ chmod 755 ${pkgdir}/usr/share/applications
+
+ install -d ${pkgdir}/usr/lib
+ mv ${srcdir}/usr/lib/photomatix ${pkgdir}/usr/lib
+
+ mv ${srcdir}/usr/bin ${pkgdir}/usr/
+ chmod 755 ${pkgdir}/usr/bin
+}
+
+post_install() {
+ cp /usr/share/photomatix/apps.photomatix.gschema.xml /usr/share/glib-2.0/schemas/
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+ chmod a+r /usr/share/glib-2.0/schemas/gschemas.compiled
+ chmod 0755 /usr/bin/photomatix
+}
+
+post_upgrade() {
+ post_install
+}