summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2014-05-29 15:27:11 -0700
committeryar2014-05-29 15:40:02 -0700
commit39b29496b1575a939a3c65f8bc397c8b9d39798e (patch)
treedf405a7b75d8935062bba2906f2d4da14d10ed23
parent33a3054b922113fb260eccdcb23db2502e4f4643 (diff)
downloadaur-39b29496b1575a939a3c65f8bc397c8b9d39798e.tar.gz
[tor-browser-en] arguments with spaces are broken
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xtor-browser-en.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed08b7e50dde..ec04584c155f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tor-browser-en
pkgdesc = Tor Browser Bundle: Anonymous browsing using firefox and tor
pkgver = 3.6.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.torproject.org/projects/torbrowser.html.en
install = tor-browser-en.install
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = tor-browser-en
sha256sums = b89d89749c71dbc1c762148b20edd6cbd0e77a7e20e948c5a742effd7059a5d3
sha256sums = 3d5fc01f2cfbae0a00b7117b0b0a24028d1686e6f81a347809f74de2d8522ff7
sha256sums = 17fc2f5784d080233aca16e788d62ab6fe3e57cf781b123cfe32767de97d6d3b
- sha256sums = f25fedfa77b19a96488529e6d387411fb49a82e99e3a1a9708b88ad8b6e7d2aa
+ sha256sums = 84187ff6a6d0e74005b2bacbabb76187a926dee31e154dff633ee1f9f49f1c89
pkgname = tor-browser-en
diff --git a/PKGBUILD b/PKGBUILD
index 7ef089fb1a03..8fea53693d59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgver='3.6.1'
_realpkgver='3.6.1'
_realpkgver_i686='3.6.1'
_language='en-US'
-pkgrel='1'
+pkgrel=2
pkgdesc='Tor Browser Bundle: Anonymous browsing using firefox and tor'
url='https://www.torproject.org/projects/torbrowser.html.en'
arch=('x86_64' 'i686')
@@ -43,7 +43,7 @@ else
fi
sha256sums+=('3d5fc01f2cfbae0a00b7117b0b0a24028d1686e6f81a347809f74de2d8522ff7'
'17fc2f5784d080233aca16e788d62ab6fe3e57cf781b123cfe32767de97d6d3b'
- 'f25fedfa77b19a96488529e6d387411fb49a82e99e3a1a9708b88ad8b6e7d2aa')
+ '84187ff6a6d0e74005b2bacbabb76187a926dee31e154dff633ee1f9f49f1c89')
noextract=("tor-browser-linux${_pkgarch}-${_realpkgver}_${_language}.tar.xz")
diff --git a/tor-browser-en.sh b/tor-browser-en.sh
index 135f3f2f9a53..18f264bc5d22 100755
--- a/tor-browser-en.sh
+++ b/tor-browser-en.sh
@@ -64,7 +64,9 @@ Options:
-u|--update Force update of the copy in your home directory
--dir=<directory> The Tor-Browser directory to use
- All unrecognized arguments will be passed to the browser.
+ All unrecognized arguments will be passed to the browser,
+ but arguments with spaces will break, until Tor fixes this bug:
+ https://trac.torproject.org/projects/tor/ticket/12161
EOF
}
@@ -106,4 +108,4 @@ else
fi
# start tor-browser
-cd $INSTALL_DIRECTORY && ./start-tor-browser --class 'Tor Browser' "${args[@]}"
+cd $INSTALL_DIRECTORY && ./start-tor-browser --class Tor-Browser "${args[@]}"