summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kitsinger (SwooshyCueb)2016-09-18 17:01:23 -0500
committerMarkus Kitsinger (SwooshyCueb)2016-09-18 17:01:23 -0500
commit39dbbade236e336560e3db67cd6864bbf400da34 (patch)
treea69620d2dd4767142ea6132c29cfc2974d44314b
parentae71137d1eafd0242bd1b83f22192fdfffc7a2ac (diff)
downloadaur-39dbbade236e336560e3db67cd6864bbf400da34.tar.gz
Quick update for 4.7.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--vmci.patch58
-rw-r--r--vmmon.patch16
-rw-r--r--vmnet.patch16
5 files changed, 21 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7459ea073bfe..2cdadae7c7b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Sep 18 22:00:57 UTC 2016
pkgbase = vmware-modules-dkms
pkgdesc = VMware Workstation kernel modules (DKMS)
pkgver = 308.0
- pkgrel = 8
+ pkgrel = 9
url = http://www.vmware.com/
install = vmware-modules-dkms.install
arch = i686
@@ -24,9 +26,9 @@ pkgbase = vmware-modules-dkms
sha256sums = 7baecdfd979d57aed7dac0db57e0165fc1730b15ed6bf42ed25571e68ec34b52
sha256sums = 707596776b0b232f7f5de4a0ddff12262df3bc934180afd956ea2ee45ac4db9e
sha256sums = 48951fcb72e1f964e21dc3f7ea4729dd673936abdd28b54008dbca9b0967683f
- sha256sums = 1d773551e51b3eca2be6f71ed77bc563409d309eef661ab6c298117f068d5530
- sha256sums = cd093ec14f05c1bdf268be2ca3d2ff85616493867de48452d45a527248c5254d
- sha256sums = 94bb3e6f283ef97b21b1e03a837f37bf65295f0d159582a94b9c70035344e7ee
+ sha256sums = cea6c1e3d76063a95b6e71a46f90557a06e3a668457eb0eeede66e7f121cfa5f
+ sha256sums = 8bb2e4dae95523024515b850a253baca4e6da914a85a5a3b237d4390c2617aa7
+ sha256sums = 2eb2ad24722e0ddd97387c48266295204aea95de8970eec427e3931769d15e19
sha256sums = a97e5096ef1b1595b2d1ed6b86b0fde80e34c6310f566156bcd4f5d660a74a58
pkgname = vmware-modules-dkms
diff --git a/PKGBUILD b/PKGBUILD
index cd77a6660163..161e1b6db9a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,13 @@
# Contributor : Alain Kalker <a {dot} c {dot} kalker "at" gmail {dot} com>
# Contributor : Willy Sudiarto Raharjo < willysr "at" slackware-id {dot} com>
+# We should probably find something other than VMMON_VERSION to base pkgver on,
+# as VMMON_VERSION doesn't seem to change much.
+
pkgname=vmware-modules-dkms
_pkgbase=vmware-modules
pkgver=308.0
-pkgrel=8
+pkgrel=9
pkgdesc="VMware Workstation kernel modules (DKMS)"
arch=('i686' 'x86_64')
url="http://www.vmware.com/"
@@ -34,9 +37,9 @@ sha256sums=('ee3e5cfac51703ac392bce540e3375680c579eaac7aa31990e1e08ada589e89b'
'7baecdfd979d57aed7dac0db57e0165fc1730b15ed6bf42ed25571e68ec34b52'
'707596776b0b232f7f5de4a0ddff12262df3bc934180afd956ea2ee45ac4db9e'
'48951fcb72e1f964e21dc3f7ea4729dd673936abdd28b54008dbca9b0967683f'
- '1d773551e51b3eca2be6f71ed77bc563409d309eef661ab6c298117f068d5530'
- 'cd093ec14f05c1bdf268be2ca3d2ff85616493867de48452d45a527248c5254d'
- '94bb3e6f283ef97b21b1e03a837f37bf65295f0d159582a94b9c70035344e7ee'
+ 'cea6c1e3d76063a95b6e71a46f90557a06e3a668457eb0eeede66e7f121cfa5f'
+ '8bb2e4dae95523024515b850a253baca4e6da914a85a5a3b237d4390c2617aa7'
+ '2eb2ad24722e0ddd97387c48266295204aea95de8970eec427e3931769d15e19'
'a97e5096ef1b1595b2d1ed6b86b0fde80e34c6310f566156bcd4f5d660a74a58')
build()
diff --git a/vmci.patch b/vmci.patch
index 353822bda541..4dc66c59e70c 100644
--- a/vmci.patch
+++ b/vmci.patch
@@ -1,5 +1,5 @@
diff --git a/vmci/linux/driver.c b/vmci/linux/driver.c
-index 64a3cca..526f9a9 100644
+index f676166..8e6f71f 100644
--- a/vmci/linux/driver.c
+++ b/vmci/linux/driver.c
@@ -26,6 +26,7 @@
@@ -10,40 +10,7 @@ index 64a3cca..526f9a9 100644
#include <linux/init.h>
#if defined(__x86_64__) && LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 12)
# include <linux/ioctl32.h>
-@@ -713,7 +714,7 @@ LinuxDriver_Ioctl(struct inode *inode,
-
- case IOCTL_VMCI_INIT_CONTEXT: {
- VMCIInitBlock initBlock;
-- VMCIHostUser user;
-+ uid_t user;
-
- retval = copy_from_user(&initBlock, (void *)ioarg, sizeof initBlock);
- if (retval != 0) {
-@@ -735,7 +736,11 @@ LinuxDriver_Ioctl(struct inode *inode,
- goto init_release;
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
- user = current_uid();
-+#else
-+ user = from_kuid(&init_user_ns, current_uid());
-+#endif
- retval = VMCIContext_InitContext(initBlock.cid, initBlock.flags,
- 0 /* Unused */, vmciLinux->userVersion,
- &user, &vmciLinux->context);
-@@ -1467,7 +1472,11 @@ VMCIUserVALockPage(VA addr) // IN:
- int retval;
-
- down_read(&current->mm->mmap_sem);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+ retval = get_user_pages(addr,
-+#else
- retval = get_user_pages(current, current->mm, addr,
-+#endif
- 1, 1, 0, &page, NULL);
- up_read(&current->mm->mmap_sem);
-
-@@ -1683,7 +1692,11 @@ vmci_guest_init(void)
+@@ -1687,7 +1688,11 @@ vmci_guest_init(void)
/* This should be last to make sure we are done initializing. */
retval = pci_register_driver(&vmci_driver);
if (retval < 0) {
@@ -55,7 +22,7 @@ index 64a3cca..526f9a9 100644
data_buffer = NULL;
return retval;
}
-@@ -2470,7 +2483,11 @@ vmci_exit(void)
+@@ -2474,7 +2479,11 @@ vmci_exit(void)
if (guestDeviceInit) {
pci_unregister_driver(&vmci_driver);
@@ -67,7 +34,7 @@ index 64a3cca..526f9a9 100644
guestDeviceInit = FALSE;
}
-@@ -2479,12 +2496,16 @@ vmci_exit(void)
+@@ -2483,12 +2492,16 @@ vmci_exit(void)
VMCI_HostCleanup();
@@ -85,7 +52,7 @@ index 64a3cca..526f9a9 100644
hostDeviceInit = FALSE;
}
diff --git a/vmci/linux/vmciKernelIf.c b/vmci/linux/vmciKernelIf.c
-index 8b1788f..12cce68 100644
+index 3fba8b6..f60d7b1 100644
--- a/vmci/linux/vmciKernelIf.c
+++ b/vmci/linux/vmciKernelIf.c
@@ -40,6 +40,7 @@
@@ -148,20 +115,7 @@ index 8b1788f..12cce68 100644
pages[i] = NULL;
}
}
-@@ -2048,8 +2069,12 @@ VMCIHost_GetUserMemory(VA64 produceUVA, // IN
- int err = VMCI_SUCCESS;
-
- down_write(&current->mm->mmap_sem);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+ retval = get_user_pages(
-+#else
- retval = get_user_pages(current,
- current->mm,
-+#endif
- (VA)produceUVA,
- produceQ->kernelIf->numPages,
- 1, 0,
-@@ -2062,8 +2087,12 @@ VMCIHost_GetUserMemory(VA64 produceUVA, // IN
+@@ -2070,8 +2091,12 @@ VMCIHost_GetUserMemory(VA64 produceUVA, // IN
goto out;
}
diff --git a/vmmon.patch b/vmmon.patch
index fe1231c1704e..1346e2e979b7 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -1,5 +1,5 @@
diff --git a/vmmon/linux/driver.c b/vmmon/linux/driver.c
-index 0a72335..63cea5d 100644
+index 87cf45b..6e90af4 100644
--- a/vmmon/linux/driver.c
+++ b/vmmon/linux/driver.c
@@ -1279,7 +1279,7 @@ LinuxDriverReadTSC(void *data, // OUT: TSC values
@@ -12,7 +12,7 @@ index 0a72335..63cea5d 100644
{
TSCDelta tscDelta;
diff --git a/vmmon/linux/hostif.c b/vmmon/linux/hostif.c
-index d1bc8ba..4d5018b 100644
+index 7053a83..a4a4eb2 100644
--- a/vmmon/linux/hostif.c
+++ b/vmmon/linux/hostif.c
@@ -74,6 +74,7 @@
@@ -23,18 +23,6 @@ index d1bc8ba..4d5018b 100644
#include "vmware.h"
#include "x86apic.h"
-@@ -1162,7 +1163,11 @@ HostIFGetUserPages(void *uvAddr, // IN
- int retval;
-
- down_read(&current->mm->mmap_sem);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+ retval = get_user_pages((unsigned long)uvAddr,
-+#else
- retval = get_user_pages(current, current->mm, (unsigned long)uvAddr,
-+#endif
- numPages, 0, 0, ppages, NULL);
- up_read(&current->mm->mmap_sem);
-
diff --git a/vmmon/linux/vmmonInt.h b/vmmon/linux/vmmonInt.h
index 4dc04e9..993212d 100644
--- a/vmmon/linux/vmmonInt.h
diff --git a/vmnet.patch b/vmnet.patch
index 05e990a76187..910cbc07c8f8 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -1,19 +1,3 @@
-diff --git a/vmnet/userif.c b/vmnet/userif.c
-index 4e457ba..b7b186a 100644
---- a/vmnet/userif.c
-+++ b/vmnet/userif.c
-@@ -113,7 +113,11 @@ UserifLockPage(VA addr) // IN
- int retval;
-
- down_read(&current->mm->mmap_sem);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+ retval = get_user_pages(addr,
-+#else
- retval = get_user_pages(current, current->mm, addr,
-+#endif
- 1, 1, 0, &page, NULL);
- up_read(&current->mm->mmap_sem);
-
diff --git a/vmnet/vm_device_version.h b/vmnet/vm_device_version.h
index e2cb477..3dd7097 100644
--- a/vmnet/vm_device_version.h