summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Butler2023-04-15 10:48:31 +0100
committerAlex Butler2023-04-15 10:48:31 +0100
commit39f0ac2b56d1811564e58900b46dcc23f072656e (patch)
tree280a637ec0c4d523e23389df79effb2150b0cca6
parent0e0ec5bfc7bb407715f55dd834ce6f01db131746 (diff)
downloadaur-39f0ac2b56d1811564e58900b46dcc23f072656e.tar.gz
0.7.7-1
Use crates-io sparse fetch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecb36d23a6c7..9bfb9c398dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ab-av1
pkgdesc = AV1 encoding tool with fast VMAF sampling.
- pkgver = 0.7.6
+ pkgver = 0.7.7
pkgrel = 1
url = https://github.com/alexheretic/ab-av1
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = ab-av1
depends = svt-av1
depends = ffmpeg
depends = vmaf
- source = https://github.com/alexheretic/ab-av1/archive/v0.7.6.tar.gz
- sha256sums = 65d4dbe73691cc3fc559295a3c4f8f44080a1cb381664061ba9224ee528196eb
+ source = https://github.com/alexheretic/ab-av1/archive/v0.7.7.tar.gz
+ sha256sums = 48fe4b44adcff9f865de916f48bd626ef73d7e029ddab8677a082e6d2f9cc94e
pkgname = ab-av1
diff --git a/PKGBUILD b/PKGBUILD
index 406879baa770..2dd2d483d1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Butler <alexheretic@gmail.com>
pkgname=ab-av1
-pkgver=0.7.6
+pkgver=0.7.7
pkgrel=1
pkgdesc="AV1 encoding tool with fast VMAF sampling."
arch=('x86_64')
@@ -14,11 +14,12 @@ makedepends=('cargo'
'git'
'lld')
source=("https://github.com/alexheretic/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('65d4dbe73691cc3fc559295a3c4f8f44080a1cb381664061ba9224ee528196eb')
+sha256sums=('48fe4b44adcff9f865de916f48bd626ef73d7e029ddab8677a082e6d2f9cc94e')
build() {
cd "$pkgname-$pkgver"
RUSTFLAGS='-C link-arg=-fuse-ld=lld' \
+ CARGO_REGISTRIES_CRATES_IO_PROTOCOL=sparse \
RUSTUP_TOOLCHAIN=stable \
cargo build --release --locked
}