summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2015-10-08 20:45:00 +0100
committerMatthew Hague2015-10-08 20:45:00 +0100
commit3a252613bf412a4cdb9292ebc1ee862f849037db (patch)
treed20eb9b9dff3bb4e50e3453ce51008a55c944a84
parentbf476da92b06457593094ba0bfb9cd212a1b7fdd (diff)
downloadaur-3a252613bf412a4cdb9292ebc1ee862f849037db.tar.gz
moved service file to systemd/user and removed _ from config directory
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--imapnotify@.service3
-rw-r--r--nodejs-imapnotify-git.install2
4 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5ea6b51d9b4..635cb8713f88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nodejs-imapnotify-git
pkgdesc = Execute scripts on new messages using IDLE imap command
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/a-sk/node-imapnotify
install = nodejs-imapnotify-git.install
arch = any
@@ -11,7 +11,7 @@ pkgbase = nodejs-imapnotify-git
source = nodejs-imapnotify-git::git://github.com/a-sk/node-imapnotify.git
source = imapnotify@.service
sha256sums = SKIP
- sha256sums = ef5d751f86fcff398ddaf3114c3bc90ce685b85739f76e8c6f1f80cea5c1cb27
+ sha256sums = 5644bd4ba49df06c5f0aa529e89bc16bbc696691f7f03cc5f11add7c2f5869b8
pkgname = nodejs-imapnotify-git
diff --git a/PKGBUILD b/PKGBUILD
index 79b9de8557d9..3053406a6ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_npmname=imapnotify
pkgname=nodejs-imapnotify-git
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Execute scripts on new messages using IDLE imap command'
arch=(any)
url='http://github.com/a-sk/node-imapnotify'
@@ -15,7 +15,7 @@ conflicts=('nodejs-imapnotify')
source=($pkgname::git://github.com/a-sk/node-imapnotify.git
imapnotify@.service)
sha256sums=('SKIP'
- 'ef5d751f86fcff398ddaf3114c3bc90ce685b85739f76e8c6f1f80cea5c1cb27')
+ '5644bd4ba49df06c5f0aa529e89bc16bbc696691f7f03cc5f11add7c2f5869b8')
package() {
cd $srcdir
@@ -23,5 +23,5 @@ package() {
mkdir -p $_npmdir
cd $_npmdir
PYTHON=/usr/bin/python2 npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
- install -Dm644 "${srcdir}/imapnotify@.service" "${pkgdir}/usr/lib/systemd/system/imapnotify@.service"
+ install -Dm644 "${srcdir}/imapnotify@.service" "${pkgdir}/usr/lib/systemd/user/imapnotify@.service"
}
diff --git a/imapnotify@.service b/imapnotify@.service
index 5d14588babac..621815a2d7e0 100644
--- a/imapnotify@.service
+++ b/imapnotify@.service
@@ -3,9 +3,8 @@ Description=Execute scripts on new messages using IDLE imap command
After=network.target
[Service]
-User=username
Type=simple
-ExecStart=/usr/bin/imapnotify -c ~/.config/imap_inotify/%I.json
+ExecStart=/usr/bin/imapnotify -c ~/.config/imapnotify/%I.json
Restart=on-failure
RestartSec=20
diff --git a/nodejs-imapnotify-git.install b/nodejs-imapnotify-git.install
index 33b4715be95a..2a32afa20dc7 100644
--- a/nodejs-imapnotify-git.install
+++ b/nodejs-imapnotify-git.install
@@ -13,7 +13,7 @@ BLUE="${BOLD}$(tput setaf 4)"
YELLOW="${BOLD}$(tput setaf 3)"
post_install() {
- note "Copy /usr/lib/systemd/system/imapnotify@.service to /etc/systemd/system and replace User=username with your username"
+ note "To use with systemd, place a config file in ~/.config/imapnotify/<config>.json and use systemctl --user enable imapnotify@<config>"
}
post_upgrade() {