summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-09-10 15:53:47 +0200
committerStephan Springer2018-09-10 15:53:47 +0200
commit3a2ffe41a272f1f7dd834aef342e0450b381d59c (patch)
treefea8b5d282c4659b72f797f8145d18307e4bcf39
downloadaur-3a2ffe41a272f1f7dd834aef342e0450b381d59c.tar.gz
initial commit, version 3.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42ba6a6d396c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pretty_bad_protocol
+ pkgdesc = Another Python 3 wrapper for GnuPG
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://github.com/isislovecruft/python-gnupg
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = gnupg
+ source = python-pretty_bad_protocol-3.1.1.tar.gz::https://github.com/isislovecruft/python-gnupg/archive/3.1.1.tar.gz
+ sha256sums = 69b74379f235a370379d0c3f890102f5fdf0b0db580a728702abdfa4be5780ba
+
+pkgname = python-pretty_bad_protocol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6babb6361d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+
+_pkgname=python-gnupg
+pkgname=python-pretty_bad_protocol
+pkgver=3.1.1
+pkgrel=1
+pkgdesc='Another Python 3 wrapper for GnuPG'
+arch=('any')
+url='https://github.com/isislovecruft/python-gnupg'
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python' 'gnupg')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/isislovecruft/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('69b74379f235a370379d0c3f890102f5fdf0b0db580a728702abdfa4be5780ba')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}