summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimur Kiyivinski2017-03-28 15:28:42 +0800
committerTimur Kiyivinski2017-03-28 15:28:42 +0800
commit3a47aee9a562c5aab085f094b0d3c7e1cf3841e1 (patch)
treee5e722dae6ee1a27687d518c632df2b25cbbe030
parent45173d15c001da9ee9b21db74e003b1b25617cce (diff)
downloadaur-3a47aee9a562c5aab085f094b0d3c7e1cf3841e1.tar.gz
[REFACTOR] Enable UPNP and migrate to Qt5
Temporarily using my forked repository as the PR has not been merged into the official repository.
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c12528e92cd..bc5ab4f9be26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Timur Kiyivinski <timur@linux.com>
pkgname=zcoin-git
-pkgver=91.6452e96
+pkgver=154.ca0bb3c
pkgrel=1
pkgdesc='The Zerocoin Cryptocurrency'
arch=('any')
url='https://github.com/zcoinofficial/zcoin'
license=('MIT')
-depends=('boost' 'qt4')
-source=("$pkgname::git+https://github.com/zcoinofficial/zcoin.git"
+depends=('db' 'boost' 'miniupnpc' 'qt5-base')
+source=("$pkgname::git+https://github.com/TimurKiyivinski/zcoin.git"
"${pkgname/-git/}.desktop")
md5sums=('SKIP'
'2e3eff2f4fd362a84687979ebb136867')
@@ -20,7 +20,8 @@ pkgver() {
build() {
cd "$pkgname"
- qmake-qt4 USE_UPNP=- -spec /usr/share/qt4/mkspecs/linux-g++-64 -o Makefile zcoin.pro
+ git checkout fix-miniupnpc
+ qmake-qt5 USE_UPNP=1 -o Makefile zcoin.pro
make
}