summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuckSoft2020-12-13 20:22:35 +0800
committerDuckSoft2020-12-13 20:22:35 +0800
commit3a960a57d8b8463b95e48aa930c65eff976e0117 (patch)
tree273c1b0e0542e7ad1af4c0f3933336fe57a8d2aa
downloadaur-3a960a57d8b8463b95e48aa930c65eff976e0117.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD41
-rw-r--r--ducksoft-want-my-space-back.patch46
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d294a8513dd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = dolphin-duckspace
+ pkgdesc = KDE File Manager (with DuckSoft's Space Patch)
+ pkgver = 20.12.0
+ pkgrel = 1
+ url = https://kde.org/applications/system/dolphin/
+ arch = x86_64
+ groups = kde-applications
+ groups = kde-system
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = packagekit-qt5
+ depends = baloo-widgets
+ depends = knewstuff
+ depends = kio-extras
+ depends = kcmutils
+ depends = kparts
+ depends = kinit
+ depends = kactivities
+ depends = kuserfeedback
+ optdepends = kde-cli-tools: for editing file type options
+ optdepends = ffmpegthumbs: video thumbnails
+ optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
+ optdepends = konsole: terminal panel
+ optdepends = purpose: share context menu
+ optdepends = packagekit-qt5: service menu installer
+ provides = dolphin
+ conflicts = dolphin
+ source = https://download.kde.org/stable/release-service/20.12.0/src/dolphin-20.12.0.tar.xz
+ source = https://download.kde.org/stable/release-service/20.12.0/src/dolphin-20.12.0.tar.xz.sig
+ source = ducksoft-want-my-space-back.patch
+ validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
+ validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
+ sha256sums = 02b384e85b00aaaf1b4efd7ee7ca9d2f98991b850aa3645b7161219e9087ccd3
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dolphin-duckspace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95dcf7e2ebeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Antonio Rojas <arojas@archlinux,org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=dolphin-duckspace
+_pkgname=dolphin
+pkgver=20.12.0
+pkgrel=1
+pkgdesc="KDE File Manager (with DuckSoft's Space Patch)"
+arch=(x86_64)
+url="https://kde.org/applications/system/dolphin/"
+license=(LGPL)
+provides=(dolphin)
+conflicts=(dolphin)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit kactivities kuserfeedback)
+makedepends=(extra-cmake-modules kdoctools packagekit-qt5)
+optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
+ 'konsole: terminal panel' 'purpose: share context menu' 'packagekit-qt5: service menu installer')
+groups=(kde-applications kde-system)
+source=("https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz"{,.sig}
+ "ducksoft-want-my-space-back.patch")
+sha256sums=('02b384e85b00aaaf1b4efd7ee7ca9d2f98991b850aa3645b7161219e9087ccd3'
+ 'SKIP' 'SKIP')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
+
+prepare() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ patch -p1 < ../ducksoft-want-my-space-back.patch
+}
+
+build() {
+ cmake -B build -S $_pkgname-$pkgver \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
diff --git a/ducksoft-want-my-space-back.patch b/ducksoft-want-my-space-back.patch
new file mode 100644
index 000000000000..67a84ffd5bd7
--- /dev/null
+++ b/ducksoft-want-my-space-back.patch
@@ -0,0 +1,46 @@
+From 67f0185ac119188c881a3041d810f2e5d84cd611 Mon Sep 17 00:00:00 2001
+From: DuckSoft <ducksoft@build.archlinuxcn.org>
+Date: Sun, 13 Dec 2020 20:11:14 +0800
+Subject: [PATCH] Revert "Compute text width taking into account the zoom
+ level"
+
+This reverts commit c7d4c37534fd4c7107497a3bb67e8ffe96ce775c.
+---
+ src/views/dolphinitemlistview.cpp | 14 ++++----------
+ 1 file changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/src/views/dolphinitemlistview.cpp b/src/views/dolphinitemlistview.cpp
+index 9fa91a674..df28a0858 100644
+--- a/src/views/dolphinitemlistview.cpp
++++ b/src/views/dolphinitemlistview.cpp
+@@ -17,7 +17,6 @@
+ #include "zoomlevelinfo.h"
+
+ #include <KIO/PreviewJob>
+-#include <QtMath>
+
+
+ DolphinItemListView::DolphinItemListView(QGraphicsWidget* parent) :
+@@ -164,16 +163,11 @@ void DolphinItemListView::updateGridSize()
+
+ switch (itemLayout()) {
+ case KFileItemListView::IconsLayout: {
++ const int minItemWidth = 48;
++ itemWidth = minItemWidth + IconsModeSettings::textWidthIndex() * 64;
+
+- // an exponential factor based on zoom, 0 -> 1, 4 -> 1.36 8 -> ~1.85, 16 -> 3.4
+- auto zoomFactor = qExp(m_zoomLevel / 13.0);
+- // 9 is the average char width for 10pt Noto Sans, making fontFactor =1
+- // by each pixel the font gets larger the factor increases by 1/9
+- auto fontFactor = option.fontMetrics.averageCharWidth() / 9.0;
+- itemWidth = 48 + IconsModeSettings::textWidthIndex() * 64 * fontFactor * zoomFactor;
+-
+- if (itemWidth < iconSize + padding * 2 * zoomFactor) {
+- itemWidth = iconSize + padding * 2 * zoomFactor;
++ if (itemWidth < iconSize + padding * 2) {
++ itemWidth = iconSize + padding * 2;
+ }
+
+ itemHeight = padding * 3 + iconSize + option.fontMetrics.lineSpacing();
+--
+2.29.2