summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-07-09 18:55:59 +0200
committerMichel Zou2019-07-09 18:55:59 +0200
commit3aacdf6f0613a07e1d10fdb9ce67431f51b0cd95 (patch)
tree911240ddc13d49796a5700ff5ace6c2f6895c69b
parent57f88dface6354d4f1dc5135335e006e5f887ce9 (diff)
downloadaur-3aacdf6f0613a07e1d10fdb9ce67431f51b0cd95.tar.gz
2.0!
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD53
2 files changed, 11 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89815d3d5a07..469b0f8f8e8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = scantool
pkgdesc = OBD-II vehicle diagnostic scanner
- pkgver = 1.21
+ pkgver = 2.0
pkgrel = 1
- url = http://www.scantool.net
+ url = https://github.com/kees/scantool
arch = i686
arch = x86_64
license = GPL
makedepends = dos2unix
depends = allegro4
- noextract = scantool_net121src.zip
- source = http://downloads.sourceforge.net/dzcomm/dzcomm/0.9.9i/dz099i.zip
- source = https://www.scantool.net/scantool/downloads/82/scantool_net121src.zip
- source = http://http.debian.net/debian/pool/main/s/scantool/scantool_1.21+dfsg-5.debian.tar.xz
- md5sums = 2540dd366cf08de2ff1a97880315e921
- md5sums = c87b53a2d3bbc4ee1f29245be9412457
- md5sums = 8ff409e7e83aebc8af66249e2eb30577
+ source = https://github.com/kees/scantool/archive/v2.0.tar.gz
+ sha256sums = b47d5a5f02bda5d2102292e23b0e31178046689fbd651239faddac61c29caf45
pkgname = scantool
diff --git a/PKGBUILD b/PKGBUILD
index 4ccc7bb63550..b7eaae2382c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,21 @@
pkgname=scantool
-pkgver=1.21
+pkgver=2.0
pkgrel=1
pkgdesc="OBD-II vehicle diagnostic scanner"
arch=('i686' 'x86_64')
-url="http://www.scantool.net"
+url="https://github.com/kees/scantool"
license=('GPL')
makedepends=('dos2unix')
depends=('allegro4')
-source=("http://downloads.sourceforge.net/dzcomm/dzcomm/0.9.9i/dz099i.zip"
- "https://www.scantool.net/scantool/downloads/82/scantool_net121src.zip"
- "http://http.debian.net/debian/pool/main/s/scantool/scantool_1.21+dfsg-5.debian.tar.xz")
-md5sums=('2540dd366cf08de2ff1a97880315e921'
- 'c87b53a2d3bbc4ee1f29245be9412457'
- '8ff409e7e83aebc8af66249e2eb30577')
-noextract=('scantool_net121src.zip')
-
-prepare () {
- pushd dz099i
- find . -type f -print0 | xargs -0 dos2unix
- patch -p2 -i "${srcdir}"/debian/patches/dzcomm-usb-serial.patch
- patch -p2 -i "${srcdir}"/debian/patches/kfreebsd-build-fixes.patch
- patch -p2 -i "${srcdir}"/debian/patches/build-flags.patch
- autoreconf
- CFLAGS="-DALLEGRO_NO_FIX_ALIASES $CFLAGS"
- sh ./configure
- chmod a+x misc/*.sh
- popd
-
- mkdir -p ${pkgname}-${pkgver} && cd ${pkgname}-${pkgver}
- bsdtar xf "${srcdir}"/scantool_net121src.zip
- cp -r "${srcdir}"/debian .
- patch -p1 -i debian/patches/scantool-linux-build.patch
- patch -p1 -i debian/patches/logging-newlines.patch
- patch -p1 -i debian/patches/drop-listports.patch
- patch -p1 -i debian/patches/allow-elm327-clones.patch
- patch -p1 -i debian/patches/drop-report-request.patch
- patch -p1 -i debian/patches/multi-code.patch
-}
+source=("https://github.com/kees/scantool/archive/v2.0.tar.gz")
+sha256sums=('b47d5a5f02bda5d2102292e23b0e31178046689fbd651239faddac61c29caf45')
build() {
- cd dz099i
- make depend
- make lib
-
cd "${srcdir}"/${pkgname}-${pkgver}
- make CFLAGS="$CPPFLAGS $CFLAGS -I../dz099i/include -DDZCOMM_DJGPP=1" LDFLAGS="$LDFLAGS -L../dz099i/lib/unix"
- cd "${srcdir}"/${pkgname}-${pkgver}
- make -C debian/codes
+ make
}
-
package () {
- install -d "${pkgdir}"/usr/bin
- install -m755 "${srcdir}"/${pkgname}-${pkgver}/${pkgname} "${pkgdir}"/usr/bin/scantool-net
- install -d "${pkgdir}"/usr/share/scantool
- install -m644 "${srcdir}"/${pkgname}-${pkgver}/${pkgname}.dat "${pkgdir}"/usr/share/scantool
- install -m644 "${srcdir}"/${pkgname}-${pkgver}/debian/codes/codes.dat "${pkgdir}"/usr/share/scantool
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make install DESTDIR="${pkgdir}"
}
-