summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2018-04-11 18:31:42 +0200
committerCarsten Teibes2018-04-11 18:31:42 +0200
commit3ace00801fadd6b822d497dcab72fed14e15c4d9 (patch)
treefcb9986acce0ac119db5f53acfbd582d6f95753f
parent7e6f606be5cb4d4061c7245fcc9ad0acac4edb17 (diff)
downloadaur-3ace00801fadd6b822d497dcab72fed14e15c4d9.tar.gz
[upd] 0.64.13→0.64.15
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--raine-gcc7-abs.patch32
3 files changed, 8 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac71e426bf58..a01b64a0d6e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raine
pkgdesc = A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo
- pkgver = 0.64.13
+ pkgver = 0.64.15
pkgrel = 1
url = http://raine.1emulation.com/
arch = i686
@@ -15,12 +15,10 @@ pkgbase = raine
optdepends = arcade-command-dat: database with button combinations for special moves in (mostly fighting) games
replaces = neoraine
options = emptydirs
- source = raine-0.64.13.tar.gz::https://github.com/zelurker/raine/archive/0.64.13.tar.gz
+ source = raine-0.64.15.tar.gz::https://github.com/zelurker/raine/archive/0.64.15.tar.gz
source = http://raine.1emulation.com//archive/debian/dists/unstable/main/binary-i386/raine_0.64.13_i386.deb
- source = raine-gcc7-abs.patch
- sha256sums = 0af13e67744ac81f987687a3f83703bc844897a6a1b828a19d82f96dfe8ab719
+ sha256sums = 7aabe3138bd41e95b586a48a29c4d8bf68ff44aeb44d54dae0899c2f4aba6542
sha256sums = 71414fc61c1d26eeccfab4f7319ba9efce19b8276151d3a119fd86c3db0a172b
- sha256sums = 396eecb13c8546b55f98094a69dbe8ccab79855e2a3eca58397aedc72308bd59
depends_i686 = sdl_ttf
depends_i686 = sdl_image
depends_i686 = sdl_sound
diff --git a/PKGBUILD b/PKGBUILD
index 2fb34baedf57..e61972ff9423 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=raine
-pkgver=0.64.13
+pkgver=0.64.15
pkgrel=1
pkgdesc="A multiple arcade emulator focused on 680x0 machines like NeoCD and Neo Geo"
url="http://raine.1emulation.com/"
@@ -20,11 +20,9 @@ optdepends=('raine-artwork: additional background graphics for some games'
'arcade-history-dat: database with various information about the loaded rom'
'arcade-command-dat: database with button combinations for special moves in (mostly fighting) games')
source=(raine-$pkgver.tar.gz::"https://github.com/zelurker/raine/archive/$pkgver.tar.gz"
- "$url/archive/debian/dists/unstable/main/binary-i386/raine_${pkgver}_i386.deb"
- "raine-gcc7-abs.patch")
-sha256sums=('0af13e67744ac81f987687a3f83703bc844897a6a1b828a19d82f96dfe8ab719'
- '71414fc61c1d26eeccfab4f7319ba9efce19b8276151d3a119fd86c3db0a172b'
- '396eecb13c8546b55f98094a69dbe8ccab79855e2a3eca58397aedc72308bd59')
+ "$url/archive/debian/dists/unstable/main/binary-i386/raine_0.64.13_i386.deb")
+sha256sums=('7aabe3138bd41e95b586a48a29c4d8bf68ff44aeb44d54dae0899c2f4aba6542'
+ '71414fc61c1d26eeccfab4f7319ba9efce19b8276151d3a119fd86c3db0a172b')
options=('emptydirs')
prepare() {
@@ -33,7 +31,7 @@ prepare() {
bsdtar xf data.tar.xz -C raine-bin
cd raine-$pkgver
- # copy bitmaps and fonts from raine's deb package
+ # copy bitmaps and fonts from raine's old deb package
cp -rup "$srcdir"/raine-bin/usr/share/games/raine/bitmaps .
cp -rup "$srcdir"/raine-bin/usr/share/games/raine/fonts .
@@ -50,9 +48,6 @@ prepare() {
# 'detect-cpu' script does not recognize most recent cpus, use generic optimizing
echo "_MARCH=-march=${CARCH/x86_64/x86-64} -mtune=generic" > cpuinfo
echo "CPU=generic" >> cpuinfo
-
- # gcc7 compatibility
- patch -p1 < "$srcdir"/raine-gcc7-abs.patch
}
build() {
@@ -66,7 +61,5 @@ package() {
install -d "$pkgdir"/usr/share/{doc,licenses}/raine
install -m644 docs/* changes/* "$pkgdir"/usr/share/doc/raine
head -n5 source/raine.c > "$pkgdir"/usr/share/licenses/raine/LICENSE
- # deprecate neoraine, both projects have been merged
- ln -s raine "$pkgdir"/usr/bin/neoraine
rm "$pkgdir"/usr/share/{applications,pixmaps}/neoraine.*
}
diff --git a/raine-gcc7-abs.patch b/raine-gcc7-abs.patch
deleted file mode 100644
index 42af74051024..000000000000
--- a/raine-gcc7-abs.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur raine-0.64.13.orig/source/sdl/console/exec.cpp raine-0.64.13/source/sdl/console/exec.cpp
---- raine-0.64.13.orig/source/sdl/console/exec.cpp 2016-05-19 13:03:43.000000000 +0200
-+++ raine-0.64.13/source/sdl/console/exec.cpp 2017-06-27 14:06:46.650802838 +0200
-@@ -73,7 +73,7 @@
- } else {
- int adr = parse(argv[1]),n;
- for (n=0; n<used_break; n++) {
-- if (abs(adr-breakp[n].adr)<2) {
-+ if (abs((int)(adr-breakp[n].adr))<2) {
- if (cons) cons->print("already have a breakpoint at %x",breakp[n].adr);
- return;
- }
-diff -Naur raine-0.64.13.orig/source/sdl/gui/tfont.cpp raine-0.64.13/source/sdl/gui/tfont.cpp
---- raine-0.64.13.orig/source/sdl/gui/tfont.cpp 2016-05-19 13:03:43.000000000 +0200
-+++ raine-0.64.13/source/sdl/gui/tfont.cpp 2017-06-27 14:01:36.537194579 +0200
-@@ -73,14 +73,14 @@
- // 1st look for height
- while ((entry = readdir(dir))) {
- get_font_dimensions(entry->d_name,&w,&h);
-- if (abs(h-ideal_height) < abs(besth - ideal_height))
-+ if (abs((int)(h-ideal_height)) < abs((int)(besth - ideal_height)))
- besth = h;
- }
- rewinddir(dir);
- // Now look for the best width with this height
- while ((entry = readdir(dir))) {
- get_font_dimensions(entry->d_name,&w,&h);
-- if (h == besth && (abs(w-ideal_width) < abs(bestw-ideal_width))) {
-+ if (h == besth && (abs((int)(w-ideal_width)) < abs((int)(bestw-ideal_width)))) {
- strcpy(selected, entry->d_name);
- bestw = w;
- }