summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2022-01-31 14:11:11 +0100
committerTorben2022-01-31 14:11:11 +0100
commit3aedb65015e15a91a49d1ba7249fafc40f92998b (patch)
treeb070d404e495c575e6d5e591a7eff02dc7418db2
parentc6c0db3cd2bbb551756cea45eec5f9ca3ceecfa8 (diff)
downloadaur-3aedb65015e15a91a49d1ba7249fafc40f92998b.tar.gz
Upgrade to 4.0b4; Remove JFX related patches
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
-rw-r--r--fix_theme_engine.patch20
-rw-r--r--no_jdk_download.patch35
-rw-r--r--no_jfx_download.patch11
-rw-r--r--use_system_jdk.patch20
-rw-r--r--use_system_libraries.patch26
7 files changed, 27 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c130012b2f8b..7bf4a10a46ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = processing4
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = 4.0b3
- pkgrel = 3
+ pkgver = 4.0b4
+ pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
license = GPL
@@ -10,29 +10,20 @@ pkgbase = processing4
makedepends = gendesk
makedepends = rsync
makedepends = unzip
- depends = jdk-openjdk
- depends = java-openjfx
+ depends = java-environment-openjdk=17
provides = processing
provides = processing4
conflicts = processing
options = !strip
- source = https://github.com/processing/processing4/archive/processing-1278-4.0b3.tar.gz
+ source = https://github.com/processing/processing4/archive/processing-1279-4.0b4.tar.gz
source = disable_update_check.patch
source = get_reference_via_https.patch
- source = fix_theme_engine.patch
source = no_ffmpeg_download.patch
source = no_jdk_download.patch
- source = no_jfx_download.patch
- source = use_system_jdk.patch
- source = use_system_libraries.patch
- sha256sums = 1f328895ca20b7b077f10faaac8d342f985c3ae80133b2384324c02ffbd185da
+ sha256sums = 37d120f1a347b61a53266b8c5a72e18e8e5d4dd8c21d66f97c1b6f91aeac7996
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
- sha256sums = 1d549cf94d033e572050f85a59c6ba526aee2bce6b4c96e8b55764136e6c21b5
- sha256sums = 24b8a3e18b6e3a0de9422e4dbde46cceb91385f7ad6bdc89ec0a9614e082c977
+ sha256sums = 970cab09bb2d22f9a72415d626ab77714b31b2727c51e4d8992eeee4f7f3645d
sha256sums = b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126
- sha256sums = c390900419ac9ad188700075a09b658f672d2f3471c8ced0be4f3008ee375d5f
- sha256sums = dc733c1cb5a41cb06ef0f9ea01d701fd9ac7713b5817b4fe79d7076a505a7c44
- sha256sums = d2877ad894f76594675534026ee91581f6357a3892afe2fd0efcf86de746c7cb
- sha256sums = 15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb
+ sha256sums = 5c3314d6a63955fa472aa87c6c99a9675eed3db9c589b784593c9f14432ef201
pkgname = processing4
diff --git a/PKGBUILD b/PKGBUILD
index dd597df3026f..45278c906c31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4
-pkgver=4.0b3
-pkgrel=3
+pkgver=4.0b4
+pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
url='https://github.com/processing/processing4'
license=(GPL LGPL)
provides=('processing' 'processing4')
conflicts=('processing')
-depends=( 'jdk-openjdk' 'java-openjfx')
+depends=('java-environment-openjdk=17')
makedepends=('ant' 'gendesk' 'rsync' 'unzip')
options=(!strip)
source=("https://github.com/processing/processing4/archive/processing-$((1275+${pkgver##4.0b}))-$pkgver.tar.gz"
disable_update_check.patch
get_reference_via_https.patch
- fix_theme_engine.patch
no_ffmpeg_download.patch
- no_jdk_download.patch
- no_jfx_download.patch
- use_system_jdk.patch
- use_system_libraries.patch)
-sha256sums=('1f328895ca20b7b077f10faaac8d342f985c3ae80133b2384324c02ffbd185da'
+ no_jdk_download.patch)
+sha256sums=('37d120f1a347b61a53266b8c5a72e18e8e5d4dd8c21d66f97c1b6f91aeac7996'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
- '1d549cf94d033e572050f85a59c6ba526aee2bce6b4c96e8b55764136e6c21b5'
- '24b8a3e18b6e3a0de9422e4dbde46cceb91385f7ad6bdc89ec0a9614e082c977'
+ '970cab09bb2d22f9a72415d626ab77714b31b2727c51e4d8992eeee4f7f3645d'
'b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126'
- 'c390900419ac9ad188700075a09b658f672d2f3471c8ced0be4f3008ee375d5f'
- 'dc733c1cb5a41cb06ef0f9ea01d701fd9ac7713b5817b4fe79d7076a505a7c44'
- 'd2877ad894f76594675534026ee91581f6357a3892afe2fd0efcf86de746c7cb'
- '15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb')
+ '5c3314d6a63955fa472aa87c6c99a9675eed3db9c589b784593c9f14432ef201')
prepare() {
# Symbolic link for not having to repeat the revision number
@@ -40,19 +32,11 @@ prepare() {
# Don't download JDK and JFX files during Ant's build process
patch $pkgname/build/build.xml < no_jdk_download.patch
- patch $pkgname/java/libraries/javafx/build.xml < no_jfx_download.patch
patch $pkgname/build/shared/tools/MovieMaker/build.xml < no_ffmpeg_download.patch
# Ensure that reference.zip is downloaded via HTTPS
patch -p0 < get_reference_via_https.patch
- # Use system libraries during build process
- patch $pkgname/core/build.xml < use_system_libraries.patch
- patch $pkgname/build/shared/tools/ThemeEngine/build.xml < fix_theme_engine.patch
-
- # Use system JDK to start processing
- patch $pkgname/build/linux/processing < use_system_jdk.patch
-
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
}
diff --git a/fix_theme_engine.patch b/fix_theme_engine.patch
deleted file mode 100644
index 231d12d5ffc0..000000000000
--- a/fix_theme_engine.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build/shared/tools/ThemeEngine/build.xml
-+++ b/build/shared/tools/ThemeEngine/build.xml
-@@ -6,7 +6,7 @@
- <property name="core.bin.path" location="../../../../core/bin" />
-
- <property name="javafx.path"
-- location="../../../../java/libraries/javafx/library/macosx" />
-+ location="/usr/lib/jvm/java-17-openjdk/lib/" />
-
- <target name="clean" description="Clean the build directories">
- <delete dir="bin" />
-@@ -26,7 +26,7 @@
- <pathelement location="${app.bin.path}" />
- <pathelement location="${core.bin.path}" />
-
-- <fileset dir="${javafx.path}/modules">
-+ <fileset dir="${javafx.path}">
- <include name="**/*.jar" />
- </fileset>
- </classpath>
diff --git a/no_jdk_download.patch b/no_jdk_download.patch
index f76c1a58bb05..314c954025b2 100644
--- a/no_jdk_download.patch
+++ b/no_jdk_download.patch
@@ -1,30 +1,30 @@
---- build.xml.orig 2022-01-20 10:53:16.417109453 +0100
-+++ build.xml.mod 2022-01-20 10:51:11.613210989 +0100
-@@ -1024,7 +1024,7 @@
+--- a/build/build.xml 2022-01-31 12:44:46.824038995 +0100
++++ b/build/build.xml 2022-01-31 12:47:21.567810435 +0100
+@@ -940,7 +940,7 @@
</if>
</target>
-- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
-+ <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
+- <target name="linux-build" depends="revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-rpi" description="Build Linux version">
++ <target name="linux-build" depends="revision-check, linux-check-os, subprojects-build, subprojects-build-rpi" description="Build Linux version">
<mkdir dir="linux/work" />
<copy todir="linux/work" preservelastmodified="true">
-@@ -1111,54 +1111,6 @@
+@@ -1014,45 +1014,6 @@
<copy file="linux/processing-pde.xml" todir="linux/work/lib" />
<copy file="linux/appdata.xml" todir="linux/work/lib" />
<copy file="linux/desktop.template" todir="linux/work/lib" />
-
--<!--
+- <!--
- Cannot use ant version of tar because it doesn't preserve properties.
- <untar compression="gzip"
- dest="linux/work"
- src="linux/jdk.tgz"
- overwrite="false"/>
---->
+- -->
-
--<!--
-- http://www.gnu.org/software/tar/manual/html_section/transform.html
---->
+- <!--
+- http://www.gnu.org/software/tar/manual/html_section/transform.html
+- -->
- <exec executable="tar" dir="linux">
- <!-- Change directory -->
- <!--
@@ -36,12 +36,10 @@
- <arg value="../${jdk.archive.path}"/>
- </exec>
-
-- <property name="jdk.dir" value="jdk-${jdk.detail}+${jdk.build}/" />
--
- <exec executable="rsync" dir="linux">
- <arg value="-a" />
- <arg value="--delete" />
-- <arg value="${jdk.dir}" />
+- <arg value="${jdk.folder}/" />
- <arg value="work/java/" />
- </exec>
-
@@ -52,15 +50,8 @@
-
- <exec executable="rm">
- <arg value="-r"/>
-- <arg line="linux/jdk-${jdk.detail}+${jdk.build}"/>
+- <arg line="linux/${jdk.folder}"/>
- </exec>
--
-- <!--
-- <exec executable="rm">
-- <arg value="-r"/>
-- <arg line="${jfx.path.dist}"/>
-- </exec>
-- -->
</target>
<target name="linux-run" depends="linux-build"
diff --git a/no_jfx_download.patch b/no_jfx_download.patch
deleted file mode 100644
index d000da10b992..000000000000
--- a/no_jfx_download.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/java/libraries/javafx/build.xml
-+++ b/java/libraries/javafx/build.xml
-@@ -167,7 +167,6 @@
- nowarn="true" />
- </target>
-
-- <target name="build" depends="compile" description="Build JavaFX renderer">
-- <jar basedir="bin" destfile="library/javafx.jar" />
-+ <target name="build" description="Build JavaFX renderer">
- </target>
- </project>
diff --git a/use_system_jdk.patch b/use_system_jdk.patch
deleted file mode 100644
index 5ac14aec6ce9..000000000000
--- a/use_system_jdk.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build/linux/processing
-+++ b/build/linux/processing
-@@ -66,7 +66,7 @@ APPDIR=`dirname "$APPDIR"`
- log APPDIR
-
- # Try using a local JDK from the same directory as this script
--JDKDIR=`readlink -f "$APPDIR/java"`
-+JDKDIR=`readlink -f /usr/lib/jvm/java-17-openjdk`
- make_jdkcp "$JDKDIR"
- log SUCCESS
-
-@@ -113,6 +113,6 @@ else
- fi
- cd "$APPDIR"
-
-- #java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64/modules --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing,javafx.web -Xmx512m processing.app.Base "$SKETCH" &
-- java -Djna.nosys=true -Dpython.console.encoding=UTF-8 -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64/modules --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing,javafx.web -Xmx512m processing.app.ui.Splash "$SKETCH" &
-+ #java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:/usr/lib/jvm/java-17-openjdk/lib --module-path=/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.web -Xmx512m processing.app.Base "$SKETCH" &
-+ java -Djna.nosys=true -Dpython.console.encoding=UTF-8 -Djava.library.path=lib:/usr/lib/jvm/java-17-openjdk/lib --module-path=/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.web -Xmx512m processing.app.ui.Splash "$SKETCH" &
- fi
diff --git a/use_system_libraries.patch b/use_system_libraries.patch
deleted file mode 100644
index 67d2871b301b..000000000000
--- a/use_system_libraries.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/core/build.xml b/core/build.xml
-index db633fff9..f984ae71c 100644
---- a/core/build.xml
-+++ b/core/build.xml
-@@ -66,14 +66,14 @@
- <pathelement location="library/gluegen-rt.jar" />
-
- <!-- <pathelement location="library/javafx-swt.jar" /> -->
-- <pathelement location="library/javafx.base.jar" />
-- <pathelement location="library/javafx.controls.jar" />
-- <pathelement location="library/javafx.fxml.jar" />
-- <pathelement location="library/javafx.graphics.jar" />
-- <pathelement location="library/javafx.media.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar" />
- <!-- error? it's not a .jar, but is this how config is handled? [fry 210619] -->
-- <pathelement location="library/javafx.properties" />
-- <pathelement location="library/javafx.swing.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.properties" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar" />
- <!-- <pathelement location="library/javafx.web.jar" /> -->
- </path>
-