summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Fuhry2024-03-06 11:37:26 -0500
committerDan Fuhry2024-03-06 11:37:26 -0500
commit3b12cd64a0c9fbbb4769a5eb6ff9197eb0b7b8d7 (patch)
tree6fa6817326025e056e6a04bfd6e063539b853154
parentdbbc0aff586f01657c81d42b01ed5f140aafb64e (diff)
downloadaur-3b12cd64a0c9fbbb4769a5eb6ff9197eb0b7b8d7.tar.gz
updpkg: envoyproxy-1.29.1-1
- add patch from https://github.com/envoyproxy/envoy/pull/31894 in lieu of disabling `-fno-sized-deallocation` - update to upstream release v1.29.1 - sync patches
-rw-r--r--.SRCINFO18
-rw-r--r--0001-arch-dynamically-link-libpsl.patch16
-rw-r--r--0002-luajit-use-correct-make-binary.patch48
-rw-r--r--0002-patch-cel-cpp-to-not-break-build.patch78
-rw-r--r--PKGBUILD16
5 files changed, 99 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 572d58880be8..6b9472a22b65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = envoyproxy
pkgdesc = A high performance, open source, general RPC framework that puts mobile and HTTP/2 first.
- pkgver = 1.27.0
- pkgrel = 2
+ pkgver = 1.29.1
+ pkgrel = 1
url = https://envoyproxy.io
arch = i686
arch = x86_64
@@ -17,15 +17,11 @@ pkgbase = envoyproxy
makedepends = perl
makedepends = python
makedepends = libxcrypt-compat
- source = https://github.com/envoyproxy/envoy/archive/v1.27.0.tar.gz
+ source = https://github.com/envoyproxy/envoy/archive/v1.29.1.tar.gz
source = 0001-arch-dynamically-link-libpsl.patch
- source = 0002-luajit-use-correct-make-binary.patch
- source = 0003-close-http-connections-that-prematurely-reset-stream.patch
- source = 0004-limit-http-requests-per-io-cycle.patch
- sha512sums = de4d05962413d56f1ffcfe05266d1e3892bb48a6f313dda3dc34a436cec6631220b91a9d624c5f4f09653cf85f9498efec8bf5169ced4e527d55054788c7cc87
- sha512sums = 58f7f40a420e1dc7ba845c5349a7596126b4eecc39ca15ebb94fbfe9cd944109318e7577329242164d4dd4ae3a99359723f41dc7265a0334cba06e556c7e8be3
- sha512sums = 905643509ad1998c5bfe6854c97ad13cb1db1d981801876a98ca1c36cc93a63548501dd84e9f310735856095a097122756a68b7d0aea7797ac2e7f3f23d0bc99
- sha512sums = 9a5de75818a8bf93282328412650c3556d46404b8dcc1d39dc61cbe2148fdbd83363cfd8a146c106c68b98ad00b5907060575e23a3a3dc300597c983d72e5d79
- sha512sums = f444701ddc0bf447cc974b87f19b1f8ef3f148b46d727f163cc9bc4a313f21cf719b13dd228843125174f02f444dad975fd7d3017213ac8baefe06c4b41bb6b1
+ source = 0002-patch-cel-cpp-to-not-break-build.patch
+ sha512sums = 912caf9d305832998becb0990d02238d7aeb2d12cece0e1882d65288aaa236fb456e3a1d16ab7bb95d21d92b6e6d0f92ae985b6d42f1bc6e35ed67d25fb4823b
+ sha512sums = 82a695c4c5ebd3f154acd424e00c5b9be27d809ed895870650b1ea0d1a757104753c242b67718bb68eef128d507668af2a5c7b101a64c346f27a9d0d5ad33cb9
+ sha512sums = 6306c91abe482533dbc11aa4c39b0fc0ca145893c6692d56d5ecc77a8bf195e9495151c417ffa5d0702b85c0ad8a96133e1ec8fb01d04b1cdf5db9d71f51216f
pkgname = envoyproxy
diff --git a/0001-arch-dynamically-link-libpsl.patch b/0001-arch-dynamically-link-libpsl.patch
index 1d7f30d81333..fd712ec067d0 100644
--- a/0001-arch-dynamically-link-libpsl.patch
+++ b/0001-arch-dynamically-link-libpsl.patch
@@ -1,16 +1,16 @@
-diff -Naur envoy-1.26.2.a/.bazelrc envoy-1.26.2.b/.bazelrc
---- envoy-1.26.2.a/.bazelrc 2023-06-05 04:42:11.000000000 -0400
-+++ envoy-1.26.2.b/.bazelrc 2023-06-26 18:38:28.905340126 -0400
-@@ -58,7 +58,7 @@
+diff -Naur a/.bazelrc b/.bazelrc
+--- a/.bazelrc 2024-02-09 22:41:26.000000000 -0500
++++ b/.bazelrc 2024-02-14 13:22:15.574438344 -0500
+@@ -69,7 +69,7 @@
build:linux --fission=dbg,opt
build:linux --features=per_object_debug_info
build:linux --action_env=BAZEL_LINKLIBS=-l%:libstdc++.a
-build:linux --action_env=BAZEL_LINKOPTS=-lm
+build:linux --action_env=BAZEL_LINKOPTS=-lm:-lpsl
- # TODO(keith): remove once https://github.com/DataDog/dd-opentracing-cpp/pull/252 is integrated
- # this avoids warnings/errors on arm64 Linux builds
-@@ -170,7 +170,7 @@
+ # We already have absl in the build, define absl=1 to tell googletest to use absl for backtrace.
+ build --define absl=1
+@@ -188,7 +188,7 @@
build:libc++ --action_env=LDFLAGS=-stdlib=libc++
build:libc++ --action_env=BAZEL_CXXOPTS=-stdlib=libc++
build:libc++ --action_env=BAZEL_LINKLIBS=-l%:libc++.a:-l%:libc++abi.a
@@ -18,4 +18,4 @@ diff -Naur envoy-1.26.2.a/.bazelrc envoy-1.26.2.b/.bazelrc
+build:libc++ --action_env=BAZEL_LINKOPTS=-lm:-pthread:-lpsl
build:libc++ --define force_libcpp=enabled
- # Optimize build for binary size reduction.
+ build:libc++20 --config=libc++
diff --git a/0002-luajit-use-correct-make-binary.patch b/0002-luajit-use-correct-make-binary.patch
deleted file mode 100644
index 3bf8b20c660f..000000000000
--- a/0002-luajit-use-correct-make-binary.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From f61750d8b2983f211f5f3418c7fa48763dad0744 Mon Sep 17 00:00:00 2001
-From: Michael Kaufmann <michael.kaufmann@ergon.ch>
-Date: Fri, 25 Aug 2023 11:24:43 +0200
-Subject: [PATCH] build: use the correct "make" binary for building LuaJIT
-
-The "make" binary that is referenced by the environment variable "MAKE" must be
-used to build LuaJIT, not the "make" binary of the system.
-
-The build rules of "rules_foreign_cc" create an own "make" binary (currently
-GNU Make 4.3). The "MAKE" environment variable references this binary.
-
-LuaJIT's Makefile uses "make" recursively:
-
-default all $(INSTALL_DEP):
- @echo "==== Building LuaJIT $(VERSION) ===="
- $(MAKE) -C src
-
-This means that at this point, the "make" binary referenced by the "MAKE"
-environment variable will be invoked.
-
-The system's "make" binary may be newer than the "make" of "rules_foreign_cc"
-(e.g. GNU Make 4.4 vs GNU Make 4.3), and this can lead to errors, because the
-newer "make" passes information in the "MAKEFLAGS" environment variable to the
-older "make", and the older "make" does not understand this information:
-
-"internal error: invalid --jobserver-auth string 'fifo:/tmp/GMfifo359'. Stop."
-
-The solution is to build LuaJIT with a single version of GNU Make.
-
-Fixes https://github.com/envoyproxy/envoy/issues/28633
-
-Signed-off-by: Michael Kaufmann <michael.kaufmann@ergon.ch>
----
- bazel/foreign_cc/luajit.patch | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff -Naur a/bazel/foreign_cc/luajit.patch b/bazel/foreign_cc/luajit.patch
---- a/bazel/foreign_cc/luajit.patch 2023-07-26 13:15:12.000000000 -0400
-+++ b/bazel/foreign_cc/luajit.patch 2023-08-29 21:57:56.311852727 -0400
-@@ -166,7 +166,7 @@
- + with open("clang-asan-blocklist.txt", "w") as f:
- + f.write("fun:*\n")
- +
--+ os.system('make -j{} V=1 PREFIX="{}" install'.format(os.cpu_count(), args.prefix))
-++ os.system('"{}" -j{} V=1 PREFIX="{}" install'.format(os.environ["MAKE"], os.cpu_count(), args.prefix))
- +
- +def win_main():
- + src_dir = os.path.dirname(os.path.realpath(__file__))
diff --git a/0002-patch-cel-cpp-to-not-break-build.patch b/0002-patch-cel-cpp-to-not-break-build.patch
new file mode 100644
index 000000000000..439b0d88a58b
--- /dev/null
+++ b/0002-patch-cel-cpp-to-not-break-build.patch
@@ -0,0 +1,78 @@
+From e9ce2fe81ccd79938d6ca83deb7afa5af0425604 Mon Sep 17 00:00:00 2001
+From: Raven Black <ravenblack@dropbox.com>
+Date: Thu, 18 Jan 2024 16:34:15 +0000
+Subject: [PATCH] Patch cel-cpp to not break build
+
+Signed-off-by: Raven Black <ravenblack@dropbox.com>
+---
+ bazel/cel-cpp-memory.patch | 44 ++++++++++++++++++++++++++++++++++++++
+ bazel/repositories.bzl | 5 ++++-
+ 2 files changed, 48 insertions(+), 1 deletion(-)
+ create mode 100644 bazel/cel-cpp-memory.patch
+
+diff --git a/bazel/cel-cpp-memory.patch b/bazel/cel-cpp-memory.patch
+new file mode 100644
+index 0000000000000..84df54db60b82
+--- /dev/null
++++ b/bazel/cel-cpp-memory.patch
+@@ -0,0 +1,44 @@
++From 09a072b4bb5a75e1df15beba29a9f13b1948ff8b Mon Sep 17 00:00:00 2001
++From: Ivan Prisyazhnyy <john.koepi@gmail.com>
++Date: Thu, 18 Jan 2024 13:55:29 +0000
++Subject: [PATCH] Fix: use of sized deallocation in base/memory.h wo check
++
++Dependant projects that do not use `-fsized-deallocation`
++would not compile with the call to delete(void*, size_t, align).
++
++There are other places that already check for
++`defined(__cpp_sized_deallocation)` and this patch just shares
++this practice.
++
++Testing:
++
++ // fix .bazelrc to have:
++ build --cxxopt=-fno-sized-deallocation
++
++ $ bazel build --verbose_failures //base:\*
++
++Signed-off-by: Ivan Prisyazhnyy <john.koepi@gmail.com>
++---
++ base/memory.h | 8 +++++++-
++ 1 file changed, 7 insertions(+), 1 deletion(-)
++
++diff --git a/base/memory.h b/base/memory.h
++index 3552e19a..c310128a 100644
++--- a/base/memory.h
+++++ b/base/memory.h
++@@ -89,8 +89,14 @@ class Allocator {
++
++ void deallocate(pointer p, size_type n) {
++ if (!allocation_only_) {
++- ::operator delete(static_cast<void*>(p), n * sizeof(T),
+++#if defined(__cpp_sized_deallocation) && __cpp_sized_deallocation >= 201309L
+++ ::operator delete(static_cast<void *>(p), n * sizeof(T),
++ static_cast<std::align_val_t>(alignof(T)));
+++#else
+++ ::operator delete(static_cast<void *>(p),
+++ static_cast<std::align_val_t>(alignof(T)));
+++ static_cast<void>(n); // unused
+++#endif
++ }
++ }
++
+diff --git a/bazel/repositories.bzl b/bazel/repositories.bzl
+index aa93c9c838d8a..3220aeb2ecb18 100644
+--- a/bazel/repositories.bzl
++++ b/bazel/repositories.bzl
+@@ -702,7 +702,10 @@ def _com_github_facebook_zstd():
+ def _com_google_cel_cpp():
+ external_http_archive(
+ "com_google_cel_cpp",
+- patches = ["@envoy//bazel:cel-cpp.patch"],
++ patches = [
++ "@envoy//bazel:cel-cpp.patch",
++ "@envoy//bazel:cel-cpp-memory.patch",
++ ],
+ patch_args = ["-p1"],
+ )
+
diff --git a/PKGBUILD b/PKGBUILD
index 8c8d726d11de..4be2f32aa32e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Dan Fuhry <dan@fuhry.com>
pkgname=envoyproxy
-pkgver=1.27.0
-pkgrel=2
+pkgver=1.29.1
+pkgrel=1
pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
arch=('i686' 'x86_64')
url='https://envoyproxy.io'
@@ -26,15 +26,11 @@ makedepends=(
source=(
"https://github.com/$pkgname/envoy/archive/v$pkgver.tar.gz"
0001-arch-dynamically-link-libpsl.patch
- 0002-luajit-use-correct-make-binary.patch
- 0003-close-http-connections-that-prematurely-reset-stream.patch
- 0004-limit-http-requests-per-io-cycle.patch
+ 0002-patch-cel-cpp-to-not-break-build.patch
)
-sha512sums=('de4d05962413d56f1ffcfe05266d1e3892bb48a6f313dda3dc34a436cec6631220b91a9d624c5f4f09653cf85f9498efec8bf5169ced4e527d55054788c7cc87'
- '58f7f40a420e1dc7ba845c5349a7596126b4eecc39ca15ebb94fbfe9cd944109318e7577329242164d4dd4ae3a99359723f41dc7265a0334cba06e556c7e8be3'
- '905643509ad1998c5bfe6854c97ad13cb1db1d981801876a98ca1c36cc93a63548501dd84e9f310735856095a097122756a68b7d0aea7797ac2e7f3f23d0bc99'
- '9a5de75818a8bf93282328412650c3556d46404b8dcc1d39dc61cbe2148fdbd83363cfd8a146c106c68b98ad00b5907060575e23a3a3dc300597c983d72e5d79'
- 'f444701ddc0bf447cc974b87f19b1f8ef3f148b46d727f163cc9bc4a313f21cf719b13dd228843125174f02f444dad975fd7d3017213ac8baefe06c4b41bb6b1')
+sha512sums=('912caf9d305832998becb0990d02238d7aeb2d12cece0e1882d65288aaa236fb456e3a1d16ab7bb95d21d92b6e6d0f92ae985b6d42f1bc6e35ed67d25fb4823b'
+ '82a695c4c5ebd3f154acd424e00c5b9be27d809ed895870650b1ea0d1a757104753c242b67718bb68eef128d507668af2a5c7b101a64c346f27a9d0d5ad33cb9'
+ '6306c91abe482533dbc11aa4c39b0fc0ca145893c6692d56d5ecc77a8bf195e9495151c417ffa5d0702b85c0ad8a96133e1ec8fb01d04b1cdf5db9d71f51216f')
prepare() {
cd "envoy-$pkgver"