summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-01-31 10:38:55 +0100
committerKlaus Alexander Seistrup2023-01-31 10:38:55 +0100
commit3b28ba5b78ce088c9fc503020f8cdd07e45b77e0 (patch)
tree92b5f9a3d3b985efed91e1a450ae239d392a5d51
downloadaur-3b28ba5b78ce088c9fc503020f8cdd07e45b77e0.tar.gz
Initial AUR commit (upstream v0.5.2)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3537ec15561c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mdsilo-bin
+ pkgdesc = Local-first, lightweight personal wiki, RSS and podcast client (pre-compiled)
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://mdsilo.com/
+ arch = x86_64
+ license = MIT
+ depends = webkit2gtk
+ provides = mdsilo
+ conflicts = mdsilo
+ source = https://github.com/mdSilo/mdSilo/releases/download/app-v0.5.2/mdsilo_0.5.2_amd64.deb
+ source = https://raw.githubusercontent.com/mdSilo/mdSilo/main/LICENSE
+ sha256sums = 64085d08fc16b1bf88e2509586818cea2d2a3f87cbe93ba286bc83b6f34ce0c7
+ sha256sums = SKIP
+ sha512sums = 6c12bc9cdacded53ad545a8ef7cf86daeea146aa118af3b78e00cfb26cf407db607ab26f242facc1068e00103eddd81936d0df395b7aa62ec601e7abe4aff105
+ sha512sums = SKIP
+ b2sums = 678fabcadbf12c396f3c155eb8cc18e914f457b987b9638662b03652b70d311577ee6d19b4a6723cb83458cbbfdb8197ec04a0a73946b8080ee6900eaf1132af
+ b2sums = SKIP
+
+pkgname = mdsilo-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52bb55287892
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Klaus Alexander Seistrup <klaus@seistrup.dk>
+# -*- sh -*-
+
+pkgname='mdsilo-bin'
+_pkgname="${pkgname%%-bin}"
+pkgver=0.5.2
+pkgrel=1
+pkgdesc='Local-first, lightweight personal wiki, RSS and podcast client (pre-compiled)'
+arch=('x86_64')
+url='https://mdsilo.com/'
+_url='https://github.com/mdSilo/mdSilo'
+_rawurl='https://raw.githubusercontent.com/mdSilo/mdSilo'
+license=('MIT')
+depends=('webkit2gtk')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "$_url/releases/download/app-v$pkgver/${_pkgname}_${pkgver}_amd64.deb"
+ "$_rawurl/main/LICENSE"
+)
+
+package() {
+ bsdtar -xf "$srcdir/data.tar.gz" -C "$pkgdir"
+ chown -R root:root "$pkgdir/usr"
+ install -Dm0644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha256sums=(
+ '64085d08fc16b1bf88e2509586818cea2d2a3f87cbe93ba286bc83b6f34ce0c7'
+ SKIP
+)
+sha512sums=(
+ '6c12bc9cdacded53ad545a8ef7cf86daeea146aa118af3b78e00cfb26cf407db607ab26f242facc1068e00103eddd81936d0df395b7aa62ec601e7abe4aff105'
+ SKIP
+)
+b2sums=(
+ '678fabcadbf12c396f3c155eb8cc18e914f457b987b9638662b03652b70d311577ee6d19b4a6723cb83458cbbfdb8197ec04a0a73946b8080ee6900eaf1132af'
+ SKIP
+)
+
+# eof