summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:36:05 +0800
committerSukanka2022-06-06 01:36:05 +0800
commit3b368ee76d0e73cde7a423e8e524655b71a79630 (patch)
tree81734b20d7a5a72a6e896d2bc57156a709e0b540
downloadaur-3b368ee76d0e73cde7a423e8e524655b71a79630.tar.gz
add r-annotationhub
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD62
2 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d531a7b9239b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = r-annotationhub
+ pkgdesc = Client to access AnnotationHub resources
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/AnnotationHub
+ arch = x86_64
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-biocfilecache
+ depends = r-biocgenerics
+ depends = r-biocmanager
+ depends = r-biocversion
+ depends = r-curl
+ depends = r-dplyr
+ depends = r-httr
+ depends = r-interactivedisplaybase
+ depends = r-rappdirs
+ depends = r-rsqlite
+ depends = r-s4vectors
+ depends = r-yaml
+ optdepends = r-annotationforge
+ optdepends = r-annotationhubdata
+ optdepends = r-biocstyle
+ optdepends = r-biostrings
+ optdepends = r-experimenthub
+ optdepends = r-gdsfmt
+ optdepends = r-genomeinfodb
+ optdepends = r-genomicfeatures
+ optdepends = r-genomicranges
+ optdepends = r-hubpub
+ optdepends = r-iranges
+ optdepends = r-knitr
+ optdepends = r-msnbase
+ optdepends = r-mzr
+ optdepends = r-rbiopaxparser
+ optdepends = r-rmarkdown
+ optdepends = r-rsamtools
+ optdepends = r-rtracklayer
+ optdepends = r-runit
+ optdepends = r-summarizedexperiment
+ optdepends = r-variantannotation
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/AnnotationHub_3.4.0.tar.gz
+ sha256sums = bacb8e2c4f14168087aa5c463902f3f910acf27d224c4ad2ee69eb3c485fb50d
+
+pkgname = r-annotationhub
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1e5add7692c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=AnnotationHub
+_pkgver=3.4.0
+pkgname=r-${_pkgname,,}
+pkgver=3.4.0
+pkgrel=1
+pkgdesc='Client to access AnnotationHub resources'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-biocfilecache
+ r-biocgenerics
+ r-biocmanager
+ r-biocversion
+ r-curl
+ r-dplyr
+ r-httr
+ r-interactivedisplaybase
+ r-rappdirs
+ r-rsqlite
+ r-s4vectors
+ r-yaml
+)
+optdepends=(
+ r-annotationforge
+ r-annotationhubdata
+ r-biocstyle
+ r-biostrings
+ r-experimenthub
+ r-gdsfmt
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-hubpub
+ r-iranges
+ r-knitr
+ r-msnbase
+ r-mzr
+ r-rbiopaxparser
+ r-rmarkdown
+ r-rsamtools
+ r-rtracklayer
+ r-runit
+ r-summarizedexperiment
+ r-variantannotation
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('bacb8e2c4f14168087aa5c463902f3f910acf27d224c4ad2ee69eb3c485fb50d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: