summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormortzu2021-03-03 19:29:00 +0100
committermortzu2021-03-03 19:29:00 +0100
commit3b5b7948b5a97f2c30758239c658c1586476cb2b (patch)
tree777dfc21e89dfa16d7bda2db4b208348202b5ce5
parentca9183982ba961141d8e5594a0bf6ff7e060aa89 (diff)
downloadaur-3b5b7948b5a97f2c30758239c658c1586476cb2b.tar.gz
Added GCC10 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--gcc10-fix.patch11
-rw-r--r--vadriverinit-fix.patch13
4 files changed, 37 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb456a35287..17d27ce71b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,11 @@ pkgbase = intel-hybrid-codec-driver
depends = libcmrt
optdepends = libva-intel-driver-hybrid: To be able to use the full hw codecs with hybrid codecs
source = intel-hybrid-driver::git+https://github.com/01org/intel-hybrid-driver.git
+ source = gcc10-fix.patch
+ source = vadriverinit-fix.patch
sha256sums = SKIP
+ sha256sums = 90c01a1771f90007b001057edd4ada66751e54ccc380b3d87672694ab7ea92cb
+ sha256sums = 5359cfa322403bad1a20dc55de290c5f5c2f8d56afeba9c4a84dfc35cc89ec8b
pkgname = intel-hybrid-codec-driver
diff --git a/PKGBUILD b/PKGBUILD
index b0aec0e7adf4..a81da2300478 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Bay Trail M (BYT) vp8enc
# Broadwell (BRW) vp9dec vp9enc
# Braswell (BSW) vp8enc vp9dec
-#
+#
#
# The libva-intel-driver package isn't compiled with support for loading this driver
# so in order to use this driver's features with non hybrid codecs either
@@ -27,8 +27,12 @@ license=('MIT')
depends=('libva' 'libcmrt')
optdepends=('libva-intel-driver-hybrid: To be able to use the full hw codecs with hybrid codecs')
makedepends=('git')
-source=("$_gitname::$_gitroot")
-sha256sums=('SKIP')
+source=("$_gitname::$_gitroot"
+ 'gcc10-fix.patch'
+ 'vadriverinit-fix.patch')
+sha256sums=('SKIP'
+ '90c01a1771f90007b001057edd4ada66751e54ccc380b3d87672694ab7ea92cb'
+ '5359cfa322403bad1a20dc55de290c5f5c2f8d56afeba9c4a84dfc35cc89ec8b')
pkgver() {
cd ${srcdir}/$_gitname
@@ -37,6 +41,8 @@ pkgver() {
prepare() {
cd ${srcdir}/${_gitname}
+ patch -p1 -i ${srcdir}/gcc10-fix.patch
+ patch -p1 -i ${srcdir}/vadriverinit-fix.patch
autoreconf -v --install
}
diff --git a/gcc10-fix.patch b/gcc10-fix.patch
new file mode 100644
index 000000000000..0c170579857f
--- /dev/null
+++ b/gcc10-fix.patch
@@ -0,0 +1,11 @@
+--- intel-hybrid-driver/src/media_drv_common.h 2020-05-26 23:18:02.279795861 +0100
++++ intel-hybrid-driver-new/src/media_drv_common.h 2020-05-26 23:19:11.316101524 +0100
+@@ -39,6 +39,6 @@
+ #define BRC_INIT_IGNORE_PICTURE_HEADER_SIZE 0x2000
+ #define BRC_INIT_DISABLE_MBBRC 0x8000
+
+-UINT SEARCH_PATH_TABLE[2][8][16];
+-UINT ME_CURBE_INIT_DATA[30];
++extern UINT SEARCH_PATH_TABLE[2][8][16];
++extern UINT ME_CURBE_INIT_DATA[30];
+ #endif
diff --git a/vadriverinit-fix.patch b/vadriverinit-fix.patch
new file mode 100644
index 000000000000..5177e1448539
--- /dev/null
+++ b/vadriverinit-fix.patch
@@ -0,0 +1,13 @@
+--- intel-hybrid-driver/src/media_drv_init.c
++++ intel-hybrid-driver-new/src/media_drv_init.c
+@@ -2764,9 +2764,9 @@ va_driver_init (VADriverContextP ctx)
+ return ret;
+ }
+
+-VAStatus DLL_EXPORT __vaDriverInit_0_34 (VADriverContextP ctx);
++VAStatus DLL_EXPORT VA_DRIVER_INIT_FUNC (VADriverContextP ctx);
+ VAStatus
+-__vaDriverInit_0_34 (VADriverContextP ctx)
++VA_DRIVER_INIT_FUNC (VADriverContextP ctx)
+ {
+ VAStatus ret = VA_STATUS_ERROR_UNKNOWN;