summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-04-19 21:08:44 +0200
committerGeorg Schlisio2016-04-19 21:08:44 +0200
commit3b993d38353702150362ccefb7c096503f799292 (patch)
tree44066265c5bec5f6a20da2f4e5599c0010479f40
downloadaur-3b993d38353702150362ccefb7c096503f799292.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b081e968e41c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-ipcalc
+ pkgdesc = IP subnet calculator for Python.
+ pkgver = 1.99.0
+ pkgrel = 1
+ url = https://github.com/tehmaze/ipcalc
+ arch = any
+ license = custom:unknown
+ depends = python2
+ source = http://pypi.python.org/packages/source/i/ipcalc/ipcalc-1.99.0.tar.gz
+ sha1sums = a9841397166cce456f02e0226c0b97cbbdaf300a
+
+pkgname = python2-ipcalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc8e155cd890
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# This file was taken from BlackArch Linux ( http://blackarch.org )
+# and brought to AUR to benefit all arch users
+
+pkgname='python2-ipcalc'
+pkgver='1.99.0'
+pkgrel=1
+pkgdesc='IP subnet calculator for Python.'
+arch=('any')
+url='https://github.com/tehmaze/ipcalc'
+license=('custom:unknown')
+depends=('python2')
+source=("http://pypi.python.org/packages/source/i/ipcalc/ipcalc-${pkgver}.tar.gz")
+sha1sums=('a9841397166cce456f02e0226c0b97cbbdaf300a')
+
+package() {
+ cd "$srcdir/ipcalc-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}