summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-11 11:24:27 -0500
committerCarlos Aznarán2024-02-11 11:24:27 -0500
commit3bab2d120d2d9e58480b22697f9da95934096484 (patch)
tree75544cfe487617d9971b74f28f762f403f8674c8
parent2b4c01b122287f536b06828929e9155e767ae15d (diff)
downloadaur-3bab2d120d2d9e58480b22697f9da95934096484.tar.gz
Bump version to 0.6.5
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--CHANGELOG.md3
-rw-r--r--PKGBUILD52
-rw-r--r--setup.py.patch51
5 files changed, 35 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4120cbf5be1..74f3986b35d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = python-ripser
- pkgdesc = Homology Library for Python
- pkgver = 0.6.4
+ pkgdesc = A Lean Persistent Homology Library for Python
+ pkgver = 0.6.5
pkgrel = 1
url = https://github.com/scikit-tda/ripser.py
changelog = CHANGELOG.md
arch = x86_64
license = MIT
- makedepends = cython
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- depends = python-numpy
- depends = python-scipy
- depends = python-scikit-learn
+ makedepends = cython
depends = python-persim
- source = python-ripser-0.6.4.tar.gz::https://files.pythonhosted.org/packages/source/r/ripser/ripser-0.6.4.tar.gz
- source = setup.py.patch
- sha256sums = 7a9b3e9420869c50df85e9a446c912b8af81621e62ca1af8f9492c6335b7e594
- sha256sums = 5d6538cf07d897cfead808048682266bcf2a9199f2ddda9becd4919221612195
+ source = ripser.py-0.6.5.tar.gz::https://github.com/scikit-tda/ripser.py/archive/0.6.5.tar.gz
+ sha512sums = 42d43613148a9eac6c8f9d08487302991a71680ec19068467e375ab5249e175c53e5899403bce78bc3197dccb27657dc80f6a0b77c3fcd73051da4a28379d2a1
pkgname = python-ripser
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 1cbbb1cc6678..180414612b99 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,6 @@
+# 0.6.5
+ - Bugfix for lower star filtrations with edges that come in at exactly 0 (courtesy of Riccardo Ceccaroni)
+
# 0.6.4
- Add some includes to ripser.cpp for newer Ubuntu/C++ environments
diff --git a/PKGBUILD b/PKGBUILD
index 027ac298758b..868f6783a6f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,35 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-
-pkgname=python-ripser
-_pkg="${pkgname#python-}"
-pkgver=0.6.4
+_base=ripser
+pkgname=python-${_base}
+pkgver=0.6.5
pkgrel=1
-pkgdesc="Homology Library for Python"
-arch=('x86_64')
-url="https://github.com/scikit-tda/ripser.py"
-license=('MIT')
-depends=('python-numpy' 'python-scipy' 'python-scikit-learn' 'python-persim')
-makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+pkgdesc="A Lean Persistent Homology Library for Python"
+arch=(x86_64)
+url="https://github.com/scikit-tda/${_base}.py"
+license=(MIT)
+depends=(python-persim)
+makedepends=(python-build python-installer python-setuptools python-wheel cython)
+checkdepends=(python-pytest)
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/$_pkg/$_pkg-$pkgver.tar.gz"
- 'setup.py.patch')
-sha256sums=('7a9b3e9420869c50df85e9a446c912b8af81621e62ca1af8f9492c6335b7e594'
- '5d6538cf07d897cfead808048682266bcf2a9199f2ddda9becd4919221612195')
+source=(${_base}.py-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('42d43613148a9eac6c8f9d08487302991a71680ec19068467e375ab5249e175c53e5899403bce78bc3197dccb27657dc80f6a0b77c3fcd73051da4a28379d2a1')
-prepare() {
- patch -p1 -d "$_pkg-$pkgver" < setup.py.patch
+build() {
+ cd ${_base}.py-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
+check() {
+ cd ${_base}.py-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/$_pkg-$pkgver.dist-info/LICENSE.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${_base}.py-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/setup.py.patch b/setup.py.patch
deleted file mode 100644
index 3a61980ce5a2..000000000000
--- a/setup.py.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 5f44f2f..c43766a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -25,12 +25,12 @@ if mo:
- else:
- raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
-
--# Use README.md as the package long description
-+# Use README.md as the package long description
- with open('README.md') as f:
- long_description = f.read()
-
- class CustomBuildExtCommand(build_ext):
-- """ This extension command lets us not require numpy be installed before running pip install ripser
-+ """ This extension command lets us not require numpy be installed before running pip install ripser
- build_ext command for use when numpy headers are needed.
- """
-
-@@ -52,11 +52,11 @@ if platform.system() == "Windows":
- ])
- elif platform.system() == "Darwin":
- extra_compile_args.extend([
-- '-std=c++11',
-+ '-std=c++11',
- "-mmacosx-version-min=10.9"
- ])
- extra_link_args.extend([
-- "-stdlib=libc++",
-+ "-stdlib=libc++",
- "-mmacosx-version-min=10.9"
- ])
- else:
-@@ -104,7 +104,7 @@ setup(
- url="https://ripser.scikit-tda.org",
- license='MIT',
- packages=['ripser'],
-- ext_modules=cythonize(ext_modules),
-+ ext_modules=cythonize(ext_modules, language_level = '3'),
- install_requires=[
- 'Cython',
- 'numpy',
-@@ -114,7 +114,7 @@ setup(
- ],
- extras_require={
- 'testing': [ # `pip install -e ".[testing]"``
-- 'pytest'
-+ 'pytest'
- ],
- 'docs': [ # `pip install -e ".[docs]"`
- 'sktda_docs_config'