summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Boyle2021-02-13 23:57:10 +0000
committerJonathan Boyle2021-02-13 23:57:10 +0000
commit3bf12d6d7dc92bc9f182f96a899acb4566ea448a (patch)
tree8f2e015fe0047ce87d987f15fb777e9fb5e608bc
downloadaur-3bf12d6d7dc92bc9f182f96a899acb4566ea448a.tar.gz
Initial Commit of Version 2.0.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--RELEASENOTES.md153
3 files changed, 203 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d34e1959bff9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mulle-dispense
+ pkgdesc = Copy build products and reorganize them
+ pkgver = 2.0.1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/mulle-sde/mulle-dispense
+ changelog = RELEASENOTES.md
+ arch = any
+ groups = mulle-sde-all
+ license = BSD3
+ depends = bash
+ depends = mulle-bashfunctions>=3.3.0
+ source = https://github.com/mulle-sde/mulle-dispense/archive/2.0.1.tar.gz
+ md5sums = fedbd94f28dcb4542393493d9dbc5446
+
+pkgname = mulle-dispense
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1505a8eb17a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
+pkgname=mulle-dispense
+pkgver=2.0.1
+pkgrel=1
+epoch=1
+pkgdesc="Copy build products and reorganize them"
+arch=('any')
+url="https://github.com/mulle-sde/mulle-dispense"
+license=('BSD3')
+groups=('mulle-sde-all')
+depends=('bash' 'mulle-bashfunctions>=3.3.0')
+changelog="RELEASENOTES.md"
+source=("https://github.com/mulle-sde/mulle-dispense/archive/2.0.1.tar.gz")
+noextract=()
+md5sums=('fedbd94f28dcb4542393493d9dbc5446')
+validpgpkeys=()
+
+package() {
+ # Install License
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Run Install
+ cd bin
+ chmod +x installer
+ ./installer "${pkgdir}/usr"
+
+ # Move libexec to lib/$pkgname
+ cd "${pkgdir}/usr"
+ mkdir -p "lib/${pkgname}"
+ mv libexec/* "lib/${pkgname}"
+ rm -r libexec
+}
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
new file mode 100644
index 000000000000..f1f961f87063
--- /dev/null
+++ b/RELEASENOTES.md
@@ -0,0 +1,153 @@
+### 2.0.1
+
+* installer verbose toggle
+
+# 2.0.0
+
+* mulle-dispense now copies instead of moves per default, which is basically what was advertised all along ...
+* use the --move option on the dispense command to move as before
+* use ``MULLE_DISPENSE_SEARCH_LIB_PATH`` and related environment variables to tweak the search path for build products
+* the various ``MULLE_DISPENSE_SEARCH_`<dir>`_PATH`` variables may also reference files,
+
+
+## 1.2.0
+
+* changed to mulle-bashfunctions 2 call convention
+* moved to mulle-bashfunctions v2
+
+
+### 1.0.2
+
+* hack change version to 1.0.1 because of a debian problem
+
+### 0.6.3
+
+* small beauty fixes in code
+
+### 0.6.2
+
+* a bit less verbose
+
+### 0.6.1
+
+* improve README.md, miniscule code improvements
+
+## 0.6.0
+
+* tune what gets dispensed with commandline parameters like --no-headers
+
+
+### 0.5.1
+
+* mulle-dispense does not wrongly assert the pathname 'sanity' of the source anymore
+
+## 0.5.0
+
+* use `r_` functions of mulle-bashfunctions 1.8.0
+
+
+## 0.4.0
+
+* fix test for mingw
+
+
+### 0.3.2
+
+* add missing quotes around string
+
+### 0.3.1
+
+* less verbose
+
+## 0.3.0
+
+* add --header-dir option
+
+
+### 0.2.22
+
+* small code change
+
+### 0.2.21
+
+* capitalize an error message properly
+
+### 0.2.20
+
+* add `._.DS_Store` to .gitignore
+
+### 0.2.19
+
+* quote more case patterns to avoid extglob surprises
+
+### 0.2.18
+
+* use `LC_ALL=C` for sort
+
+### 0.2.17
+
+* remove file from git
+
+### 0.2.16
+
+* simplify README
+
+### 0.2.15
+
+* improved brew formula definition
+
+### 0.2.14
+
+* fix package dependencies more
+
+### 0.2.13
+
+* fix package dependencies
+
+### 0.2.12
+
+* fix homebrew install ruby script
+
+### 0.2.11
+
+* rename install to installer, because of name conflict
+
+### 0.2.10
+
+* rename install.sh to install
+
+### 0.2.9
+
+* CMakeLists.txt CMakePackage.txt LICENSE Makefile README.md RELEASENOTES.md build install.chk install.sh mulle-dispense mulle-dispense.sublime-project mulle-dispense.sublime-workspace mulle-project src tests tmp.4G7WECAI tmp.Cm9FA2Yu tmp.H70JmUwp tmp.OMcvmXX1 tmp.RPTGbiBb tmp.T7CWYggR tmp.XRatwWEH tmp.gKzio3Kf tmp.nJXgwker tmp.wXAYgWwu simplified CMakeLists.txt
+
+### 0.2.8
+
+* fix potential bug in test
+
+### 0.2.7
+
+* remove `MULLE_EXECUTABLE_FAIL_PREFIX`
+
+### 0.2.6
+
+* miniscule code improvement
+
+### 0.2.5
+
+* use proper `DEPENDENCY_DIR` and `MULLE_UNAME`
+
+### 0.2.4
+
+* small cleanup
+
+### 0.2.3
+
+* unify mulle-bashfunctions-env usage and help
+
+### 0.2.2
+
+* * fix option handling for project
+
+## 0.2.0
+
+* use `MULLE_USAGE_NAME`