summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-03-18 23:12:36 +0100
committerhaawda2017-03-18 23:12:36 +0100
commit3c16ad44a3a7516cb67d5969751ffd91bf36746b (patch)
tree8eedb291e00614a7a1bcac15aa8a9e2ff8dfca83
downloadaur-3c16ad44a3a7516cb67d5969751ffd91bf36746b.tar.gz
initial upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b3afb93bc1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Mar 18 22:12:12 UTC 2017
+pkgbase = c-graph
+ pkgdesc = Demonstrates the theory of convolution underlying engineering systems and signal analysis.
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://www.gnu.org/software/c-graph/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ source = http://ftp.halifax.rwth-aachen.de/gnu/c-graph/c-graph-2.0.tar.gz
+ md5sums = e8a6d310f6063175ca77ff49762977c5
+
+pkgname = c-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db3bfaf5520d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=c-graph
+pkgver=2.0
+pkgrel=1
+pkgdesc="Demonstrates the theory of convolution underlying engineering systems and signal analysis. "
+url="https://www.gnu.org/software/c-graph/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('gcc-libs')
+source=("http://ftp.halifax.rwth-aachen.de/gnu/c-graph/$pkgname-$pkgver.tar.gz")
+md5sums=('e8a6d310f6063175ca77ff49762977c5')
+# or any other gnu mirror
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make -k || true
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}