summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Fryers2022-09-28 10:21:19 +0100
committerTom Fryers2022-09-28 10:21:19 +0100
commit3c1b4f2e037564d928e03c1df169171d37f51b22 (patch)
treeb854540106b4d25cb586167b80d7bf32f8721ffc
parent7ed3fc44447aadefd6bf37e9110d3c4dde262c79 (diff)
downloadaur-3c1b4f2e037564d928e03c1df169171d37f51b22.tar.gz
Update from upstream
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
-rwxr-xr-x[-rw-r--r--]nemacs0
-rw-r--r--site-list-aot.md20
5 files changed, 38 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b16d3ad975b4..b2b66af14d81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,37 +16,22 @@ pkgbase = emacs-pgtk-native-comp-git
depends = libgccjit
depends = libxi
depends = gtk3
+ depends = libsm
+ depends = xcb-util
+ depends = libxcb
depends = libjpeg-turbo
+ depends = libpng
depends = giflib
- depends = alsa-lib
- depends = webkit2gtk
- depends = gpm
+ depends = libwebp
+ depends = libtiff
+ depends = libxpm
+ depends = cairo
provides = emacs
- provides = emacs-pretest
- provides = emacs26-git
- provides = emacs-27-git
- provides = emacs28-git
- provides = emacs-git
- provides = emacs-seq
- provides = emacs-nox
- conflicts = emacs
- conflicts = emacs-pretest
- conflicts = emacs26-git
- conflicts = emacs-27-git
- conflicts = emacs28-git
- conflicts = emacs-git
- conflicts = emacs-seq
- conflicts = emacs-nox
replaces = emacs
- replaces = emacs-pretest
- replaces = emacs26-git
- replaces = emacs-27-git
- replaces = emacs28-git
- replaces = emacs-git
- replaces = emacs-seq
- replaces = emacs-nox
options = !strip
source = emacs-git::emacs-git::git+https://github.com/emacs-mirror/emacs.git
+ source = nemacs
b2sums = SKIP
+ b2sums = 58e028b439d3c7cf03ea0be617b429a2c54e7aa1b8ca32b5ed489214daaa71e22c323de9662761ad2ce4de58e21dbe45ce6ce198f402686828574f8043d053d0
pkgname = emacs-pgtk-native-comp-git
diff --git a/.gitignore b/.gitignore
index d517c3782020..a7490fd0d82a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,5 @@ src/
emacs-git
*.local
local
+LOCAL
+*.txt
diff --git a/PKGBUILD b/PKGBUILD
index 815e912c2eef..a723b6de58f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,8 +42,12 @@ JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
#
# To compile all site-lisp on demand (repos/AUR packages,
# ELPA, MELPA, whatever), add
- # (setq comp-deferred-compilation t)
+ # (setq native-comp-deferred-compilation t)
# to your .emacs file.
+ #
+ # And to keep the eln cache clean add
+ # (setq native-compile-prune-cache t)
+ # to delete old versions.
AOT="YES" # Compile all elisp files.
@@ -88,7 +92,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-pgtk-native-comp-git"
fi
-pkgver=29.0.50.157962
+pkgver=29.0.50.160160
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -99,7 +103,6 @@ depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs')
replaces=('emacs')
-#source=("emacs-git::git://git.savannah.gnu.org/emacs.git"
source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git"
"nemacs")
options=(!strip)
diff --git a/nemacs b/nemacs
index 6becea07654c..6becea07654c 100644..100755
--- a/nemacs
+++ b/nemacs
diff --git a/site-list-aot.md b/site-list-aot.md
new file mode 100644
index 000000000000..10cedd1db5e2
--- /dev/null
+++ b/site-list-aot.md
@@ -0,0 +1,20 @@
+# ON-DEMAND COMPILATION OF SITE-LISP AND LOCAL PACKAGES
+
+To compile all site-lisp on demand (repos/AUR packages, ELPA, MELPA,
+ whatever), add
+
+ (setq native-comp-deferred-compilation t)
+
+to your `.emacs` file.
+
+Or search the option in the editor's GUI configuration, set it
+to true and save your `.emacs` file to add it to the file's
+`custom-set-variables` array automatically.
+
+As emacs-git changes its version everytime you compile a new
+binary, new eln files are generated for that particular binary
+and old versions will accumulate over time. To keep the eln-cache
+tidy, add this to your `.emacs` file:
+
+ (setq native-compile-prune-cache t)
+