summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2015-06-16 16:50:41 -0400
committerDavid Parrish2015-06-16 16:50:41 -0400
commit3c60262fe188eca84ce766f3089f61c909f1d698 (patch)
tree38c1b6c96f0a548348b9a7dd3f9a84e18a9fba6b
downloadaur-3c60262fe188eca84ce766f3089f61c909f1d698.tar.gz
Initial commit for Mercury Exchange package
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD28
-rw-r--r--mercuryex.desktop9
-rw-r--r--mercuryex.pngbin0 -> 3116 bytes
-rw-r--r--mercuryex.sh2
6 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52df52c62775
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mercuryex
+ pkgdesc = A multi-coin wallet that supports trustless cross-chain trading
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://mercuryex.com/
+ arch = x86_64
+ license = MIT
+ source_x86_64 = https://github.com/mappum/mercury/releases/download/0.0.2-alpha/MercuryWallet-0.0.2.jar
+ source_x86_64 = mercuryex.sh
+ source_x86_64 = LICENSE.md
+ source_x86_64 = mercuryex.png
+ source_x86_64 = mercuryex.desktop
+ md5sums_x86_64 = 90924d0f61c66e26c413100b1c18424d
+ md5sums_x86_64 = 4ce1d64a3c152cc85b99398b1afbe216
+ md5sums_x86_64 = 6b88abfd948fb39633c620b58c1f90c2
+ md5sums_x86_64 = 013d2867c255082cef02fae79b875e44
+ md5sums_x86_64 = 60a827b7da9b0638b9978b9964356611
+
+pkgname = mercuryex
+
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..b632a8aea46e
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright 2015 Mercury
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5e10011ad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: David Parrish <daveparrish@gmail.com>
+
+pkgname=mercuryex
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A multi-coin wallet that supports trustless cross-chain trading"
+arch=('x86_64')
+url="http://mercuryex.com/"
+license=('MIT')
+source_x86_64=("https://github.com/mappum/mercury/releases/download/0.0.2-alpha/MercuryWallet-0.0.2.jar"
+ "mercuryex.sh"
+ "LICENSE.md"
+ "mercuryex.png"
+ "mercuryex.desktop")
+md5sums_x86_64=('90924d0f61c66e26c413100b1c18424d'
+ '4ce1d64a3c152cc85b99398b1afbe216'
+ '6b88abfd948fb39633c620b58c1f90c2'
+ '013d2867c255082cef02fae79b875e44'
+ '60a827b7da9b0638b9978b9964356611')
+
+package() {
+ install -D -m755 "mercuryex.sh" "${pkgdir}/usr/bin/mercuryex"
+ install -D -m644 MercuryWallet-${pkgver}.jar "${pkgdir}/usr/share/java/mercuryex/MercuryWallet.jar"
+
+ install -Dm644 mercuryex.desktop "${pkgdir}/usr/share/applications/mercuryex.desktop"
+ install -Dm644 mercuryex.png "${pkgdir}/usr/share/pixmaps/mercuryex.png"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}
diff --git a/mercuryex.desktop b/mercuryex.desktop
new file mode 100644
index 000000000000..d8575dab1f63
--- /dev/null
+++ b/mercuryex.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mercury Exchange
+GenericName=P2P Altcoin Exchange
+Comment=A multi-coin wallet that supports trustless cross-chain trading
+Exec=/usr/bin/mercuryex
+Icon=/usr/share/pixmaps/mercuryex.png
+Terminal=false
+Type=Application
+Categories=Utility;Finance;
diff --git a/mercuryex.png b/mercuryex.png
new file mode 100644
index 000000000000..0f5f6328f545
--- /dev/null
+++ b/mercuryex.png
Binary files differ
diff --git a/mercuryex.sh b/mercuryex.sh
new file mode 100644
index 000000000000..4261b7ca540a
--- /dev/null
+++ b/mercuryex.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "$JAVA_HOME/bin/java" -jar /usr/share/java/mercuryex/MercuryWallet.jar "$@"