summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel B. Sant'Anna2021-02-14 03:57:58 +0100
committerGabriel B. Sant'Anna2021-02-14 03:57:58 +0100
commit3c67146e7614dafacd564114f0db39424707f26e (patch)
tree3d61b4b0d2c51814dd45eaba9586f1952979a010
parent8ed459f4c3b758db711fd0f27e17fa37e08a31cc (diff)
downloadaur-3c67146e7614dafacd564114f0db39424707f26e.tar.gz
Update to version 1.1.0
Now it should work with Guile 3.0
-rw-r--r--.SRCINFO11
-rw-r--r--Makefile15
-rw-r--r--PKGBUILD12
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acb3f99e96a0..7530665b53ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = akku
pkgdesc = Language package manager for Scheme
- pkgver = 1.0.1
- pkgrel = 3
+ pkgver = 1.1.0
+ pkgrel = 4
url = https://akkuscm.org/
arch = any
license = GPL3
@@ -10,13 +10,12 @@ pkgbase = akku
depends = git
depends = curl
depends = guile>=2.2
- depends = guile<3
noextract = $pkgname-$pkgver.tar.gz.sig
options = !strip
- source = https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/akku-1.0.1.tar.gz
- source = https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/akku-1.0.1.tar.gz.sig
+ source = https://gitlab.com/akkuscm/akku/uploads/819fd1f988c6af5e7df0dfa70aa3d3fe/akku-1.1.0.tar.gz
+ source = https://gitlab.com/akkuscm/akku/uploads/7650c7563078baba3d835282765c43cb/akku-1.1.0.tar.gz.sig
validpgpkeys = 08272FBB54EEB5072D5BA930E33E61A2E9B8C3A2
- md5sums = 72ce46a5bc98cb0c4a549b41dd3f11b2
+ md5sums = 09916b7e1c51d7f762ef6385934f96eb
md5sums = SKIP
pkgname = akku
diff --git a/Makefile b/Makefile
index 1d3bbead5fed..3e474a7b5a53 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,22 @@
.PHONY: all clean verify force-build update-checksums
-PACKAGE=akku-*-any.pkg.tar.xz
+PACKAGE = akku-*-any.pkg*
# default
all: $(PACKAGE)
+ @make update-checksums
@make verify
@make .SRCINFO
clean:
-rm *.tar.*
-rm -R src/
- -rm -R pkg/
+ -rm -Rf pkg/
+
+# downloads files, generates checksums and updates them on PKGBUILD
+update-checksums:
+ makepkg --verifysource --skipchecksums -f --nobuild --noextract
+ updpkgsums
# NOTE: excludes are only used to prevent namcap false positives over Guile object (.go) files
verify: PKGBUILD $(PACKAGE)
@@ -21,11 +27,6 @@ verify: PKGBUILD $(PACKAGE)
force-build:
@LC_ALL=C makepkg -f --clean
-# downloads files, generates checksums and updates them on PKGBUILD
-update-checksums:
- makepkg --verifysource --skipchecksums -f --nobuild --noextract
- updpkgsums
-
.SRCINFO: PKGBUILD
@makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index fcba5c29ffb0..485131cbf0c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@ license=('GPL3')
arch=('any')
# version-specific information
-pkgrel=3
-pkgver=1.0.1
+pkgrel=4
+pkgver=1.1.0
# dependencies are stated in https://gitlab.com/akkuscm/akku/-/blob/master/README.md
-depends=('git' 'curl' 'guile>=2.2' 'guile<3')
+depends=('git' 'curl' 'guile>=2.2')
makedepends=('pkg-config' 'make')
# source URLs for latest versions can be found at https://gitlab.com/akkuscm/akku/-/releases
options=(!strip) # disable stripping
-source=("https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/$pkgname-$pkgver.tar.gz"
- "https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/$pkgname-$pkgver.tar.gz.sig")
+source=("https://gitlab.com/akkuscm/akku/uploads/819fd1f988c6af5e7df0dfa70aa3d3fe/akku-1.1.0.tar.gz"
+ "https://gitlab.com/akkuscm/akku/uploads/7650c7563078baba3d835282765c43cb/akku-1.1.0.tar.gz.sig")
noextract=('$pkgname-$pkgver.tar.gz.sig')
# full fingerprint from the output of gpg --list-keys --fingerprint E33E61A2E9B8C3A2
@@ -39,5 +39,5 @@ package() {
}
# md5sums generated with updpkgsums
-md5sums=('72ce46a5bc98cb0c4a549b41dd3f11b2'
+md5sums=('09916b7e1c51d7f762ef6385934f96eb'
'SKIP')