summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnselmo L. S. Melo2016-08-12 17:41:46 -0300
committerAnselmo L. S. Melo2016-08-12 17:41:46 -0300
commit3c731407c2ae56ae54819eafba2ed4f1be5faca2 (patch)
tree4e58536f68c0985ea95c8c8004af1c7d96018395
downloadaur-3c731407c2ae56ae54819eafba2ed4f1be5faca2.tar.gz
Initial PKGBUILD for qm-dfu-util releases
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b291a972d786
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Aug 12 20:41:18 UTC 2016
+pkgbase = qm-dfu-util
+ pkgdesc = UART-based dfu-util for Quark MCUs
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/quark-mcu/qm-dfu-util
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ provides = qm-dfu-util
+ provides = dfu-util-qda
+ conflicts = qm-dfu-util-git
+ replaces = qm-dfu-util-git
+ source = https://github.com/quark-mcu/qm-dfu-util/archive/v1.1.0.tar.gz
+ md5sums = 0fcde4fc6e8d75ee9b3ae5fbab2ed180
+
+pkgname = qm-dfu-util
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ea5cf735c50
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/qm-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82585763c45e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Anselmo L. S. Melo <anselmo.melo@intel.com>
+pkgname=qm-dfu-util
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="UART-based dfu-util for Quark MCUs"
+arch=('x86_64' 'i686')
+url="https://github.com/quark-mcu/qm-dfu-util"
+license=('GPL2')
+depends=()
+provides=("${pkgname%-git}" 'dfu-util-qda')
+conflicts=('qm-dfu-util-git')
+replaces=('qm-dfu-util-git')
+source=("https://github.com/quark-mcu/qm-dfu-util/archive/v$pkgver.tar.gz")
+md5sums=('0fcde4fc6e8d75ee9b3ae5fbab2ed180')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}