summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-01-26 00:47:22 +0100
committersL1pKn072019-01-26 00:48:16 +0100
commit3ca64e3ade34ea82c9974650cc0bf258fea614a5 (patch)
treebcd815954ecbeafd7eeca2fac4db6c1b121c6387
parentb4266c273f0f4c9d6287f2b2b8e63d0f9cb7653c (diff)
downloadaur-3ca64e3ade34ea82c9974650cc0bf258fea614a5.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--patch.patch13
4 files changed, 6 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be47a56155b7..6ce43c125979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jan 5 21:37:50 UTC 2018
+# Fri Jan 25 23:47:40 UTC 2019
pkgbase = vapoursynth-plugin-inpaint-git
pkgdesc = Plugin for Vapoursynth: inpaint
pkgver = r2.dafa5b5
@@ -12,9 +12,7 @@ pkgbase = vapoursynth-plugin-inpaint-git
depends = vapoursynth
depends = opencv
source = inpaint::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git
- source = patch.patch
sha256sums = SKIP
- sha256sums = f2454d793377b7f6a955d2f939dd83be7005a91025bfdca3b6867e49c172cd1c
pkgname = vapoursynth-plugin-inpaint-git
diff --git a/.gitignore b/.gitignore
index d5a163ad2410..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!patch.patch
diff --git a/PKGBUILD b/PKGBUILD
index a26733f49b48..466a65323822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,8 @@ depends=('vapoursynth'
'opencv'
)
makedepends=('git')
-source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git"
- 'patch.patch'
- )
-sha256sums=('SKIP'
- 'f2454d793377b7f6a955d2f939dd83be7005a91025bfdca3b6867e49c172cd1c'
- )
+source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -29,10 +25,11 @@ prepare(){
cd "${_plug}"
rm -fr VSHelper.h VapourSynth.h
- patch -p1 -i "${srcdir}/patch.patch"
+ sed 's|<vapoursynth.h>|<VapourSynth.h>|g' \
+ -i Inpaint.h
echo "all:
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o Inpaint.o Inpaint.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) $(pkg-config --cflags opencv4) -o Inpaint.o Inpaint.cpp
g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
}
diff --git a/patch.patch b/patch.patch
deleted file mode 100644
index c0b88c8ec682..000000000000
--- a/patch.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Inpaint.h b/Inpaint.h
-index 0325d7b..de056d8 100644
---- a/Inpaint.h
-+++ b/Inpaint.h
-@@ -1,7 +1,7 @@
- #ifndef INPAINT_H
- #define INPAINT_H
-
--#include <vapoursynth.h>
-+#include <VapourSynth.h>
- #include <VSHelper.h>
- #include <opencv2/opencv.hpp>
-