summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Munkres2019-02-23 06:39:32 -0800
committerAndrew Munkres2019-02-23 06:39:32 -0800
commit3ca7579ca8fbf85aa7ed99afb0ea660a8cd19d8f (patch)
tree703e5460c345c8fbef7991f372f0f36691161338
downloadaur-3ca7579ca8fbf85aa7ed99afb0ea660a8cd19d8f.tar.gz
Initial import
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD101
-rw-r--r--quickviewer-1.1.3-change-qmake-variable-defs.patch27
-rw-r--r--quickviewer-1.1.3-desktopfile-changes.patch13
-rw-r--r--quickviewer-1.1.3-fileloader-projectfile-changes.patch26
-rw-r--r--quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch11
-rw-r--r--quickviewer-1.1.3-lib7z-projectfile-changes.patch10
-rw-r--r--quickviewer-1.1.3-main-projectfile-changes.patch44
8 files changed, 286 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaf7e7393165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = quickviewer
+ pkgdesc = An image/comic viewer application
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://kanryu.github.io/quickviewer/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = custom:unrar
+ license = custom:ResizeHalf
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-base
+ source = quickviewer::git://github.com/kanryu/quickviewer.git#tag=v1.1.3
+ source = ResizeHalf::git://github.com/chikuzen/ResizeHalf.git#commit=5099b0dc6081ddb79c1a39694b223c5840c7da9b
+ source = easyexif::git://github.com/mayanklahiri/easyexif.git#commit=19d15151c3f663813dc70cf9ff568d25ab6ff93b
+ source = exiv2::git://github.com/Exiv2/exiv2.git#commit=fa449a4d2c58d63f0d75ff259f25683a98a44630
+ source = libexpat::git://github.com/libexpat/libexpat.git#commit=56b64ca0406d31f0a8cd93e155c38a3b30b002f8
+ source = luminor::git://github.com/kanryu/luminor.git#commit=c2d113b8a45f3c7118ded920277ca35583689d1c
+ source = quazip::git://github.com/kanryu/quazip.git#commit=6cc7516f65f20e59739c629fe95a0eac7953260e
+ source = zimg::git://github.com/sekrit-twc/zimg.git#commit=5e603b6390f0fc1e32e634dece083dd8b729334a
+ source = zlib::git://github.com/madler/zlib.git#commit=cacf7f1d4e3d44d871b605da3b647f07d718623f
+ source = qactionmanager::git://github.com/kanryu/qactionmanager.git#commit=2f66c030ef2169eccc240b10a10b7f921bd0cfea
+ source = qfullscreenframe::git://github.com/kanryu/qfullscreenframe.git#commit=550f001f4383edaf5baf1598ad1473bc698f807a
+ source = qlanguageselector::git://github.com/kanryu/qlanguageselector.git#commit=d0e5cb6141854c1eacb68d2dd31bf7cb9337a7ab
+ source = qnamedpipe::git://github.com/kanryu/qnamedpipe.git#commit=f887aadb1b1587c82459e94ef3195c97a697ad05
+ source = quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch
+ source = quickviewer-1.1.3-change-qmake-variable-defs.patch
+ source = quickviewer-1.1.3-main-projectfile-changes.patch
+ source = quickviewer-1.1.3-fileloader-projectfile-changes.patch
+ source = quickviewer-1.1.3-lib7z-projectfile-changes.patch
+ source = quickviewer-1.1.3-desktopfile-changes.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 8a2729a3bd5b6b8a5e9124593c881b98a20db7742b66d82641a40ee256faaeb4
+ sha256sums = 17aaffcb0a8d812ac10d26b69b88163031e25b8144b5eb1ec65be96e33debace
+ sha256sums = a5acde9f0b45819a472d3024bf12df524bc4e3dbd08cf4af2984f272c6c8a0da
+ sha256sums = 735373799b838a84c9f962a8319d58f104daeb7617d4da1e89ebd9dfb4e0ab95
+ sha256sums = 18b03a7f06d9cd4d5afbdc14f48caad5f065b212281984726e1c90bd48dbe5bd
+ sha256sums = 7c73402e349afe235b1ddcc81f33f0d8272e9271a37cc583c30d71ceb09abe11
+
+pkgname = quickviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e1e247a4983
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,101 @@
+# Maintainer: Andrew Munkres <amunkres@nyx.net>
+
+pkgname=quickviewer
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="An image/comic viewer application"
+arch=('i686' 'x86_64')
+url="https://kanryu.github.io/quickviewer/"
+license=('GPL3' 'custom:unrar' 'custom:ResizeHalf')
+# Warning: QuickViewer's Git repository imports (as submodules) the source code
+# of some required 3rd-party libraries into QuickViewer's own source tree as
+# Git submodules; and while some of these (such as expat and easyexif) use
+# GPL3-compatible licenses, at least one (unrar) uses a GPL3-incompatible
+# license, while one other (ResizeHalf) does not appear to have any license
+# terms whatsoever. Therefore, the compiled binary likely is not legally
+# redistributable.
+depends=('qt5-base')
+makedepends=('git' 'qt5-tools')
+source=("${pkgname}::git://github.com/kanryu/${pkgname}.git#tag=v${pkgver}"
+ "ResizeHalf::git://github.com/chikuzen/ResizeHalf.git#commit=5099b0dc6081ddb79c1a39694b223c5840c7da9b"
+ "easyexif::git://github.com/mayanklahiri/easyexif.git#commit=19d15151c3f663813dc70cf9ff568d25ab6ff93b"
+ "exiv2::git://github.com/Exiv2/exiv2.git#commit=fa449a4d2c58d63f0d75ff259f25683a98a44630"
+ "libexpat::git://github.com/libexpat/libexpat.git#commit=56b64ca0406d31f0a8cd93e155c38a3b30b002f8"
+ "luminor::git://github.com/kanryu/luminor.git#commit=c2d113b8a45f3c7118ded920277ca35583689d1c"
+ "quazip::git://github.com/kanryu/quazip.git#commit=6cc7516f65f20e59739c629fe95a0eac7953260e"
+ "zimg::git://github.com/sekrit-twc/zimg.git#commit=5e603b6390f0fc1e32e634dece083dd8b729334a"
+ "zlib::git://github.com/madler/zlib.git#commit=cacf7f1d4e3d44d871b605da3b647f07d718623f"
+ "qactionmanager::git://github.com/kanryu/qactionmanager.git#commit=2f66c030ef2169eccc240b10a10b7f921bd0cfea"
+ "qfullscreenframe::git://github.com/kanryu/qfullscreenframe.git#commit=550f001f4383edaf5baf1598ad1473bc698f807a"
+ "qlanguageselector::git://github.com/kanryu/qlanguageselector.git#commit=d0e5cb6141854c1eacb68d2dd31bf7cb9337a7ab"
+ "qnamedpipe::git://github.com/kanryu/qnamedpipe.git#commit=f887aadb1b1587c82459e94ef3195c97a697ad05"
+ "quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch"
+ "quickviewer-1.1.3-change-qmake-variable-defs.patch"
+ "quickviewer-1.1.3-main-projectfile-changes.patch"
+ "quickviewer-1.1.3-fileloader-projectfile-changes.patch"
+ "quickviewer-1.1.3-lib7z-projectfile-changes.patch"
+ "quickviewer-1.1.3-desktopfile-changes.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '8a2729a3bd5b6b8a5e9124593c881b98a20db7742b66d82641a40ee256faaeb4'
+ '17aaffcb0a8d812ac10d26b69b88163031e25b8144b5eb1ec65be96e33debace'
+ 'a5acde9f0b45819a472d3024bf12df524bc4e3dbd08cf4af2984f272c6c8a0da'
+ '735373799b838a84c9f962a8319d58f104daeb7617d4da1e89ebd9dfb4e0ab95'
+ '18b03a7f06d9cd4d5afbdc14f48caad5f065b212281984726e1c90bd48dbe5bd'
+ '7c73402e349afe235b1ddcc81f33f0d8272e9271a37cc583c30d71ceb09abe11')
+
+prepare() {
+ cd ${pkgname}
+ # Apply patch to fix non-Windows version of fileNameDescendingLessThan function:
+ patch -Np1 -i ../quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch
+ # Apply patch to not build an AppImage, enable OpenGL, and adjust target pathname-prefix:
+ patch -Np1 -i ../quickviewer-1.1.3-change-qmake-variable-defs.patch
+ # Apply patch to install desktop and icon files, and change pathname for translations, etc.:
+ patch -Np1 -i ../quickviewer-1.1.3-main-projectfile-changes.patch
+ # Apply patches to have libraries build using qmake installed by their own qmake-projects,
+ # and remove unwanted RPATH:
+ patch -Np1 -i ../quickviewer-1.1.3-fileloader-projectfile-changes.patch
+ patch -Np1 -i ../quickviewer-1.1.3-lib7z-projectfile-changes.patch
+ # Apply patch to fix the pathname in QuickViewer.desktop:
+ patch -Np1 -i ../quickviewer-1.1.3-desktopfile-changes.patch
+ # Checkout the Git submodules:
+ git submodule init ResizeHalf/ResizeHalf easyexif/easyexif exiv2/exiv2 libexpat/libexpat \
+ luminor/luminor quazip/quazip zimg/zimg zlib/zlib QuickViewer/src/qactionmanager \
+ QuickViewer/src/qfullscreenframe QuickViewer/src/qlanguageselector QuickViewer/src/qnamedpipe
+ git config submodule.ResizeHalf.url ${srcdir}/ResizeHalf
+ git config submodule.easyexif.url ${srcdir}/easyexif
+ git config submodule.exiv2.url ${srcdir}/exiv2
+ git config submodule.libexpat.url ${srcdir}/libexpat
+ git config submodule.luminor.url ${srcdir}/luminor
+ git config submodule.quazip.url ${srcdir}/quazip
+ git config submodule.zimg.url ${srcdir}/zimg
+ git config submodule.zlib.url ${srcdir}/zlib
+ git config submodule.qactionmanager.url ${srcdir}/qactionmanager
+ git config submodule.qfullscreenframe.url ${srcdir}/qfullscreenframe
+ git config submodule.qlanguageselector.url ${srcdir}/qlanguageselector
+ git config submodule.qnamedpipe.url ${srcdir}/qnamedpipe
+ git submodule update
+}
+
+build() {
+ cd ${pkgname}
+ qmake -o Makefile -recursive QVproject.pro
+ make
+ lrelease QuickViewer/translations/*.ts
+}
+
+package() {
+ cd ${pkgname}
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/quickviewer-1.1.3-change-qmake-variable-defs.patch b/quickviewer-1.1.3-change-qmake-variable-defs.patch
new file mode 100644
index 000000000000..e6ce72063af4
--- /dev/null
+++ b/quickviewer-1.1.3-change-qmake-variable-defs.patch
@@ -0,0 +1,27 @@
+--- quickviewer/QVproject.pri.orig 2019-02-22 05:26:12.664409728 -0800
++++ quickviewer/QVproject.pri 2019-02-23 00:03:43.007544369 -0800
+@@ -2,19 +2,19 @@
+ DEFINES += QV_WITH_LUMINOR
+
+ ## Comment out if you need OpenGL support
+-DEFINES += QV_WITHOUT_OPENGL
++#DEFINES += QV_WITHOUT_OPENGL
+
+ ## Define when asking for portable operation.
+ ## When off, the installation will be done by OS standard method
+ ## Installation destination when not portable:
+ ## Windows: "C:\Program Files" or "C:\Users\[user]\Appdata\Roaming"
+ ## Linux: "/usr/local"
+-DEFINES += QV_PORTABLE
++#DEFINES += QV_PORTABLE
+
+ !contains(DEFINES, QV_PORTABLE) {
+- QV_BIN_PATH = /usr/local/bin
+- QV_LIB_PATH = /usr/local/lib
+- QV_SHARED_PATH = /usr/local/shared
++ QV_BIN_PATH = /usr/bin
++ QV_LIB_PATH = /usr/lib
++ QV_SHARED_PATH = /usr/share
+ }
+
+ greaterThan(QT_MAJOR_VERSION, 4) {
diff --git a/quickviewer-1.1.3-desktopfile-changes.patch b/quickviewer-1.1.3-desktopfile-changes.patch
new file mode 100644
index 000000000000..ee8cfc221e46
--- /dev/null
+++ b/quickviewer-1.1.3-desktopfile-changes.patch
@@ -0,0 +1,13 @@
+--- quickviewer/QuickViewer/QuickViewer.desktop.orig 2019-02-23 03:51:38.724009967 -0800
++++ quickviewer/QuickViewer/QuickViewer.desktop 2019-02-23 04:49:20.480625309 -0800
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+ Name=QuickViewer
+ Comment=A image viewer application for folders/archives, it can show images very fast
+-Keywords=viewer;commic;manga;opengl;
+-Exec=usr/bin/QuickViewer %F
++Keywords=viewer;comics;manga;opengl;
++Exec=/usr/bin/QuickViewer %F
+ Icon=quickviewer
+ Terminal=false
+ Type=Application
diff --git a/quickviewer-1.1.3-fileloader-projectfile-changes.patch b/quickviewer-1.1.3-fileloader-projectfile-changes.patch
new file mode 100644
index 000000000000..69c4201d0866
--- /dev/null
+++ b/quickviewer-1.1.3-fileloader-projectfile-changes.patch
@@ -0,0 +1,26 @@
+--- quickviewer/fileloader/fileloader.pro.orig 2019-02-23 05:29:22.150589475 -0800
++++ quickviewer/fileloader/fileloader.pro 2019-02-23 05:30:24.377255206 -0800
+@@ -16,7 +16,7 @@
+
+ *g++* {
+ win32: CONFIG += staticlib
+- QMAKE_LFLAGS += -Wl,-rpath,../lib
++ #QMAKE_LFLAGS += -Wl,-rpath,../lib
+ QMAKE_CXXFLAGS += -std=c++11
+ DEFINES += NTDDI_VERSION=NTDDI_VISTA
+ }
+@@ -54,11 +54,13 @@
+ INCLUDEPATH += ../Qt7z/Qt7z
+ LIBS += -lQt7z
+
+-unix {
++linux {
+ # SOURCES += $$PWD/fileloaderziparchive.cpp
+ # HEADERS += $$PWD/fileloaderziparchive.h
+ # DEFINES += QUAZIP_STATIC
+ # INCLUDEPATH += $$PWD/../quazip/quazip/quazip $$PWD/../zlib/zlib
+ # LIBS += -lquazip -lzlib
++ target.path = /usr/lib
++ INSTALLS += target
+ }
+
diff --git a/quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch b/quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch
new file mode 100644
index 000000000000..1a22d40b2357
--- /dev/null
+++ b/quickviewer-1.1.3-fix-nonwindows-filename-comparator.patch
@@ -0,0 +1,11 @@
+--- quickviewer/QuickViewer/src/models/volumemanager.cpp.orig 2019-02-22 03:48:52.047947231 -0800
++++ quickviewer/QuickViewer/src/models/volumemanager.cpp 2019-02-22 04:50:15.231151952 -0800
+@@ -71,7 +71,7 @@ static bool fileNameDescendingLessThan(c
+
+ static bool fileNameDescendingLessThan(const QvImageMetadata& m1, const QvImageMetadata& m2)
+ {
+- return s1 > s2;
++ return m1.filename().localeAwareCompare(m2.filename()) > 0;
+ }
+
+ #endif
diff --git a/quickviewer-1.1.3-lib7z-projectfile-changes.patch b/quickviewer-1.1.3-lib7z-projectfile-changes.patch
new file mode 100644
index 000000000000..42c1f16c7187
--- /dev/null
+++ b/quickviewer-1.1.3-lib7z-projectfile-changes.patch
@@ -0,0 +1,10 @@
+--- quickviewer/Qt7z/lib7z/lib7z.pro.orig 2019-02-23 03:30:46.104028146 -0800
++++ quickviewer/Qt7z/lib7z/lib7z.pro 2019-02-23 03:40:24.020686431 -0800
+@@ -281,3 +281,7 @@
+
+ macx: LIBS += -framework CoreFoundation
+
++linux {
++ target.path = /usr/lib
++ INSTALLS += target
++}
diff --git a/quickviewer-1.1.3-main-projectfile-changes.patch b/quickviewer-1.1.3-main-projectfile-changes.patch
new file mode 100644
index 000000000000..9b2129bb21ed
--- /dev/null
+++ b/quickviewer-1.1.3-main-projectfile-changes.patch
@@ -0,0 +1,44 @@
+--- quickviewer/QuickViewer/QuickViewer.pro.orig 2019-02-23 03:43:51.157350083 -0800
++++ quickviewer/QuickViewer/QuickViewer.pro 2019-02-23 03:45:55.597348307 -0800
+@@ -424,22 +424,21 @@
+
+ # not portable, install into /usr/local/bin
+ linux : !CONFIG(debug, debug|release) : !contains(DEFINES, QV_PORTABLE) {
+- APPDIR = QuickViewer-$${VERSION}-$${TARGET_ARCH}.AppDir
+- APPIMAGE = QuickViewer-$${VERSION}-$${TARGET_ARCH}.AppImage
+- MY_DEFAULT_INSTALL = ../../$${APPDIR}
++ target.path = $${QV_BIN_PATH}
+
+- install_target.files = $${DESTDIR}/QuickViewer
+- install_target.path = $${QV_BIN_PATH}
+-
+- install_libs.files = $${DESTDIR}/../lib/libfileloader.so.1 $${DESTDIR}/../lib/lib7z.so
+- install_libs.path = $${QV_LIB_PATH}
++ install_desktop.files = $${PWD}/QuickViewer.desktop
++ install_desktop.path = $${QV_SHARED_PATH}/applications
+
++ install_mainicon.files = $${PWD}/../docs/quickviewer.png
++ install_mainicon.path = $${QV_SHARED_PATH}/icons/hicolor/512x512/apps
+
++ install_deploy_files.files = $${PWD}/../README.md
+ install_deploy_files.path = $${QV_SHARED_PATH}/QuickViewer
+- install_deploy_files.files = $${PWD}/../README.md $${PWD}/../LICENSE
+- install_deploy_files.depends = install_install_target install_install_libs
+
+- install_translations.path = $$[QT_INSTALL_TRANSLATIONS]
++ install_license.files = $${PWD}/../LICENSE
++ install_license.path = $${QV_SHARED_PATH}/licenses/quickviewer
++
++ install_translations.path = $${QV_SHARED_PATH}/QuickViewer/translations
+ install_translations.files = \
+ $${PWD}/translations/languages.ini \
+ $${PWD}/translations/quickviewer_ja.qm \
+@@ -462,7 +461,7 @@
+ ../AssociateFilesWithQuickViewer/icons/qv_tiff.ico \
+ ../AssociateFilesWithQuickViewer/icons/qv_webp.ico \
+
+- INSTALLS += install_target install_libs install_deploy_files install_translations install_assoc_icons
++ INSTALLS += target install_desktop install_mainicon install_deploy_files install_license install_translations install_assoc_icons
+ }
+
+ macos : !CONFIG(debug, debug|release) {