summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2019-05-22 21:33:45 -0400
committerJeremy Audet2019-05-22 21:39:20 -0400
commit3cd8fe25c9d25a05c7e78073aad5b41055d35d34 (patch)
treea71392c075029ced258237328dadaa3a9b994fa0
parent473b84c7086e7d40294cac1bc6c02c9c1255e3bf (diff)
downloadaur-3cd8fe25c9d25a05c7e78073aad5b41055d35d34.tar.gz
Simplify launch script
Drop references to firejail from launch script, and add a work-around for https://github.com/mono/mono/issues/11557. The result is a dramatically simpler one-line launch script.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gog-jotun26
3 files changed, 6 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 237a6688e13f..72941910f801 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = gog-jotun
source = gog-jotun
source = gog-jotun.desktop
source = file://jotun_20190430_29317.sh
- sha256sums = 15730c6bddfb776b8c9bbde0439b8ba67c783f2d94457b8965b9d3d22b6d03a8
+ sha256sums = 8a99b6c941c309af11a3d251280562d0729dad74667dabe5d654530aa9064410
sha256sums = c68e6416957174c6194b4d38d773b122a635a8e4579b69c995c8f2709cb77840
sha256sums = 0ca6c3941e0bec757c4b2306f1800fa7591b5305520025ab34646adbaf828912
diff --git a/PKGBUILD b/PKGBUILD
index dfd37611e701..fe9ffa5eebae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ source=(
"file://jotun_${pkgver}.sh"
)
sha256sums=(
- '15730c6bddfb776b8c9bbde0439b8ba67c783f2d94457b8965b9d3d22b6d03a8'
+ '8a99b6c941c309af11a3d251280562d0729dad74667dabe5d654530aa9064410'
'c68e6416957174c6194b4d38d773b122a635a8e4579b69c995c8f2709cb77840'
'0ca6c3941e0bec757c4b2306f1800fa7591b5305520025ab34646adbaf828912'
)
diff --git a/gog-jotun b/gog-jotun
index 9a9d9458b6d3..bf6bce8e0bcf 100644
--- a/gog-jotun
+++ b/gog-jotun
@@ -1,24 +1,6 @@
-#! /bin/bash
+#!/usr/bin/env bash
-pkgname='gog-jotun'
-pkgdir="/opt/${pkgname}/"
-run="${pkgdir}/start.sh"
+# https://github.com/mono/mono/issues/11557
+TERM=xterm /opt/gog-jotun/start.sh "${@}"
-if hash firejail; then
- echo "Firejail detected; attempting to enforce a sandbox..."
- if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
- echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
- echo "Enforcing a sandbox!"
- firejail "${run}"
- elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
- echo "Firejail profile for ${pkgname} found in /etc/firejail/"
- echo "Enforcing a sandbox!"
- firejail "${run}"
- else
- echo "No Firejail profile detected!"
- echo "Skipping Firejail sandbox..."
- "${run}"
- fi
-else
- "${run}"
-fi
+# vim: sw=2 ts=2 et: