summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-16 21:58:45 +0200
committerMichał Wojdyła2022-10-16 21:58:45 +0200
commit3cdb507d7ea893baa4fe905182b6c3e45247d1b1 (patch)
tree6ba58d5db352fb8f0d59fca5e68f157d9c57fcc4
parent47d06f0f51e245a79ee6bfbd397094a76f13d425 (diff)
downloadaur-3cdb507d7ea893baa4fe905182b6c3e45247d1b1.tar.gz
update dependencies, small packaging changes
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD77
2 files changed, 71 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37de755e25a6..c6f8bc9ee480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
pkgbase = 0ad-git
- pkgver = 26504
+ pkgdesc = Cross-platform, 3D and historically-based real-time strategy game - built from git development version.
+ pkgver = A26.r63.g43444ea887
pkgrel = 1
+ epoch = 1
url = http://play0ad.com/
arch = i686
arch = x86_64
@@ -10,9 +12,32 @@ pkgbase = 0ad-git
makedepends = cmake
makedepends = mesa
makedepends = zip
- makedepends = python2
makedepends = libsm
+ makedepends = rust
+ makedepends = python
+ makedepends = clang
makedepends = git
+ makedepends = enet
+ makedepends = fmt
+ makedepends = gloox
+ makedepends = glu
+ makedepends = libgl
+ makedepends = libminiupnpc.so
+ makedepends = libogg
+ makedepends = libpng
+ makedepends = libsodium
+ makedepends = libvorbis
+ makedepends = miniupnpc
+ makedepends = nspr
+ makedepends = openal
+ makedepends = sdl2
+ makedepends = wxwidgets-gtk3
+ options = !lto
+ source = git+https://github.com/0ad/0ad.git
+ md5sums = SKIP
+
+pkgname = 0ad-git
+ depends = 0ad-data-git
depends = binutils
depends = boost-libs
depends = curl
@@ -23,26 +48,22 @@ pkgbase = 0ad-git
depends = libxml2
depends = openal
depends = sdl2
- depends = wxgtk2
+ depends = wxwidgets-gtk3
depends = zlib
depends = libgl
depends = glu
+ depends = fmt
depends = gloox
depends = miniupnpc
+ depends = libminiupnpc.so
depends = icu
depends = nspr
- options = !strip
- source = git+https://github.com/0ad/0ad.git
- md5sums = SKIP
-
-pkgname = 0ad-git
- pkgdesc = Cross-platform, 3D and historically-based real-time strategy game — built from git development version. WARNING: you will need more than 42 GiB of disk space!
- depends = 0ad-data-git
+ depends = libsodium
provides = 0ad
conflicts = 0ad
pkgname = 0ad-data-git
- pkgdesc = Data package for 0ad built from git development version. WARNING: you will need more than 42 GiB of disk space!
+ pkgdesc = Data package for 0ad built from git development version.
depends = 0ad-git
provides = 0ad-data
conflicts = 0ad-data
diff --git a/PKGBUILD b/PKGBUILD
index 346756ecb1cc..031e95dfb1d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# $Id$
# Maintainer: tuxayo <victor (replace by @) tuxayo DOT net>
-# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
-# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
+# Contributor: Sven-Hendrik Haase <svenstaro@archlinux.org>
# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
-# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
+# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
-pkgver=26504
+epoch=1
+pkgver=A26.r63.g43444ea887
pkgrel=1
+pkgdesc="Cross-platform, 3D and historically-based real-time strategy game - built from git development version."
arch=('i686' 'x86_64')
url="http://play0ad.com/"
license=('GPL2' 'CCPL')
-depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
- 'libxml2' 'openal' 'sdl2' 'wxgtk2' 'zlib' 'libgl' 'glu'
- 'gloox' 'miniupnpc' 'icu' 'nspr')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'python2' 'libsm' 'git')
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python' 'clang' 'git'
+ 'enet' 'fmt' 'gloox' 'glu' 'libgl' 'libminiupnpc.so' 'libogg'
+ 'libpng' 'libsodium' 'libvorbis' 'miniupnpc' 'nspr' 'openal'
+ 'sdl2' 'wxwidgets-gtk3')
+options=('!lto') # breaks spidermonkey linking (https://bugs.gentoo.org/746947)
source=("git+https://github.com/0ad/0ad.git")
md5sums=('SKIP')
pkgver() {
- cd ${srcdir}/${_pkgname}
- git rev-list --count HEAD
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -30,60 +33,58 @@ prepare() {
build() {
cd "$srcdir/${_pkgname}/build/workspaces"
- unset CPPFLAGS # for le spidermonkey
- export SDL2_CONFIG="pkg-config sdl2"
-
./update-workspaces.sh \
+ --without-pch \
--bindir=/usr/bin \
--libdir=/usr/lib/0ad \
--datadir=/usr/share/${pkgname}/data
- cd "$srcdir/${_pkgname}/libraries/source/fcollada/src"
- make # always keep uncommented
- # OPTIONAL: uncomment for a debug build, it's a 2nd executable named
- # `pyrogenesis_dbg`
- # It's independent from the debug symbols and not as important as them.
- # https://trac.wildfiregames.com/wiki/Debugging#CallstackonLinuxmacOS
- # It's likely a small increase of build time.
- # And up to a 1.2 GiB in total used space. (inc. package build files)
- # Note there is something else to uncomment below in package_0ad-git()
- # make config=debug
+# cd "$srcdir/${_pkgname}/libraries/source/fcollada/src"
+# make # always keep uncommented
+# # OPTIONAL: uncomment for a debug build, it's a 2nd executable named
+# # `pyrogenesis_dbg`
+# # It's independent from the debug symbols and not as important as them.
+# # https://trac.wildfiregames.com/wiki/Debugging#CallstackonLinuxmacOS
+# # It's likely a small increase of build time.
+# # And up to a 1.2 GiB in total used space. (inc. package build files)
+# # Note there is something else to uncomment below in package_0ad-git()
+# # make config=debug
- cd "$srcdir/${_pkgname}/build/workspaces/gcc"
- make # always keep uncommented
+ cd gcc
+ VERBOSE=1 make # always keep uncommented
# OPTIONAL: uncomment for a debug build, see above
# make config=debug
}
package_0ad-git() {
- pkgdesc="Cross-platform, 3D and historically-based real-time strategy game — built from git development version."
+ depends=('0ad-data-git' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
+ 'libxml2' 'openal' 'sdl2' 'wxwidgets-gtk3' 'zlib' 'libgl' 'glu' 'fmt'
+ 'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium')
conflicts=('0ad')
- depends=('0ad-data-git')
provides=('0ad')
- install -d "${pkgdir}"/usr/{bin,lib/${_pkgname}}
+ install -d "${pkgdir}"/usr/{bin,lib/0ad,share/"${_pkgname}"/data}
cd "$srcdir/${_pkgname}"
install -Dm755 binaries/system/pyrogenesis "${pkgdir}/usr/bin"
# OPTIONAL: uncomment below for debug build. See the comments around the `make` calls
#install -Dm755 binaries/system/pyrogenesis_dbg "${pkgdir}/usr/bin"
- install -Dm755 binaries/system/*.so "${pkgdir}/usr/lib/${_pkgname}"
+ install -Dm755 binaries/system/*.so "${pkgdir}/usr/lib/0ad"
- install -Dm755 build/resources/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+ cp -r binaries/data/l10n/ "${pkgdir}/usr/share/${_pkgname}/data/"
- install -Dm644 build/resources/${_pkgname}.desktop \
- "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -Dm644 build/resources/${_pkgname}.png \
- "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ install -Dm755 build/resources/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 build/resources/${_pkgname}.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 build/resources/${_pkgname}.png "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
}
package_0ad-data-git() {
pkgdesc="Data package for 0ad built from git development version."
- conflicts=('0ad-data')
depends=('0ad-git')
+ conflicts=('0ad-data')
provides=('0ad-data')
-
mkdir -p ${pkgdir}/usr/share/${_pkgname}-git
- cp -r ${srcdir}/${_pkgname}/binaries/data ${pkgdir}/usr/share/${_pkgname}-git
+ cd "$srcdir/${_pkgname}"
+ cp -r "binaries/data" "${pkgdir}/usr/share/${_pkgname}-git"
}