summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-12 14:11:42 +0200
committerJ5lx2015-07-12 14:11:42 +0200
commit3cdca9e0f423380738f450c7c9e3350a0d5915d6 (patch)
tree57a512c1218067f16b5e7e4fb88d6cbed7f1d75d
downloadaur-3cdca9e0f423380738f450c7c9e3350a0d5915d6.tar.gz
112.35.00-1: Initial package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..626d4c09b67a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ocaml-pa_structural_sexp
+ pkgdesc = Industrial strength alternative to OCaml's standard library
+ pkgver = 112.35.00
+ pkgrel = 1
+ url = https://github.com/janestreet/core
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = camlp4
+ depends = ocaml-sexplib
+ depends = ocaml-type_conv
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/112.35/files/pa_structural_sexp-112.35.00.tar.gz
+ md5sums = b9d40e3a8586d6679c799d99cfabc596
+
+pkgname = ocaml-pa_structural_sexp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67b42db619a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-pa_structural_sexp
+pkgver=112.35.00
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="Industrial strength alternative to OCaml's standard library"
+url="https://github.com/janestreet/core"
+depends=('ocaml' 'camlp4' 'ocaml-sexplib' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('b9d40e3a8586d6679c799d99cfabc596')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
+}