summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruli2022-09-29 11:11:27 +0200
committeruli2022-09-29 11:11:27 +0200
commit3ce8e25b3db3b9de4a92dfac520a4d978e6f430c (patch)
tree88d41b3356b48a4ee53071ec6c329b6675c76a3d
parentfa8985060ff3913a539fce89424791cf52893ec0 (diff)
downloadaur-3ce8e25b3db3b9de4a92dfac520a4d978e6f430c.tar.gz
reworked for 6.2.0 and wx-3.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--opencpn.install15
-rw-r--r--wx_workaround.patch11
4 files changed, 36 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3057984ba733..5e6ee0d1d392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = opencpn
pkgdesc = Open Source Chart Plotting / Marine Navigation
- pkgver = 5.6.0
+ pkgver = 5.6.2
pkgrel = 1
url = http://opencpn.org
- install = opencpn.install
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
makedepends = lsb-release
depends = wxgtk3
- depends = gpsd
depends = portaudio
depends = tinyxml
- depends = hicolor-icon-theme
+ depends = libsndfile
+ depends = libarchive
+ depends = libexif
+ depends = glu
depends = webkit2gtk
- source = https://github.com/OpenCPN/OpenCPN/archive/Release_5.6.0.tar.gz
- sha1sums = 62b3ebdf373c76f00b7191a44e1b0576df872e55
+ optdepends = gpsd: GPS position support
+ source = https://github.com/OpenCPN/OpenCPN/archive/Release_5.6.2.tar.gz
+ source = wx_workaround.patch
+ b2sums = a45e19d293d63262f2bb6bd0bd5d18723cadd0b93af8e64484b55d246cebbe623dccbb6a1d257eccd74fb9111953d9cdd4b44d6f3fb38c3a9f40fa253718f337
+ b2sums = ac80978933a4893aa55b019547025e07e888b689378eba82322d1f36a8db5f64faf150c4084690d621e3d30e7fbbd5c94f47ec8582e6c1e174dcd60d7b79d176
pkgname = opencpn
diff --git a/PKGBUILD b/PKGBUILD
index cba34d33882e..7f26ef630f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,38 @@
-# Maintainer: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
-# Co-maintainer: Romain Bazile <gromain.baz@gmail.com>
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
# Contributor: Bruno Rodriguez (brunorro)
# Contributor: Øyvind 'Mr.Elendig' Heggstad <mrelendig at har-ikkje dot net>
# Contributor: Travis Fickett <tfickett AT ufl DOT edu>
# Submitter: Anders Lund <anders at alweb dot dk>
pkgname=opencpn
-_name="OpenCPN"
-pkgver=5.6.0
+pkgver=5.6.2
pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation"
arch=('x86_64' 'aarch64')
license=("GPL2")
-depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme' 'webkit2gtk')
+depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glu' 'webkit2gtk')
+optdepends=('gpsd: GPS position support')
makedepends=('cmake' 'lsb-release')
url="http://opencpn.org"
-install=opencpn.install
-source=("https://github.com/${_name}/${_name}/archive/Release_${pkgver}.tar.gz")
-sha1sums=('62b3ebdf373c76f00b7191a44e1b0576df872e55')
+source=("https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz" "wx_workaround.patch")
+b2sums=('a45e19d293d63262f2bb6bd0bd5d18723cadd0b93af8e64484b55d246cebbe623dccbb6a1d257eccd74fb9111953d9cdd4b44d6f3fb38c3a9f40fa253718f337' 'dee0d7d6a62d13e35211f3e1e47beb30fa61755852435f53d8a540a1f3fd61fb57661890ec99fb258c11b152887858347d1f64e664f4401a252e62d563a0b68c')
prepare() {
- cd "OpenCPN-Release_${pkgver}"
- export PATH="$PWD/bin:$PATH"
- mkdir -p bin
- ln -sf /usr/bin/wx-config-gtk3 bin/wx-config
+ cd OpenCPN-Release_${pkgver}
+ patch --strip=1 --input=../wx_workaround.patch
}
build() {
- cd "OpenCPN-Release_${pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DOCPN_FORCE_GTK3=ON
+ cd OpenCPN-Release_${pkgver}
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "OpenCPN-Release_${pkgver}"
+ cd OpenCPN-Release_${pkgver}/build
make DESTDIR="$pkgdir" install
}
diff --git a/opencpn.install b/opencpn.install
deleted file mode 100644
index 0a039b4dd254..000000000000
--- a/opencpn.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
diff --git a/wx_workaround.patch b/wx_workaround.patch
new file mode 100644
index 000000000000..007d4b5e1994
--- /dev/null
+++ b/wx_workaround.patch
@@ -0,0 +1,11 @@
+diff a/include/bbox.h b/include/bbox.h
+--- a/include/bbox.h
++++ b/include/bbox.h
+@@ -6,7 +6,9 @@
+ #include "wx/wx.h"
+ #endif
+
++#undef wxDEPRECATED_MSG
++#define wxDEPRECATED_MSG(param)
+ #include "wx/matrix.h"
+ #include "wx/geometry.h"