summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2016-07-05 04:17:20 +0300
committerIvan Shapovalov2016-07-05 04:17:50 +0300
commit3d2126784727b7fdc076eef03b96d38a6413e585 (patch)
treee1681bf3b4763e9251dd6f7769063c8b9aa9f167
downloadaur-3d2126784727b7fdc076eef03b96d38a6413e585.tar.gz
Initialize from community/toxcore.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD54
-rw-r--r--toxcore.conf2
-rw-r--r--toxcore.install11
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a0de4b417d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 01:17:08 UTC 2016
+pkgbase = toxcore-git
+ pkgdesc = Secure, configuration-free, P2P Skype replacement backend
+ pkgver = r3758.532629d
+ pkgrel = 1
+ url = https://tox.chat
+ install = toxcore.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = check
+ depends = systemd
+ depends = libconfig
+ depends = libsodium
+ depends = libvpx
+ depends = opus
+ provides = tox
+ provides = toxcore
+ conflicts = tox
+ conflicts = toxcore
+ backup = etc/tox-bootstrapd.conf
+ source = git+https://github.com/irungentoo/toxcore.git
+ source = toxcore.conf
+ sha512sums = SKIP
+ sha512sums = 71885e69f7b84955f6bdbf27b9e8196349cdd254b02b510433851bd218374d9c47aa7d3946dcc6a5cff6c8e705bc98d8a09de27039f60b8b088784cf8fa9d719
+
+pkgname = toxcore-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc4ca98c9c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
+# Contributor: naxuroqa <naxuroqa at gmail.com>
+# Contributor: Boohbah <boohbah at gmail.com>
+# Contributor: Kevin MacMartin <prurigro at gmail dot com>
+
+pkgname=toxcore-git
+_pkgname=toxcore
+pkgver=r3758.532629d
+pkgrel=1
+pkgdesc='Secure, configuration-free, P2P Skype replacement backend'
+arch=('i686' 'x86_64')
+url='https://tox.chat'
+license=('GPL3')
+depends=('systemd' 'libconfig' 'libsodium' 'libvpx' 'opus')
+makedepends=('git' 'check')
+conflicts=("tox" "toxcore")
+provides=("tox" "toxcore")
+backup=('etc/tox-bootstrapd.conf')
+install=$_pkgname.install
+source=("git+https://github.com/irungentoo/toxcore.git"
+ 'toxcore.conf')
+sha512sums=('SKIP'
+ '71885e69f7b84955f6bdbf27b9e8196349cdd254b02b510433851bd218374d9c47aa7d3946dcc6a5cff6c8e705bc98d8a09de27039f60b8b088784cf8fa9d719')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ sed -i "s|/usr/local|/usr|" other/bootstrap_daemon/tox-bootstrapd.service
+}
+
+build() {
+ cd $_pkgname
+ autoreconf -if
+ ./configure \
+ --prefix=/usr \
+ --enable-daemon \
+ --disable-ntox \
+ --enable-tests
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/toxcore.conf" "$pkgdir/usr/lib/sysusers.d/toxcore.conf"
+ install -Dm644 ./other/bootstrap_daemon/tox-bootstrapd.service "$pkgdir/usr/lib/systemd/system/tox-bootstrapd.service"
+ install -Dm644 ./other/bootstrap_daemon/tox-bootstrapd.conf "$pkgdir/etc/tox-bootstrapd.conf"
+}
diff --git a/toxcore.conf b/toxcore.conf
new file mode 100644
index 000000000000..42d040fff0fb
--- /dev/null
+++ b/toxcore.conf
@@ -0,0 +1,2 @@
+u tox-bootstrapd - "Tox bootstrapd"
+g tox-bootstrapd - \ No newline at end of file
diff --git a/toxcore.install b/toxcore.install
new file mode 100644
index 000000000000..f2ccedabb8f0
--- /dev/null
+++ b/toxcore.install
@@ -0,0 +1,11 @@
+post_install() {
+ systemd-sysusers toxcore.conf
+ [[ -d var/lib/tox-bootstrapd ]] || install -dm 750 -o tox-bootstrapd -g tox-bootstrapd var/lib/tox-bootstrapd
+}
+
+post_upgrade() {
+ (( $(vercmp $2 '3523-3') < 0 )) && (
+ systemd-sysusers toxcore.conf
+ [[ -d var/lib/tox-bootstrapd ]] || install -dm 750 -o tox-bootstrapd -g tox-bootstrapd var/lib/tox-bootstrapd
+ ) || true
+}