summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2023-12-04 20:46:44 +0100
committerIyán Méndez Veiga2023-12-04 20:46:44 +0100
commit3d511bc9576dc6e1f5a0e5d0b9a977a216b26338 (patch)
treea52abe615afd840e0d549e1a14a19939f38f23f9
parenta3a75fa53fec354ce6dd5b60662ca99f81446e84 (diff)
downloadaur-3d511bc9576dc6e1f5a0e5d0b9a977a216b26338.tar.gz
upgpkg: python-qiskit 1:0.45.1-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec9688952ca8..fb142fdc5331 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-qiskit
pkgdesc = An open-source SDK for working with quantum computers at the level of extended quantum circuits, operators, and primitives
- pkgver = 0.45.0
+ pkgver = 0.45.1
pkgrel = 1
epoch = 1
url = https://github.com/Qiskit/qiskit
@@ -43,7 +43,7 @@ pkgbase = python-qiskit
optdepends = python-tweedledum: synthesizing and manipulating quantum circuits
provides = python-qiskit-terra
conflicts = python-qiskit-terra
- source = qiskit-0.45.0.tar.gz::https://github.com/Qiskit/qiskit/archive/0.45.0.tar.gz
- b2sums = c18b8f6f8e365f3bae2df87db4f1f623a407bbeacfdb09c45a641187a683c25f2be6781c1637f2b94dbc7fde8080ff9b4007fed5e1ca62df5fbaabfb14cec593
+ source = qiskit-0.45.1.tar.gz::https://github.com/Qiskit/qiskit/archive/0.45.1.tar.gz
+ b2sums = fd5ac5e98dd3512e34309fb81dfcb97d10ef03db03ad9011fa5043f28e9f9019fa3bc8a8406252cc1623ca6d9841703e9353cda8b8af81fd2602294aceed5b6b
pkgname = python-qiskit
diff --git a/PKGBUILD b/PKGBUILD
index 3de05282a1f2..4f13c1200410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit
pkgname=python-${_pkgname}
-pkgver=0.45.0
+pkgver=0.45.1
pkgrel=1
epoch=1
pkgdesc="An open-source SDK for working with quantum computers at the level of extended quantum circuits, operators, and primitives"
@@ -51,16 +51,33 @@ makedepends=(
'python-setuptools-rust'
'python-wheel'
)
+#checkdepends=(
+# 'python-anyio'
+# 'python-ddt'
+# 'python-hypothesis'
+# 'python-pytest'
+# 'python-pytest-benchmark'
+# 'python-pytest-xdist'
+#)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-b2sums=('c18b8f6f8e365f3bae2df87db4f1f623a407bbeacfdb09c45a641187a683c25f2be6781c1637f2b94dbc7fde8080ff9b4007fed5e1ca62df5fbaabfb14cec593')
+b2sums=('fd5ac5e98dd3512e34309fb81dfcb97d10ef03db03ad9011fa5043f28e9f9019fa3bc8a8406252cc1623ca6d9841703e9353cda8b8af81fd2602294aceed5b6b')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
+#check() {
+# local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+# cd "${_pkgname}-${pkgver}"
+# python -m installer --destdir=test_dir dist/*.whl
+# # Delete qiskit folder so that the installed package is loaded and not the src
+# rm -rf qiskit
+# PYTHONPATH="test_dir/$_site_packages:$PYTHONPATH" pytest -v -k 'not test_examples' test/python
+#}
+
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}