summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheodoros Theodoridis2024-03-11 11:21:35 +0100
committerTheodoros Theodoridis2024-03-11 11:21:35 +0100
commit3d77f4a86bcd5f46e2c59f3d22a8deb435b73fdc (patch)
tree84af42185ef20976e3b3b9e9719285c9913d3000
parentcabfc88dc35397bdf460cb551d15f839c18a24a7 (diff)
downloadaur-3d77f4a86bcd5f46e2c59f3d22a8deb435b73fdc.tar.gz
Use github releases as the original source is down
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 940828bb177a..0545ea95ca7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Thu Sep 7 17:55:14 UTC 2017
pkgbase = csmith
pkgdesc = Tool for stress-testing compilers, static analyzers, and other tools that process C code
pkgver = 2.3.0
@@ -9,8 +7,7 @@ pkgbase = csmith
arch = x86_64
license = custom:BSD
depends = perl
- source = https://embed.cs.utah.edu/csmith/csmith-2.3.0.tar.gz
- sha256sums = f247cc0aede5f8a0746271b40a5092b5b5a2d034e5e8f7a836c879dde3fb65d5
+ source = https://github.com/csmith-project/csmith/archive/refs/tags/csmith-2.3.0.tar.gz
+ sha256sums = 9d024a6b202f6a1b9e01351218a85888c06b67b837fe4c6f8ef5bd522fae098c
pkgname = csmith
-
diff --git a/PKGBUILD b/PKGBUILD
index e1db1dce53e0..7d9ab867f045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: jerry73204 <jerry73204@gmail.com>
+# Maintainer: Kritias <theodoridisgr@gmail.com>
+# Previous Maintainer: jerry73204 <jerry73204@gmail.com>
# Previous maintainer: spider-mario <spidermario@free.fr>
pkgname=csmith
pkgver=2.3.0
@@ -8,22 +9,22 @@ arch=('i686' 'x86_64')
url='http://embed.cs.utah.edu/csmith/'
license=('custom:BSD')
depends=('perl')
-source=("https://embed.cs.utah.edu/csmith/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('f247cc0aede5f8a0746271b40a5092b5b5a2d034e5e8f7a836c879dde3fb65d5')
+source=("https://github.com/csmith-project/${pkgname}/archive/refs/tags/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9d024a6b202f6a1b9e01351218a85888c06b67b837fe4c6f8ef5bd522fae098c')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make -k check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
install --directory "${pkgdir}/usr/share/licenses/${pkgname}/"