summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-01-22 12:56:54 +0100
committerMartino Pilia2018-01-22 12:56:54 +0100
commit3d8394aef0dac72088f965e89c346d07594defa1 (patch)
tree81d3a892ddf69d7c4b707d90dba8b3e87be64c01
parent2d8a187d748703522d9be885a839b15a98efb5eb (diff)
downloadaur-3d8394aef0dac72088f965e89c346d07594defa1.tar.gz
use system Elastix, fix install_prefix and destdir
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d97d3b6a92..733d94507d0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = minc-toolkit-v2
pkgdesc = Medical Imaging NetCDF Toolkit
pkgver = 1.9.15
- pkgrel = 1
+ pkgrel = 2
url = https://www.mcgill.ca/bic/software/minc
arch = any
license = GPL3
@@ -23,6 +23,7 @@ pkgbase = minc-toolkit-v2
depends = hdf5
depends = nifticlib
depends = insight-toolkit
+ depends = elastix
provides = minc-toolkit
source = git+https://github.com/BIC-MNI/minc-toolkit-v2.git
source = FindNIFTI.patch
diff --git a/PKGBUILD b/PKGBUILD
index 178f0d45a990..820b647c089b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# PKBGUILD: Martino Pilia <martino.pilia@gmail.com>
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=minc-toolkit-v2
pkgver=1.9.15
-pkgrel=1
+pkgrel=2
pkgdesc="Medical Imaging NetCDF Toolkit"
arch=('any')
url="https://www.mcgill.ca/bic/software/minc"
license=('GPL3')
-depends=('perl' 'libjpeg-turbo' 'libxi' 'libxmu' 'libgl' 'glu' 'fftw' 'glut' 'netcdf' 'pcre' 'zlib' 'hdf5' 'nifticlib' 'insight-toolkit')
+depends=('perl' 'libjpeg-turbo' 'libxi' 'libxmu' 'libgl' 'glu' 'fftw' 'glut' 'netcdf' 'pcre' 'zlib' 'hdf5' 'nifticlib' 'insight-toolkit' 'elastix')
makedepends=('git' 'cmake' 'bc' 'libhdf5')
provides=('minc-toolkit')
source=('git+https://github.com/BIC-MNI/minc-toolkit-v2.git'
@@ -74,17 +74,18 @@ prepare() {
cmake .. \
-DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}${_install_prefix}" \
+ -DCMAKE_INSTALL_PREFIX:PATH="${_install_prefix}" \
-DMT_BUILD_ABC:BOOL=ON \
-DMT_BUILD_ANTS:BOOL=ON \
-DMT_BUILD_C3D:BOOL=ON \
- -DMT_BUILD_ELASTIX:BOOL=ON \
+ -DMT_BUILD_ELASTIX:BOOL=OFF \
-DMT_BUILD_IM:BOOL=OFF \
-DMT_BUILD_ITK_TOOLS:BOOL=ON \
-DMT_BUILD_LITE:BOOL=OFF \
-DMT_BUILD_SHARED_LIBS:BOOL=ON \
-DMT_BUILD_VISUAL_TOOLS:BOOL=ON \
-DMT_USE_OPENMP:BOOL=ON \
+ -DUSE_SYSTEM_ELASTIX:BOOL=ON \
-DUSE_SYSTEM_FFTW3D:BOOL=ON \
-DUSE_SYSTEM_FFTW3F:BOOL=ON \
-DUSE_SYSTEM_GLUT:BOOL=ON \
@@ -111,7 +112,7 @@ build() {
package() {
cd "$srcdir/$pkgname/build"
- make install
+ make install DESTDIR="${pkgdir}"
cd "${pkgdir}${_install_prefix}"
rm -rf minc-toolkit-config*