summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-05-26 21:31:28 -0300
committerDanilo J. S. Bellini2018-05-26 21:31:28 -0300
commit3d94020d5c4082ed7f9a20163ec452379c0be8fd (patch)
treeeba4e03e857467728e271aa0be04821afdae0954
parent44efa80521b63947a07a7574e94984b82f242ab6 (diff)
downloadaur-3d94020d5c4082ed7f9a20163ec452379c0be8fd.tar.gz
V1.0b1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85b12a680ca3..a22826d0dcaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,29 @@
pkgbase = python2-rasterio
pkgdesc = Fast and direct raster I/O for use with Numpy and SciPy (Python 2)
- pkgver = 1.0a8
+ pkgver = 1.0b1
pkgrel = 1
url = https://github.com/mapbox/rasterio
- arch = i686
arch = x86_64
license = BSD
+ makedepends = python2-setuptools
makedepends = cython2
depends = python2-affine
depends = python2-cligj
depends = python2-numpy
depends = python2-snuggs
+ depends = python2-attrs
depends = python2-click-plugins
depends = python2-enum34
depends = python2-setuptools
depends = gdal
+ optdepends = ipython2: Alternative inspector interpreter (rio insp --ipython)
+ optdepends = python2-boto3: AWS S3 raster access
+ optdepends = python2-matplotlib: plt object (rio insp), rasterio.plot module
options = !emptydirs
- source = https://github.com/mapbox/rasterio/archive/1.0a8.zip
- sha256sums = 65aa0cc9bda60c8d2401786101b029bbbfd1a2514133c9ed46cf5fa7e41b9167
+ source = https://files.pythonhosted.org/packages/d1/de/4a0e38dfb6c82304f8f5051babd7ca2603a35eb9805783044acece249565/rasterio-1.0b1.tar.gz
+ source = https://raw.githubusercontent.com/mapbox/rasterio/1.0b1/LICENSE.txt
+ sha256sums = 0bd8737952e99954d4e86b695cb944bf2b8f2a4d722d9bf4fe81ec5b1b5bd527
+ sha256sums = 1c4441fa02d6ced2ea5f3eab586b5aedb25b934ca6d61fce351c18569930b799
pkgname = python2-rasterio
diff --git a/PKGBUILD b/PKGBUILD
index 98b99f149896..085dbb7c619e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=rasterio
pkgname=('python2-rasterio')
-pkgver=1.0a8
+pkgver=1.0b1
pkgrel=1
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy (Python 2)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/mapbox/rasterio"
license=('BSD')
-makedepends=('cython2')
+makedepends=('python2-setuptools' 'cython2')
depends=('python2-affine' 'python2-cligj' 'python2-numpy' 'python2-snuggs'
+ 'python2-attrs'
'python2-click-plugins' 'python2-enum34' 'python2-setuptools' 'gdal')
+optdepends=('ipython2: Alternative inspector interpreter (rio insp --ipython)'
+ 'python2-boto3: AWS S3 raster access'
+ 'python2-matplotlib: plt object (rio insp), rasterio.plot module')
options=(!emptydirs)
-source=("$url/archive/$pkgver.zip")
-sha256sums=('65aa0cc9bda60c8d2401786101b029bbbfd1a2514133c9ed46cf5fa7e41b9167')
+sha256sums=('0bd8737952e99954d4e86b695cb944bf2b8f2a4d722d9bf4fe81ec5b1b5bd527'
+ '1c4441fa02d6ced2ea5f3eab586b5aedb25b934ca6d61fce351c18569930b799')
+_pypi='https://files.pythonhosted.org/packages'
+_path='d1/de/4a0e38dfb6c82304f8f5051babd7ca2603a35eb9805783044acece249565'
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/mapbox/$_name/$pkgver/LICENSE.txt")
build() {
cd "$srcdir/rasterio-$pkgver"
@@ -21,5 +30,6 @@ build() {
package() {
cd "$srcdir/rasterio-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 ../LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}