summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTodd E Johnson2021-02-18 17:49:30 -0600
committerTodd E Johnson2021-02-18 17:49:30 -0600
commit3d946ab6b14e82f22f59a4dd263051627978759e (patch)
treed8077ccd508b481110f7b99471b45e20af5805dc
downloadaur-3d946ab6b14e82f22f59a4dd263051627978759e.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
-rw-r--r--trunk-recorder.service14
-rw-r--r--trunk-recorder.sysusers1
-rw-r--r--trunk-recorder.tmpfiles2
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fec8fe90abe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = trunk-recorder
+ pkgdesc = Records calls from a Trunked Radio System (P25 & SmartNet)
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = https://github.com/robotastic/trunk-recorder
+ arch = x86_64
+ arch = i686
+ arch = armv5
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ makedepends = boost
+ makedepends = cppunit
+ depends = gnuradio
+ depends = gnuradio-osmosdr
+ depends = libuhd
+ source = https://github.com/robotastic/trunk-recorder/archive/v3.1.4.tar.gz
+ source = trunk-recorder.service
+ source = trunk-recorder.sysusers
+ source = trunk-recorder.tmpfiles
+ sha256sums = 49023ee69301b3344993eb92b910cd253442d0ef41d5c70a84dfa5d7551df605
+ sha256sums = 413f2090a853422b8987bdb4dfa6cbcf7d5b75dbdb1989d030e7c19d3e9dfb9b
+ sha256sums = f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8
+ sha256sums = c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8
+
+pkgname = trunk-recorder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..716518e597f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Todd E Johnson <todd@toddejohnson.net>
+pkgname=trunk-recorder
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
+arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
+url="https://github.com/robotastic/trunk-recorder"
+license=("GPL3")
+depends=("gnuradio" "gnuradio-osmosdr" "libuhd")
+makedepends=("cmake" "boost" "cppunit")
+optdepends=()
+source=("https://github.com/robotastic/trunk-recorder/archive/v${pkgver}.tar.gz"
+ 'trunk-recorder.service'
+ 'trunk-recorder.sysusers'
+ 'trunk-recorder.tmpfiles')
+sha256sums=('49023ee69301b3344993eb92b910cd253442d0ef41d5c70a84dfa5d7551df605'
+ '413f2090a853422b8987bdb4dfa6cbcf7d5b75dbdb1989d030e7c19d3e9dfb9b'
+ 'f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8'
+ 'c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8')
+
+prepare() {
+ rm -rf build
+ mkdir build
+}
+build() {
+ cd build
+ cmake "../${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ #DESTDIR="$pkgdir" make install
+ install -D -m 755 "recorder" "$pkgdir/usr/bin/recorder"
+ install -D -m 755 "lib/op25_repeater/lib/libgnuradio-op25_repeater.so" "$pkgdir/usr/lib/libgnuradio-op25_repeater.so"
+ install -D -m644 "../${pkgname}-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+ install -D -m644 "../$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -D -m644 "../$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -D -m644 "../$pkgname.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+}
+
diff --git a/trunk-recorder.service b/trunk-recorder.service
new file mode 100644
index 000000000000..e04352be077b
--- /dev/null
+++ b/trunk-recorder.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Trunk-Recorder
+
+[Service]
+User=trunk-recorder
+Group=trunk-recorder
+Environment=LC_ALL=en_US.utf8
+WorkingDirectory=/var/lib/trunk-recorder
+ExecStart=/usr/bin/recorder --config /etc/trunk-recorder.json
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/trunk-recorder.sysusers b/trunk-recorder.sysusers
new file mode 100644
index 000000000000..ba86c2753766
--- /dev/null
+++ b/trunk-recorder.sysusers
@@ -0,0 +1 @@
+u trunk-recorder - "Trunk Recorder daemon" /var/lib/trunk-recorder
diff --git a/trunk-recorder.tmpfiles b/trunk-recorder.tmpfiles
new file mode 100644
index 000000000000..e9cc556f638b
--- /dev/null
+++ b/trunk-recorder.tmpfiles
@@ -0,0 +1,2 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/trunk-recorder 0755 trunk-recorder trunk-recorder