summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2022-03-14 19:15:03 +0100
committerMatthias Lisin2022-03-14 19:15:03 +0100
commit3d9bc69ff075181e23282c59fe40e8abcafb7a0d (patch)
treede89feeb047d1078cfeeebb8a1edd49877ca6dde
parent3e1827d0f655b96795710b8c1a0476b23abf37a9 (diff)
downloadaur-3d9bc69ff075181e23282c59fe40e8abcafb7a0d.tar.gz
updpkg: vt-cli 0.10.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74c296b10422..8ea821b81eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vt-cli
pkgdesc = VirusTotal Command Line Interface
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://virustotal.github.io/vt-cli/
arch = i686
@@ -8,7 +8,7 @@ pkgbase = vt-cli
license = Apache
makedepends = go
depends = glibc
- source = https://github.com/VirusTotal/vt-cli/archive/0.10.0/vt-cli-0.10.0.tar.gz
- sha256sums = 88ef4d2c7708be1bc27c2290181996b6c18e08d5f56a8765de8a5ec13f68e6ac
+ source = https://github.com/VirusTotal/vt-cli/archive/0.10.1/vt-cli-0.10.1.tar.gz
+ sha256sums = b9004ebdd7a66eff15d160fe795b7f3c5577af7c316f896e7e05418e89c3792c
pkgname = vt-cli
diff --git a/PKGBUILD b/PKGBUILD
index b0a51e5d7fc8..7f0e7d0cb13f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <>
pkgname=vt-cli
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
pkgdesc='VirusTotal Command Line Interface'
arch=('i686' 'x86_64')
@@ -8,32 +8,32 @@ url=https://virustotal.github.io/vt-cli/
license=('Apache')
depends=('glibc')
makedepends=('go')
-source=("https://github.com/VirusTotal/vt-cli/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('88ef4d2c7708be1bc27c2290181996b6c18e08d5f56a8765de8a5ec13f68e6ac')
+source=("https://github.com/VirusTotal/vt-cli/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('b9004ebdd7a66eff15d160fe795b7f3c5577af7c316f896e7e05418e89c3792c')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
export GOFLAGS='-buildmode=pie -trimpath -modcacherw'
- go build -o build/vt -ldflags "-linkmode=external -X github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}" ./vt
+ go build -o build/vt -ldflags "-linkmode=external -X github.com/VirusTotal/vt-cli/cmd.Version=$pkgver" ./vt
build/vt completion bash >vt.bash
build/vt completion zsh >vt.zsh
}
check() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
# yaml_test.go broken. fails upstream as well
- go test -short ./utils/...
+ go test -ldflags "-linkmode=external" -short ./utils/...
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 build/vt -t "${pkgdir}/usr/bin"
- install -Dm644 vt.bash "${pkgdir}/usr/share/bash-completion/completions/vt"
- install -Dm644 vt.zsh "${pkgdir}/usr/share/zsh/site-functions/_vt"
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" doc/*
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/vt -t "$pkgdir/usr/bin"
+ install -Dm644 vt.bash "$pkgdir/usr/share/bash-completion/completions/vt"
+ install -Dm644 vt.zsh "$pkgdir/usr/share/zsh/site-functions/_vt"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" doc/*
}